VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: troubles with an old CD-ROM unit during install, vector linux solved it with usb  (Read 1101 times)

jagnje

  • Member
  • *
  • Posts: 2

Hello, VL community. This post is just to inform about a feature that it was immensely helpful to a linux newbie.

I had to install some linux on an pretty old compaq laptop. The laptop has a seemingly working CD-ROM unit, which boots iso perfectly, but later on installer (not just VL, any other distro I tried) doesn't recognize setup cd/dvd anymore. With other installers it was game over (not really suprising, because obviously the cd-rom is not completely dead...), but when VL doesnt succeed with mount it is giving option to run setup also from iso (same as was burnt to cd), which is copied to a normal usb flash. I know that USBs can be made bootable, but this old computer doesnt seem to have this possibility.

I do not know why this feature is present in VL setup and I am quite sure there are some other alternatives to install system (install from hard drive or network) but for my unique circumstance it was very helpful.  ;)
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4083

VL does have some unusual options for installing, for these kinds of situations and for the convenience of advanced users.  ;D

Most likely the CD-ROM on the Compaq is a proprietary system that is not supported in the kernel. It will go through standard routines for initial boot, but requires extra drivers to go beyond that point. I have an old external floppy drive that does this.
Logged