VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: SoundBlaster Live! 24-bit not working in Mozilla Firefox.  (Read 1098 times)

Locator

  • Vectorian
  • ****
  • Posts: 778
SoundBlaster Live! 24-bit not working in Mozilla Firefox.
« on: May 06, 2014, 09:25:00 pm »

It works with UMPlayer without any problem, but not in Firefox :(. Any practical suggestions to resolve that problem will be greatly appreciated.
Logged

overthere

  • Vectorian
  • ****
  • Posts: 1364
Re: SoundBlaster Live! 24-bit not working in Mozilla Firefox.
« Reply #1 on: May 07, 2014, 12:10:26 am »

It may be as simple as opening alsamixer and unmuting/increasing pcm volume

could be you need to reinstall or update flash

could be that you added an extension that causes a conflict

could be that your board has made the card something other than a pcm device or a mapping issue in which case you may have to send a command line option to the kernal ie: snd-hda-intel.index=1,0
reading here bottom
http://wiki.gentoo.org/wiki/ALSA#HTML5_does_not_play_in_firefox_browser

perhaps of interest also eternal_newbie's post
http://www.linuxquestions.org/questions/slackware-14/no-sound-with-flash-player-in-firefox-after-adding-nvidia-gt-220-graphics-card-809773/
« Last Edit: May 07, 2014, 12:15:31 am by overthere »
Logged
Everything Is Relative

wigums

  • Packager
  • Packager
  • Vectorite
  • ****
  • Posts: 209
Re: SoundBlaster Live! 24-bit not working in Mozilla Firefox.
« Reply #2 on: May 07, 2014, 08:49:23 am »

what version of vector linux are you using?
Logged
When the people fear their government, there is tyranny; when the government fears the people, there is liberty.

Locator

  • Vectorian
  • ****
  • Posts: 778
Re: SoundBlaster Live! 24-bit not working in Mozilla Firefox.
« Reply #3 on: May 09, 2014, 06:46:02 pm »

7.0
Logged

Locator

  • Vectorian
  • ****
  • Posts: 778
Re: SoundBlaster Live! 24-bit not working in Mozilla Firefox.
« Reply #4 on: July 17, 2014, 12:43:14 pm »

This is an update to what I posted back in May:

I have started using VLocity64 (7.0.1), and at first I had trouble getting Alsa to install at startup. I solved that by disabling my motherboard's built-in sound system (it turned out that VLocity64 doesn't like it for whatever reason) and I installed a third-party sound card instead (Soundblaster Live 24-bit) which works as described back in May, and yes, I read through the post by overthere, which brings up the following question - Is there a way to configure Alsa, and if so, how do I go about it?

And what would be the Vector Linux equivalent of the information found in the following link - http://wiki.gentoo.org/wiki/ALSA#HTML5_does_not_play_in_firefox_browser ?
« Last Edit: July 17, 2014, 07:47:22 pm by Locator »
Logged