Author Topic: VL-7.1-LIGHT  (Read 47735 times)

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4461
Re: VL-7.1-LIGHT
« Reply #75 on: June 21, 2015, 06:08:52 am »
The repos still need some work before we can go final.

Installing a package without dependencies often leaves it non-functional. To obtain the deps for pavucontrol you need to enable the "untested" repo.  (http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/x86/ for 32-bit). That will pull in gtkmm plus a few other packages.

Where did you get Skype from, and what type of installer?

sledgehammer

  • Vectorian
  • ****
  • Posts: 1527
Re: VL-7.1-LIGHT
« Reply #76 on: June 21, 2015, 07:51:41 am »
I removed skype from my system as soon as Gates bought it.  We need to stand up to these monopolists whenever possible.  There are alternatives.
VL7.0 xfce4 Samsung RF511

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #77 on: June 21, 2015, 09:13:17 pm »
The repos still need some work before we can go final.

Installing a package without dependencies often leaves it non-functional. To obtain the deps for pavucontrol you need to enable the "untested" repo.  (http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/x86/ for 32-bit). That will pull in gtkmm plus a few other packages.

Where did you get Skype from, and what type of installer?

http://slackbuilds.org/repository/14.1/network/skype/

Will check on gtkmm later

« Last Edit: June 21, 2015, 09:17:58 pm by Pita »

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #78 on: June 21, 2015, 09:15:22 pm »
I removed skype from my system as soon as Gates bought it.  We need to stand up to these monopolists whenever possible.  There are alternatives.

I fully agree! Unfortunately my contacts are Windows blokes. Hard to change.

And how about those using skype with their cellphone or iphone?
« Last Edit: June 23, 2015, 01:22:10 am by Pita »

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4461
Re: VL-7.1-LIGHT
« Reply #79 on: June 22, 2015, 05:07:43 am »
This really belongs in a different topic, and opens up several cans of worms. A few thoughts:
- Best approach would be to make a request for Skype in the "New package requests" area.
Otherwise, working with what you have:
- Enable the untested repo and re-install pavucontrol. It will pull in 7 other pkgs as deps.
- Read the notes that come with that slackbuild: http://slackbuilds.org/slackbuilds/14.1/network/skype/README.SLACKWARE
- You may try to use the "Dynamic" package on the Skype download page.

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1475
Re: VL-7.1-LIGHT
« Reply #80 on: June 22, 2015, 05:20:44 am »
Unfortunately, Skype under Linux is notoriously buggy and unstable, even for those distros that are more mainstream and provide Skype in their distribution repos.
ASUS K73 Intel i3 Dual Core 2.3GHz

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4461
Re: VL-7.1-LIGHT
« Reply #81 on: June 22, 2015, 02:12:22 pm »
I got skype working on Light.  ;D

First, I installed pavucontrol+deps from untested repo.
Next, I downloaded the "dynamic" version from skype.com,
extracted it (as root) to /opt with "tar xvf skype-4.3.0.37.tar.bz2 -C /opt"
Then run "/opt/skype-4.3.0.37/skype" (as user).

Had to fiddle with pavucontrol to find the correct settings, but finally made a successful test call.

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #82 on: June 23, 2015, 01:20:13 am »
I got skype working on Light.  ;D

First, I installed pavucontrol+deps from untested repo.
Next, I downloaded the "dynamic" version from skype.com,
extracted it (as root) to /opt with "tar xvf skype-4.3.0.37.tar.bz2 -C /opt"
Then run "/opt/skype-4.3.0.37/skype" (as user).

Had to fiddle with pavucontrol to find the correct settings, but finally made a successful test call.

Got mine working as well.  :)
However, the skype from the site I mentioned before.
5 libraries had to be installed from untested repo.
« Last Edit: June 23, 2015, 01:25:29 am by Pita »

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4461
Re: VL-7.1-LIGHT
« Reply #83 on: July 20, 2015, 07:32:09 am »
Almost there, guys. I have the final iso's ready here:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT.iso
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT.iso

All testers are encouraged to give this one a try. If none of you find any show stoppers, we'll release it to the general public the way it is.

Happy hacking!   ;D

Lyn

  • Vectorian
  • ****
  • Posts: 698
Re: VL-7.1-LIGHT
« Reply #84 on: July 21, 2015, 04:06:43 am »
Will test over the weekend :-)

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #85 on: July 22, 2015, 12:36:33 am »
32 bit

Bloody fast!

Sylpheed will not open when clicked from menu, either desktop or panel.
Does open with command from terminal and working properly.


roarde

  • Vectorian
  • ****
  • Posts: 782
  • it's enough
Re: VL-7.1-LIGHT
« Reply #86 on: July 22, 2015, 01:59:00 pm »
Light 7.1 is even more compatible with STD and the repos than was 7.0. A fix applied to the ISO dated 18 July would have caused problems for STD users if that updated package were moved to the stable repos. This was a "show stopper", as nightflier termed it. Light worked fine (with you in a moment, Pita), but needed to be changed so Light and STD would continue to cooperate seamlessly.

There's a new final ISO, dated 22 July. If there's anyone who'd like to check it out and hasn't tried yet, download that one. Those who have the "old" one have the option of using delta files to decrease the total size of downloads:

This is written for a 32-bit machine; those using the 64-bit version should substitute 'VL64-' where I say 'VL-'.

I repeat: If bandwidth is no problem for you, just downloading the present ISO is easier, and you can skip the rest.

Change to the directory where VL-7.1-LIGHT.iso is stored. Download the delta files to that directory.
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHTtoRC3.3.delta
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT-RC3.3to_release_.delta
64-bit:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHTtoRC3.3.delta
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT-RC3.3to_release_.delta

If you already have VL-7.1-LIGHT.iso.md5sum.txt, rename or delete it and get the new sum
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT.iso.md5sum.txt
64:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT.iso.md5sum.txt

Generate the first new ISO
Code: [Select]
xdelta patch VL-7.1-LIGHTtoRC3.3.deltaxdelta has little, or usually nothing, to say. On a slower machine, go get a cup of coffee.

Code: [Select]
echo $?Should say "0"; this is an extra check before going further.

Now rename, move, or delete VL-7.1-LIGHT.iso. The next step creates a new one.
Code: [Select]
xdelta patch VL-7.1-LIGHT-RC3.3to_release_.delta    # and wait
md5sum -c VL-7.1-LIGHT.iso.md5sum.txt

@Pita
Thanks for reporting your problem with Sylpheed startup. No one has been able to duplicate it. If you can, please try the new ISO.
Robert

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #87 on: July 22, 2015, 08:08:33 pm »
Installed Jul. 22 version.

Sylpheed still not opening from menus opens only from terminal command.

Copied /usr/share/applications/sylpheed.desktp to ~/Desktop/
Chown to user:user
Clicking on desktop icon sylpheed will not open. Trying execute, same no dice.

Next:
:$ qupzilla
qupzilla: /usr/lib/libcrypto.so.1: no version information available (required by /usr/lib/libQupZilla.so.1)
qupzilla: symbol lookup error: qupzilla: undefined symbol: _ZN2Qz7VERSIONE

Tried to open all programs on menu only sylpheed will not open and qupzilla.

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #88 on: July 22, 2015, 11:53:54 pm »
Got sylpheed working with clicking from menus or desktop icon.  ;D

How? Copied from my working box ~/Desktop/sylpheed.desktop to VL-Light ~/Desktop/  ???
Both look the same.

Pita

  • Vectorian
  • ****
  • Posts: 1349
Re: VL-7.1-LIGHT
« Reply #89 on: July 23, 2015, 12:27:55 am »
Made an upgrade via gslapt.

Qupzilla now working  :D from menus.