VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2] 3 4 5

Author Topic: VL-7.1-LIGHT  (Read 8309 times)

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #15 on: May 20, 2014, 01:39:13 am »

http://slackbuilds.org/repository/13.37/system/xcdroast/

That one built and installed, but throws an error about the permissions of /usr/bin/cdrecord. If you have your copy running on 7.1, did you do anything in particular to make it work?

I got the same error.
/usr/bin/cdrecord is a synlink to /usr/bin/wodim.
I copied cdrecord from Salix over to Light and xcdroast started. In Salix
cdrecord is not a symlink.
Logged

roarde

  • Vectorian
  • ****
  • Posts: 589
  • move the needle
Re: VL-7.1-LIGHT
« Reply #16 on: May 20, 2014, 03:22:26 pm »

Cdrtools is a beast to re-initiate into the package system due mainly to the maintainer's eccentricities. On the flip side, those same eccentricities make it pretty simple to maintain and keep once it's back in there.

But didn't I see something in xcdroast source notes about cdrecord, etc. being included somewhere in xcdroast's own libs, and copyable to system path? Was a really cursory skimming so I could easily be wrong; but maybe worth a look.
Logged
Robert
VL Light RC 1.9

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #17 on: May 22, 2014, 01:17:06 am »

I am still struggling to send mail with claws-mail or for that matter sylpheed.

with clwas-mal I get:
Code: [Select]
** (claws-mail:12250): WARNING **: getaddrinfo for smtp.smartbro.net:25 failed: No address associated with hostname

** (claws-mail:12250): WARNING **: [16:28:24] smtp.smartbro.net:25: host lookup failed (No address associated with hostname).

** (claws-mail:12243): WARNING **: DNS lookup failed

** (claws-mail:12243): WARNING **: [16:28:24] smtp.smartbro.net:25: unknown host.

** (claws-mail:12243): WARNING **: can't connect to server.

sylpheed just says: session timed out

I have never before experienced this in any distro. ???
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: VL-7.1-LIGHT
« Reply #18 on: May 22, 2014, 03:33:16 am »

Code: [Select]
** (claws-mail:12243): WARNING **: DNS lookup failed

What is the content of your "/etc/resolv.conf" file?
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #19 on: May 22, 2014, 04:03:03 am »

Code: [Select]
cat /etc/resolv.conf
# Generated by dhcpcd from eth0
# /etc/resolv.conf.head can replace this line
domain smartbro.net
nameserver 121.1.3.81
nameserver 121.1.3.16
nameserver 121.1.3.66
# /etc/resolv.conf.tail can replace this line

That has not changed for ages. ;)
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: VL-7.1-LIGHT
« Reply #20 on: May 22, 2014, 04:09:00 am »

Try replacing "121.1.3.81" with "8.8.8.8" and test again.
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #21 on: May 22, 2014, 04:12:45 am »

Try replacing "121.1.3.81" with "8.8.8.8" and test again.

Will do tomorrow. I am on my  night cap. ;)
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #22 on: May 22, 2014, 07:56:31 pm »

Try replacing "121.1.3.81" with "8.8.8.8" and test again.

Works!  :D
So I don't understand why.  ???
What would be the explanation and can that be corrected in future?
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: VL-7.1-LIGHT
« Reply #23 on: May 23, 2014, 03:10:46 am »

Glad it's working for you.  :)

Your ISP's DNS server is slow to respond. DNS is like the phone book for the internet, your computer asks it where to find smartbro.net, then makes that connection. Probably, Sylpheed does not try enough pings, and/or doesn't wait long enough to get an answer, so it gives up. The time it waits before giving up can be adjusted in the preferences.

Google offers free DNS services on 8.8.8.8 and 8.8.4.4, and so does OpenDNS at 208.67.222.222 and 208.67.220.220. I have found these servers to be better than what my ISP delivers, and use them all the time. You can configure your network manager to do this.

Another "trick" is to check for incoming mail right before sending, as this can create a connection to the server that stays alive long enough to send.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: VL-7.1-LIGHT
« Reply #24 on: May 24, 2014, 06:51:53 am »

Light A0.2 is available. Known issues: Shutdown/Reboot menu does not work. Netsurf is missing deps. Solve these by enabling untested repo, then re-install sudo and netsurf.
Logged

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1299
Re: VL-7.1-LIGHT
« Reply #25 on: May 24, 2014, 09:05:17 am »

Google offers free DNS services on 8.8.8.8 and 8.8.4.4, and so does OpenDNS at 208.67.222.222 and 208.67.220.220. I have found these servers to be better than what my ISP delivers, and use them all the time.

Careful with the OpenDNS entries. I tend to block those at the firewall as do many other admins I know. If I recall correctly, Config Server Firewall (csf) has OpenDNS blocked as default.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: VL-7.1-LIGHT
« Reply #26 on: May 24, 2014, 09:41:01 am »

Why would you want to block OpenDNS?
Logged

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1299
Re: VL-7.1-LIGHT
« Reply #27 on: May 24, 2014, 10:12:23 am »

Same reason I block TOR.  :P
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #28 on: May 25, 2014, 07:43:38 pm »

Light A0.2 is available. Known issues: Shutdown/Reboot menu does not work. Netsurf is missing deps. Solve these by enabling untested repo, then re-install sudo and netsurf.

Can't install. :(

Installation hangs on installing python-2.7.6-* both with GUI and TUI.
Burned a DVD twice, no change. When python starts the install bar
jumps all the way to the end and installation stops.
md5sum of iso file OK.

Edit:
Now used unetbootin and installation run smoothly from USB stick. :D
« Last Edit: May 25, 2014, 08:42:53 pm by Pita »
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1326
Re: VL-7.1-LIGHT
« Reply #29 on: May 25, 2014, 11:49:04 pm »

$ netsurf
netsurf: error while loading shared libraries: libnsbmp.so.0: cannot open shared object file: No such file or directory
vector:/~
$ sylpheed
sylpheed: error while loading shared libraries: libcompface.so.1: cannot open shared object file: No such file or directory
vector:/~
$ brasero
brasero: error while loading shared libraries: libtdb.so.1: cannot open shared object file: No such file or directory

ldd /usr/bin/netsurf| grep found
   libnsbmp.so.0 => not found
   libnsgif.so.0 => not found
   libwebp.so.4 => not found
   libcss.so.0 => not found
   libparserutils.so.0 => not found
   libwapcaplet.so.0 => not found
   libdom.so.0 => not found
   libhubbub.so.0 => not found

pnmixer Error
Could not bind the following hotkeys:
 XF86AudioMute
 XF86AudioRaiseVolume
 XF86AudioLowerVolume
« Last Edit: May 25, 2014, 11:53:46 pm by Pita »
Logged
Pages: 1 [2] 3 4 5