VectorLinux
October 20, 2014, 10:36:48 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: problem using ati driver after kernel upgrade  (Read 1064 times)
Banjer
Member
*
Posts: 16


« on: June 10, 2014, 09:11:42 am »

Hi
I try to search on the forum but I did not find the problem I am dealing with.
After see a video on youtube on how to install new kernel, I went to install new ati driver as suggested in the video.
Everything seems to be ok until this window appeared to me, see the attachement

Now what could I do to solve this probelm, in some post I found , they suggested to force the installation, but I would like to make a correct installation. The log file mentioned in the screenshot say this
Quote
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers.  /lib/modules/3.12.16/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

Is it  possible to resolve this problem??

thanks
Banjer

Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3184



« Reply #1 on: June 10, 2014, 09:39:04 am »

Anytime you install a kernel, you should install the kernel-modules and kernel-src packages, the latter especially if you have to re-build drivers for things like your graphics or network cards.

After you install the kernel-modules and kernel-src packages for the kernel you installed, you should be able to run the ati installer again.
Logged

Banjer
Member
*
Posts: 16


« Reply #2 on: June 10, 2014, 09:48:52 am »

But as this video said I install all 3 file of the kernel in only one time.
http://youtu.be/wdcMhFYkkp0

Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3184



« Reply #3 on: June 10, 2014, 11:04:32 am »

That's what I said... install the kernel, kernel-src, and kernel-modules pkgs
Logged

Banjer
Member
*
Posts: 16


« Reply #4 on: June 10, 2014, 12:35:52 pm »

Sorry maybe my english is not so good, but I made all the passage the video said and everything have been installed, however I made again the installation of the single pkg one by one and nothing has changed yet
The only strange thing that happened when I reboot the system is this  udev cold not find a module named rtc_cmos.... but after several seconds the system start normally. What does it means "could not find rtc_cmos"?

but above all why the installation of ati driver do not work???
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3184



« Reply #5 on: June 10, 2014, 12:44:04 pm »

post your /usr/share/ati/fglrx-install.log to a pastebin and give us the link... maybe it gives us a better idea of what it wants.
Logged

Banjer
Member
*
Posts: 16


« Reply #6 on: June 10, 2014, 12:56:22 pm »

You can see the fglrx-install.log file in the first message of this thread..I quoted  ..
however I don't know pastebin so ...let's try to learn a new thing 

http://pastebin.com/vh9Wd2HF

I hope I did the right thing!!
Logged
Banjer
Member
*
Posts: 16


« Reply #7 on: June 11, 2014, 06:44:13 am »

After several attempts I decided to install vector linux 7.1 rc and try to see if I will be able to install the amd ati drivers, maybe this release with  the kernel I used to upgrade yestarday has all what I need.

Let's see what happen!!

Logged
Banjer
Member
*
Posts: 16


« Reply #8 on: June 11, 2014, 08:20:38 am »

Ok I just finished to install vector linux 7.1 and try to install amd driver for my ati radeon serie 4*** but nothing has changed the message is always the same!!

Quote
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers.  /lib/modules/3.12.16/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

I notice this strange message at startup :
http://www.davidenaccarati.it/img/foto_l.JPG
any advice?
« Last Edit: June 11, 2014, 08:42:37 am by Banjer » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #9 on: June 11, 2014, 10:46:06 am »

Those errors indicate that the kernel source package is not installed, which is the default.

Looks like you're running 7.1 32-bit (verify by command "cat /etc/vector-version").
Download this file: http://vectorlinux.osuosl.org/veclinux-7.1/kernels/3.12.16-1vl71/kernel-src-3.12.16-x86-1vl71.txz
then install it, using the root account, with the "installpkg" command.

There is also a package for the AMD driver:
http://vectorlinux.osuosl.org/veclinux-7.1/kernels/3.12.16-1vl71/amd-catalyst-driver-13.251_3.12.16-x86-1vl71.txz
Logged
Banjer
Member
*
Posts: 16


« Reply #10 on: June 11, 2014, 11:06:20 am »

I am going to try!! Cross the fingers (I don't if in english it has the same meaning)
Logged
Banjer
Member
*
Posts: 16


« Reply #11 on: June 11, 2014, 11:13:47 am »

I have verify and the version is : 7.1 STD RC1 built on Apr-03-2014
I am downloading the file you link me
Logged
Banjer
Member
*
Posts: 16


« Reply #12 on: June 11, 2014, 11:25:24 am »

I installed the the kernel but when I try to install ati driver it gave me this:

Quote
root:# installpkg amd-catalyst-driver-13.251_3.12.16-x86-1vl71.txz

.-----.-----------------------------------------------------------------------.
| 1/1 | Installing amd-catalyst-driver-13.251_3.12.16-x86-1vl71.txz           |
'-----'-----------------------------------------------------------------------'
ERROR: Package is corrupt: amd-catalyst-driver-13.251_3.12.16-x86-1vl71.txz
vector://home/bazinga/Downloads
root:#
am I wrong something?
Logged
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #13 on: June 11, 2014, 12:20:56 pm »

The package truly is "corrupt". Hrm.

Specifically, it's ASCII text, with CRLF, LF line terminators. It can be read using any text viewer -- it's an error message from our repos. Errant upload, I guess.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Banjer
Member
*
Posts: 16


« Reply #14 on: June 11, 2014, 12:40:42 pm »

Sorry I don't understand!
How can I install it?
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!