VectorLinux
November 23, 2014, 02:07:47 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [ SOLVED ] Problem getting TV-viewer to work.  (Read 302 times)
Locator
Vectorian
****
Posts: 729



« on: June 16, 2014, 07:33:06 am »

I have mentioned a program before in these forums called TV-viewer (which you cam download from the following location: http://sourceforge.net/projects/tv-viewer/files/TV-Viewer%20-%20Snapshots/0.8.2b1/tv-viewer-0.8.2b1.tar.gz/download), but they have a new version out now. It can be obtained with the following command:

git clone https://github.com/crapp/tv-viewer.git

But the "interesting" problem that I'm experiencing with it is as follows:

When I run the configuration file, I get the following output:

doctor:$ ./configure.tcl --enable-tclkit=yes

Configuring build environment for TV-Viewer 0.8.2b2 Build 190


checking dependencies

Tk *** OK
ivtv-tune *** OK
v4l2-ctl *** OK
mplayer *** OK
xdg-email *** OK
xdg-open *** OK
xdg-screensaver *** OK
sqlite3 *** OK
sqlite3 Tcl extension *** OK

checking for optional dependencies

irexec *** FAILED

could not detect lirc
you won't be able to use a remote control

tkimg *** OK
tclkitbin tclkit-8.5.9

configuring TV-Viewer:
prefix        /usr/local
eprefix       /usr/local
bindir        /usr/local/bin
bintarget     /usr/local/share/tv-viewer
libdir        /usr/local/lib
datadir       /usr/local/share
mandir        /usr/local/share/man
docdir        /usr/local/doc/tv-viewer

tktray        1
tclkit        1
tclkitbin     tclkit-8.5.9
architecture  32bit


configure: creating ./configure.log
configure: creating   extensions/tclkit/tclkitstarter.sh
configure: creating ./install.tcl

run
% ./install.tcl
as root to install TV-Viewer

Which would indicate no problems (except no remote control which I don't need anyway). The installation also goes smoothly. But then when I try to run it (from terminal mode) I get the following output:

doctor:# can't find package sqlite3
    while executing
"package require {*}$pkg($nr)"
    (procedure "init_pkgReq" line 10)
    invoked from within
"init_pkgReq [list 2 3 4]"
    (file "/usr/local/share/tv-viewer/data/tv-viewer_main.tcl" line 189)

Any practical suggestions will ne greatly appreciated.[/list]
« Last Edit: June 16, 2014, 08:14:25 pm by Locator » Logged
roarde
Vectorian
****
Posts: 541


move the needle


« Reply #1 on: June 16, 2014, 06:22:29 pm »

Which version of VL are you using?

When built on 7.1, this build acts as you describe. 7.1 doesn't have libtclsqlite3.so yet.

I modified hata_ph's SlackBuild to build the tv-viewer version you're wanting for 7.0. It seems to build fine, and brings up the startup screens. I don't have the tuner, so I removed the package. Here's that SlackBuild, get it while it lasts: http://pastie.org/9297598

When doing a custom build for my own system, I often start with a SlackBuild that's successfully built the same or similar package for the repo. Best place to get some of them is to install the package and look around in /usr/doc/(package-name). Not all packages copy their SlackBuilds there. If it's one of those, or you just don't want to install the package, visit https://bitbucket.org/VLCore/vl70/src. Click through the folders "var", "vabs", and "(package-name)", then finally "src". Click on the SlackBuild, then find and right-click the "Raw" button to download the SlackBuild. Using it (after an edit, of course) is described below.

If it's available, use the SlackBuild from the version of VL you're using. The above url is for 7.0; for 7.1 change vl70 to vl71.

Hata_ph built stable because it's for the repo. Given what the author has to say about his future non-plans, this might be one of the few that might have beta put in the repo. On the other hand, it could be time to find a different application to handle this.

Just make a directory called "tv-viewer" somewhere. Inside it, make the directory "src".
Download the paste to the file  (PATH)/tv-viewer/src/tv-viewer.SlackBuild.
cd to tv-viewer/src and become root.
chmod +x tv-viewer.SlackBuild
Make sure your internet is up
./tv-viewer.SlackBuild

When package is complete,
cd ..
installpkg tv-view(tab complete)        I've forgotten the complete package name already. Ends in txz, of course.

Has to be installed with installpkg because there's no PACKAGES.TXT here for slapt-get or GSlapt to read. Remove with removepkg.

Worked for me on 7.0 with latest VL sqlite package installed. Are you working with 7.1 now, or is the build you did looking for libs in /usr/local/lib rather than /usr/lib?
« Last Edit: June 16, 2014, 06:41:22 pm by roarde » Logged

Robert
VL STD 7.1 RC2.3, icewmvmods
Locator
Vectorian
****
Posts: 729



« Reply #2 on: June 16, 2014, 08:13:48 pm »

I'm sorry to have to tell you this, but after all the trouble you went through to try and help me, I come to find out that the problem was actually with tclkit (outdated and a bit problamatic), so I was told (by the author) to just type "./configure.tcl", and leave out the rest, then type "./install.tcl", so now it works the way it's supposed to. And by the way, the version in question is 0.8.2b2 Build 190. It has a several bug fixes making it a BIG improvement over earlier versions. But thanks for the help though, I DO appreciate your efforts Smiley, and actually I've gone back to 7.0, at least until the bugs are worked out of 7.1 and later.
« Last Edit: June 16, 2014, 08:18:37 pm by Locator » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!