VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: SQLite Newer Versions  (Read 3021 times)

conductor56

  • Member
  • *
  • Posts: 17
SQLite Newer Versions
« on: April 14, 2014, 03:02:37 pm »

I am using SQLite v 3.7.5 which is the latest in the gslapt list of packages.  I have run into a problem that a number of others have encountered apparently.  Some of the functions in the SQLite docs are not available in v 3.7.5 - instr for example.

The SQLite web page indicates that v 3.8.4 is the latest.

Has anyone installed SQLite from the SQLite web page?  Is it reasonably straightforward?  Bearing in mind I've only used gslapt and installed from packages before.

Any and all help appreciated.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: SQLite Newer Versions
« Reply #1 on: April 14, 2014, 06:05:10 pm »

You are using VL 7.0 or 7.1?
Logged

conductor56

  • Member
  • *
  • Posts: 17
Re: SQLite Newer Versions
« Reply #2 on: April 22, 2014, 03:16:43 am »

Still on 7.0.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: SQLite Newer Versions
« Reply #3 on: April 23, 2014, 04:22:56 am »

I build sqlite-3080403 under the untested repo. Pls try to install/upgrade via slapt-get/gslapt.
Add below repo link to your slapt-getrc

32bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
64bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/

PS: Advise to disable the untested repo after install/upgrade sqlite
Logged

conductor56

  • Member
  • *
  • Posts: 17
Re: SQLite Newer Versions
« Reply #4 on: April 23, 2014, 04:07:35 pm »

Thanks.  I will try this in the next day or so and post the outcome in this thread.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: SQLite Newer Versions
« Reply #5 on: April 23, 2014, 05:41:05 pm »

K...
Logged

Locator

  • Vectorian
  • ****
  • Posts: 756
Re: SQLite Newer Versions
« Reply #6 on: June 03, 2014, 02:30:19 pm »

I build sqlite-3080403 under the untested repo. Pls try to install/upgrade via slapt-get/gslapt.
Add below repo link to your slapt-getrc

32bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
64bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/

PS: Advise to disable the untested repo after install/upgrade sqlite

I just looked for it there and didn't see it  :'(.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: SQLite Newer Versions
« Reply #7 on: June 04, 2014, 11:32:39 pm »

Pls check in the testing repo
Logged

Locator

  • Vectorian
  • ****
  • Posts: 756
Re: SQLite Newer Versions
« Reply #8 on: June 09, 2014, 04:20:48 pm »

I looked in the testing repo and finally found it. Unfortunately I found out that, the program that I'm working with (or at least trying to work with) called tv-viewer (version 0.8.2 if I'm not mistaken) requires the sqlite-tcl bindings as well which I haven't found as of yet (and yes, I did a Google search for it).
« Last Edit: June 09, 2014, 04:28:00 pm by Locator »
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: SQLite Newer Versions
« Reply #9 on: June 09, 2014, 04:57:48 pm »

Do you have tcl package installed?
Logged

Locator

  • Vectorian
  • ****
  • Posts: 756
Re: SQLite Newer Versions
« Reply #10 on: June 09, 2014, 09:44:18 pm »

Yes.
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: SQLite Newer Versions
« Reply #11 on: June 10, 2014, 05:30:32 am »

i have upgrade sqlite-3080500 to include the tcl sqlite bindings
i build tv-viewer-0.8.1.1 and ivtv-utils-1.4.1 if you want to try it
all under the untested repo...
Logged

conductor56

  • Member
  • *
  • Posts: 17
Re: SQLite Newer Versions
« Reply #12 on: June 27, 2014, 11:26:12 am »

I build sqlite-3080403 under the untested repo. Pls try to install/upgrade via slapt-get/gslapt.
Add below repo link to your slapt-getrc

32bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
64bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/

PS: Advise to disable the untested repo after install/upgrade sqlite

Replying to the above (Finally!  Apologies for delay.) , I tried adding the above to slapt-getrc then using the gslapt selection from the menu.  I still saw my installed SQLite 307... as the latest available.  In the slapt-getrc, there is a line ending with the text ":OFFICIAL".  Is it possible this source has precedence over all the others?  Is the order of the source lines important?

My need to get some more up to date versions has grown recently.  My version of Firefox (19) is not working well with the latest gmail upgrades and I rely on gmail a lot.  I'm open to trying to upgrade Firefox directly from Mozilla if others have had good experience with that.  But I'd rather just get a later package usign gslapt.

Logged

roarde

  • Vectorian
  • ****
  • Posts: 589
  • move the needle
Re: SQLite Newer Versions
« Reply #13 on: June 28, 2014, 02:06:18 am »

Hi, conductor56.

I've looked at this. From here, it seems you don't have the testing repo enabled. Edit slapt-getrc again. Change this
Code: [Select]
#SOURCE=http://vectorlinux.osuosl.org/veclinux-7.0/testing/
to this
Code: [Select]
#DISABLED=http://vectorlinux.osuosl.org/veclinux-7.0/testing/
That tags the testing repo as "available but turned off" for GSlapt. I don't think slapt-get itself does anything with the #DISABLED tag.

Now start GSlapt. From the menu, Edit > Preferences, then the Sources tab (you might need to make this window wider). Check the box next to the testing repo. It's best that "untested" is off -- that sqlite build has been moved to testing. Click OK. When the suggestion appears to update package lists, click "Yes". That does the same thing as clicking "Update" in GSlapt's toolbar: Update the list of packages, not install anything.

Now you're ready to go look for more recent packages. But maybe not Firefox. It's possible I may be the only one having this problem, but take a look at this thread. Some reply to that should come before too long.

You said in your reply to hata_ph that "I tried adding the above [repository] to slapt-getrc . . .". I take it that you added either the 32-bit or 64-bit line as appropriate, but not both. If you add a URL as "SOURCE=(urll_here)" or "#DISABLED=(url_here)", you'll be able to turn it off/on through GSlapt, otherwise probably not.

You should definitely turn untested off and enable it only long enough to grab exactly what you're looking for there. As for testing, the official wisdom is to leave it normally off, but this late in 7.0's cycle I find myself just leaving it on.
Logged
Robert
VL Light RC 1.9

conductor56

  • Member
  • *
  • Posts: 17
Re: SQLite Newer Versions
« Reply #14 on: July 02, 2014, 02:14:29 pm »

Thanks to all for helpful advice.  This seems to be resolved now.

There was still some quirky behaviour in gslapt which may be unique to my installation/environment but I will mention it below in case anyone needs to reference it.

The http://vectorlinux.osuosl.org/veclinux-7.0/testing repo was active but I wasn't seeing its contents in the latest versions of my selected packages - sqlite, firefox.  So, just to try something else, I also activated the ftp.osuosl.org/pub/ etc repo.  Then, when I looked at my packages of interest, I saw the newer versions in both of those repo's.  And the upgrade to the newer versions looks good in early use.

Thanks again.

Logged