VectorLinux
September 18, 2014, 03:25:57 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [ SOLVED ] Need help finding libx264.  (Read 412 times)
Locator
Vectorian
****
Posts: 706



« on: July 10, 2014, 08:03:07 am »

I am trying to run a program called "Cinelerra" (found in the "testing" repository), and I get the following output (from terminal mode):

doctor:$ cinelerra
cinelerra: error while loading shared libraries: libx264.so.112: cannot open shared object file: No such file or directory

Yes, I know that it was in the "untested" repository for about a week or so, but between the time that I first installed it and now, I ended up having to re-install things, and as a result, libx264 has since disappeared from the repositories  Sad.
« Last Edit: July 16, 2014, 03:08:53 pm by Locator » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #1 on: July 10, 2014, 08:46:02 am »

slapt-get -u; slapt-get -i x264
Logged

Locator
Vectorian
****
Posts: 706



« Reply #2 on: July 10, 2014, 08:58:23 am »

And the end result is:

doctor:$ slapt-get -u; slapt-get -i x264
/home/ftp/pub/veclinux/packages: Permission denied
Please update permissions on /home/ftp/pub/veclinux/packages or run with appropriate privileges
/home/ftp/pub/veclinux/packages: Permission denied
Please update permissions on /home/ftp/pub/veclinux/packages or run with appropriate privileges
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #3 on: July 10, 2014, 09:39:58 am »

slapt-get is a root utility.  Run is as root.
Logged

Locator
Vectorian
****
Posts: 706



« Reply #4 on: July 10, 2014, 11:01:44 am »

I tried that, and the end result was:

root:# slapt-get -u; slapt-get -i x264
Retrieving package data [http://vectorlinux.osuosl.org/veclinux-7.0/packages/]...Cached
Retrieving patch list [http://vectorlinux.osuosl.org/veclinux-7.0/packages/]...Done
Retrieving checksum list [http://vectorlinux.osuosl.org/veclinux-7.0/packages/]...Cached
Retrieving checksum signature [http://vectorlinux.osuosl.org/veclinux-7.0/packages/]...Not Found
Retrieving ChangeLog.txt [http://vectorlinux.osuosl.org/veclinux-7.0/packages/]...Done
Reading Package Lists...Done
Retrieving package data [http://vectorlinux.osuosl.org/veclinux-7.0/extra/]...Cached
Retrieving patch list [http://vectorlinux.osuosl.org/veclinux-7.0/extra/]...Done
Retrieving checksum list [http://vectorlinux.osuosl.org/veclinux-7.0/extra/]...Cached
Retrieving checksum signature [http://vectorlinux.osuosl.org/veclinux-7.0/extra/]...Not Found
Retrieving ChangeLog.txt [http://vectorlinux.osuosl.org/veclinux-7.0/extra/]...Done
Reading Package Lists...Done
Retrieving package data [http://vectorlinux.osuosl.org/veclinux-7.0/patches/]...Cached
Retrieving patch list [http://vectorlinux.osuosl.org/veclinux-7.0/patches/]...Done
Retrieving checksum list [http://vectorlinux.osuosl.org/veclinux-7.0/patches/]...Cached
Retrieving checksum signature [http://vectorlinux.osuosl.org/veclinux-7.0/patches/]...Not Found
Retrieving ChangeLog.txt [http://vectorlinux.osuosl.org/veclinux-7.0/patches/]...Done
Reading Package Lists...Done
Reading Package Lists...Done
x264 is up to date.
0 upgraded, 0 reinstalled, 0 newly installed, 0 to remove, 0 not upgraded.

And when I tried to run Cinelerra again (as a regular user), the end result was:

doctor:$ cinelerra
cinelerra: error while loading shared libraries: libx264.so.112: cannot open shared object file: No such file or directory
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #5 on: July 11, 2014, 12:26:04 pm »

Where did you get that package from?  The error indicates it was built against an older version of x264.  

FWIW, we have cinelerrra-cv version 2.2 on 7.0 "testing" repositories.  Remove your package and as root "slapt-get -u; slapt-get -i cinelerra-cv"
« Last Edit: July 11, 2014, 12:31:27 pm by M0E-lnx » Logged

hata_ph
Packager
Vectorian
****
Posts: 3257


-- Just being myself --


« Reply #6 on: July 11, 2014, 06:50:16 pm »

Here is the x264-20120530 packages under the extra repo...

http://vectorlinux.osuosl.org/veclinux-7.0/extra/l/x264-20120530-i586-1vl70.txz
http://vectorlinux.osuosl.org/VL64-7.0/extra/l/x264-20120530-x86_64-1vl70.txz
Logged
Locator
Vectorian
****
Posts: 706



« Reply #7 on: July 16, 2014, 03:08:29 pm »

Thank you. After doing a bit of research into the matter, I come to find out that Cinelerra is only intended to run on 64-bit systems.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!