VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: xsane segfault  (Read 28 times)

overthere

  • Vectorian
  • ****
  • Posts: 1348
xsane segfault
« on: June 29, 2015, 05:11:04 pm »

I have a brother MFC-685cw wireless and a canoscan n670u usb scanner..toshiba satillite. a100 laptop.VL7.1 std 32 final

after converting the brother drivers .rpm to .txz and installing the printer appeared in print settings and from there I added the wireless..printing appears to work so far wireless or usb

when I attempted a scan xsane found nothing, so in terminal I did

brsaneconfig2 -a name=SCANNER_mfc685CW model=MFC-685CW ip=xxx.xxx.x.xx (x=ip)( command found on google search????

now xsane scanned and found the device and opened as expected

However after preview which looked ok I clicked SCAN. at the end of the scan xsane vanished, in terminal it simply posts segmentation fault. I did half dozen scans

when I plug in the usb canoscan, xsane scans and gives option for mfc685cw or cannon..I choose cannon and xsane opens as expected but the same occurs...segfault after scan

it does not matter if I select an alternative file format, jpg, pdf etc..it does not save...but does create several files likely the temp files and the unconverted scan in .ppm.

I feel lucky the wireless printer works and thought if the scanner did not I could use the usb one, as it worked on vector last time I tried it..beta or early rc..

any thoughts on what may be causing the segmentation fault??? perhaps I can remove the brscan driver or perhaps I missed a step..the directions were for redhat so no exactly usefull and the brscanconfig line was I think from an arch forum post
Logged
Everything Is Relative

roarde

  • Vectorian
  • ****
  • Posts: 601
  • move the needle
Re: xsane segfault
« Reply #1 on: June 29, 2015, 09:50:52 pm »

I have to wonder if it might be the UI that's crashing.

Is anyone scanning succesfully with xsane on 32-bit?

How about 64-bit? Working or segfaulting?
Logged
Robert
VL 7.1 Light RC 2