Please support VectorLinux!

Author Topic: Problem installing Flightgear.  (Read 3674 times)

Locator

  • Vectorian
  • ****
  • Posts: 821
Problem installing Flightgear.
« on: November 24, 2014, 04:45:25 pm »
I am using Vector Linux 7.0, and am trying to install Flightear 2.4.0-i586-1vl70, and the following error window pops up:

Locator

  • Vectorian
  • ****
  • Posts: 821
Re: Problem installing Flightgear.
« Reply #1 on: November 29, 2014, 01:49:32 pm »
I finally managed to download and install it manually, but when I tried to run it from the "Games" menu nothing seemed to happen, so I tried running it in terminal mode with the following result:

vector:/~
doctor:$ usr/bin/fgfs --geometry=1024x768 --enable-game-mode
bash: usr/bin/fgfs: No such file or directory

DESPITE the fact that there IS a file in that sub-directory by that name. So what do you suggest I do to get it working (and yes, I have installed the dependencies the documentation for it says I need)?

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4459
Re: Problem installing Flightgear.
« Reply #2 on: November 29, 2014, 03:44:12 pm »
What you describe, happens when you try to launch a 64-bit executable in a 32-bit environment or vice versa. Make sure you have a package for the appropriate architecture.

Locator

  • Vectorian
  • ****
  • Posts: 821
Re: Problem installing Flightgear.
« Reply #3 on: November 29, 2014, 05:18:51 pm »
I didn't know that it was 64-bit (I am using the 32bit version of Vector Linux 7.0) and I assumed that I was loading the 32-bit version of that software (nothing about the file name in the repository that I saw indicated that it was a 64-bit version). And the 64-bit version is DEFINITELY named differently (I know, I checked it myself). So how do I get the 32-bit version to work?
« Last Edit: November 29, 2014, 05:33:31 pm by Locator »