Author Topic: lsof does not work correctly  (Read 2108 times)

chasster123

  • Member
  • *
  • Posts: 13
  • user
lsof does not work correctly
« on: July 27, 2015, 04:07:27 pm »
When trying to use lsof it basically does nothing toward obtaining a list of files.
lsof +D /dir/dir   files in directory
Various attempts / switches to obtain file info from directories shows no result.
Ran slapt-get -u lsof and it seemed to update.
Same non-result.
Tried in / outside of root.

Any feedback is appreciated.
cs

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2383
Re: lsof does not work correctly
« Reply #1 on: July 27, 2015, 06:55:04 pm »
There was a bug in this build indeed.

Please download new package and test it if you can, running these commands as root:

Code: [Select]
# wget http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/x86/lsof-4.78-i586-2vl71.txz
# upgradepkg lsof-4.78-i586-2vl71.txz

Fixed by https://bitbucket.org/VLCore/vl71/commits/a27ded7643001246bb3bc278cdfcdd10ac62efec
Tracking issue here: https://bitbucket.org/VLCore/vl71/issues/51/lsof-empty-package

Thanks!
« Last Edit: July 27, 2015, 07:00:12 pm by rbistolfi »
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

crum

  • Vectorite
  • ***
  • Posts: 180
Re: lsof does not work correctly
« Reply #2 on: July 28, 2015, 11:20:04 am »
@rbistolfi: Works as advertised.

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3499
Re: lsof does not work correctly
« Reply #3 on: July 28, 2015, 12:12:25 pm »
package has been moved to patches.