VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: JWM Configuration Thread  (Read 1193 times)

roarde

  • Vectorian
  • ****
  • Posts: 767
  • it's enough
JWM Configuration Thread
« on: August 07, 2015, 12:27:06 pm »

Been thinking it would be good to restart some of the window manager config threads, and a question came up elsewhere about JWM. Post config (or other) questons about JWM, or just share your own tips.

Hi guys, when i configured the window options of JWM, the terminal gives me the following problem:
the only option i want is for the package to be maximized. Every package i got there works fine, except the terminal (qterminal) when i press the keybinding for it, it launches 'xterm' NOT MAXIMIZED, i cannot get qterminal, in icewm it works just fine.

Code: [Select]
    <Group>
 <!-- Options for program groups. -->
        <Class>qterminal</Class>
        <Option>maximized</Option>
    </Group>
    <Group>
        <Name>xchat</Name>
        <Option>maximized</Option>
    </Group>
 

And so forth, i got the same option for firefox, xfe, and it works fine, IOW, when i hit the keybind the app is launched maximized, except 'qterminal' not maximized and 'xterm' instead. I edited the menu and from there it works fine, but then i would have to mouse/click and it defeats the purpose. Thanks...

Two problems here. One you posted in code, which is the reason it's not maximizing in the first place. I suspect you manually maximized, then exited. Qterminal itself remembers the previous setting; that's why it now starts maximized from menu. I think Qterminal is doing its own, saved maximization but JWM's config is still not correct.

Installed jwm and qterminal. Started jwm from gdm, started qterminal from xterm. Saw that the qterminal window was titled "QTerminal", and the title is usually the name xprop will recognize.
Code: [Select]
xprop -name QTerminal | grep 'WM_CLASS'Which returns
WM_CLASS(STRING) = "qterminal", "Qterminal"

JWM's <Name> is 'qterminal', the <Class> 'Qterminal'. The group entry would work if the key were changed to 'Name', but I see your point in wanting to use 'Class' for an x-terminal. Class will work if you case-match 'Qterminal'.

As for your keyboard shortcut, here's a wild guess: you used a wildcard for which the first match would be 'terminal'. There is a /usr/bin/terminal in your path, and if the guess is correct that's what your hotkey is finding. It's a shell script that will, in the end, default to xterm.

Using Ctrl+(anything) for a terminal launch hotkey is a real bad idea, but it popped to mind so I did it anyway:
<Key mask="C" key="t">exec:qterminal</Key>
Pressing Ctrl+t does indeed launch qterminal; maximized, even if I'd previously changed the size and exited.

Now to pick a different hotkey. I can't delete whole words (yep, "Ctrl+T") in my text editor anymore  :D
« Last Edit: August 07, 2015, 12:36:46 pm by roarde »
Logged
Robert

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: JWM Configuration Thread
« Reply #1 on: August 07, 2015, 12:57:59 pm »

Here's what the problem and solution was (in the other thread):
"M0E-lnx:
You were right, pal. My bad! the problem was not my window options, instead it was my keybindings: i had assigned F1 to launch the terminal, and instead of having 'qterminal' written, i had 'xterm'. I had forgotten to erase 'xterm' everything is hunky-dorry. :)"
Logged
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8