VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2] 3

Author Topic: Web page maker Canceled  (Read 5422 times)

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1466
Re: Web page maker
« Reply #15 on: August 30, 2015, 08:09:16 am »

Generally, your files are going to go under /home/%username%/public_html
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2380
Re: Web page maker
« Reply #16 on: August 30, 2015, 08:31:16 pm »

StrayBit,

You are accessing the file through the filesystem, you need to go by the web server. The URL may look like this:

127.0.0.1/wordpress/wp-admin/install.php

If that fails, you need to configure your web server properly. This works like this:

* You configure a server like apache or nginx to handle .php urls to a php interpreter
* You access php files via that web server (using localhost or the ip of the machine running the server in the lan)
* The web server will run the php script and return the result to the client

Good luck!
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

SmartDuck

  • Member
  • *
  • Posts: 86
    • SmartDuck
Re: Web page maker
« Reply #17 on: September 01, 2015, 10:35:00 am »

WordPress is a complete ready framework to setup a blog or presence. You will need a full webserver with php and mysql installed on your pc or install it on a host from a hosting provider. For a webserver configuration with Vector Linux see http://forum.vectorlinux.com/index.php?topic=18685.0 . For WordPress you will need to install mysql instead of SQLite.

To create or script webpages (html) you will need an editor like Geany (installed), Bluefish (in the repos) or visual tool like Kompozer (http://kompozer.net).
Logged
Dell Lattitude E4300 - Antergos 64bit
Dell Lattitude D505 - Vector Linux 7.1 Light 32bit
Raspberry Pi B+ - OpenElec 5.0.8 - Multimedia player
Raspberry Pi A+ - Arch Linux - IoT App MijnTuinkas
Raspberry Pi B - Arch Linux - Fun / IoT App MijnAquarium

sledgehammer

  • Vectorian
  • ****
  • Posts: 1525
Re: Web page maker
« Reply #18 on: September 01, 2015, 11:39:06 am »

Smart advice, SmartDuck, but I wonder about your statement that:

Quote
To create or script webpages (html) you will need an editor like Geany (installed), Bluefish (in the repos) or visual tool like Kompozer (http://kompozer.net).

Far as I know, I don't use any of that stuff as Wordpress makes creating webpages on the wordpress site very easy.

John
Logged
VL7.0 xfce4 Samsung RF511

SmartDuck

  • Member
  • *
  • Posts: 86
    • SmartDuck
Re: Web page maker
« Reply #19 on: September 01, 2015, 03:00:57 pm »

You're right :) If you don't use WordPress you will have to create with those tools and upload the pages to a host (local machine or provider).
Logged
Dell Lattitude E4300 - Antergos 64bit
Dell Lattitude D505 - Vector Linux 7.1 Light 32bit
Raspberry Pi B+ - OpenElec 5.0.8 - Multimedia player
Raspberry Pi A+ - Arch Linux - IoT App MijnTuinkas
Raspberry Pi B - Arch Linux - Fun / IoT App MijnAquarium

StrayBit

  • Vectorian
  • ****
  • Posts: 529
Re: Web page maker
« Reply #20 on: September 07, 2015, 01:19:23 pm »

OK!  I have to manually start httpd
Quote
su
apachectl start
How do I get that to be automatic at logon?  etc/rc.d/rc.httpd is allowed to run as a program
Now if I direct my browser to 127.0.0.1 or 192.168.1.x
Quote
It works!
Finally able to open
Quote
127.0.01//wordpress/wp-admin/install.php
Wordpress is in /srv/htdocs.  But it says
Quote
Your PHP installation appears to be missing the MySQL extension which is required by WordPress.
Mysql plus mariadb and sqlite are installed according to gslapt.  Now to figure out how to use/set it up
Logged
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

sledgehammer

  • Vectorian
  • ****
  • Posts: 1525
Re: Web page maker
« Reply #21 on: September 07, 2015, 06:51:08 pm »

Straybit,

At the risk of adding further confusion, I think my wordpress install uses the mysql that is on the site that hosts my wordpress page rather than the mysql on my machine.   I know nothing of mysql so take this with a grain of salt.
Logged
VL7.0 xfce4 Samsung RF511

StrayBit

  • Vectorian
  • ****
  • Posts: 529
Re: Web page maker
« Reply #22 on: September 11, 2015, 11:12:14 am »

Thanks, guys for your comments.  I'm doing all this on my local network as I don't (at this time) require or want access from the world.
OK!  I have insured that httpd 2.4.16-i586-1vl, mysql 5.6.25 and php 5.69 are installed.
I have copied wtc/httpd/mod_php.conf.example mod_php.conf
Per the php.net site, I have copied etc/httpd/php.ini-development /usr/lib/php.ini
and have edited httpd.conf:
  ServerName 192.168.1.143:80
  Include /etc/httpd/mod_php.conf
  <FileMatch \.php&>
    SetHandler application/x-httpd-php
  </FileMatch>
  LoadModule php5_module modules/libphp.so
(FileMatch and LoadModule php5 had to be typed in.)
Through SeaMonkey, typing 192.168.1.143 (or 127.0.0.1 on the server) it shows "It Works!"
http://127.0.0.1/wordpress/wp-admin/install.php:
Quote
Your PHP installation appears to be missing the MYSQL extension which is required by WordPress
I have found 7 db[m,d] modules in httpd.conf but I have no idea what they do or which (if any) I should uncomment.  The only reference I find on php.net refers to compiling.
Logged
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

StrayBit

  • Vectorian
  • ****
  • Posts: 529
Re: Web page maker
« Reply #23 on: September 13, 2015, 01:21:34 pm »

I discovered that the line that I had added
Quote
  LoadModule php5_module modules/libphp.so
not only had an error: it should have been "lib/httpd/modules/libphp5.so" and then I get the following
Code: [Select]
root:# apachectl restart
[Sun Sep 13 13:44:45.891850 2015] [so:warn] [pid 2820:tid 3068958464] AH01574: module php5_module is already loaded, skipping
so I commented it out.
I tried uncommenting each of the db[d|m] lines one at a time.  All of them gave
Code: [Select]
Your PHP installation appears to be missing the MYSQL extension which is required by WordPressthe last one (my line 141):
Quote
LoadModule session_dbd_module lib/httpd/modules/mod_session_dbd.so
gave
Quote
root:# apachectl restart
httpd: Syntax error on line 141 of /etc/httpd/httpd.conf: Cannot load lib/httpd/modules/mod_session_dbd.so into server: /usr/lib/httpd/modules/mod_session_dbd.so: undefined symbol: ap_hook_session_save
Uncommented line 139
Quote
LoadModule session_module lib/httpd/modules/mod_session.so
and had no error or warning.  Still got the message about MYSQL being missing!
So! What can I try next?
Logged
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1466
Re: Web page maker
« Reply #24 on: September 13, 2015, 01:44:07 pm »

Generally, if Apache is complaining about a missing module, it usually means it wasn't compiled in or compiled properly with Apache.

http://httpd.apache.org/docs/2.2/install.html

Quote
Also at this point, you can specify which features you want included in Apache HTTPd by enabling and disabling modules. The Apache HTTP Server comes with a Base set of modules included by default. Other modules are enabled using the --enable-module option, where module is the name of the module with the mod_ string removed and with any underscore converted to a dash. You can also choose to compile modules as shared objects (DSOs) -- which can be loaded or unloaded at runtime -- by using the option --enable-module=shared. Similarly, you can disable Base modules with the --disable-module option. Be careful when using these options, since configure cannot warn you if the module you specify does not exist; it will simply ignore the option.

« Last Edit: September 13, 2015, 01:46:14 pm by retired1af »
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1466
Re: Web page maker
« Reply #25 on: September 13, 2015, 01:53:16 pm »

Rather than doing things the hard way by installing each item individually, you may want to give this a shot instead.

https://www.apachefriends.org/index.html

It has all the necessary modules included that allows you to fire things up a lot quicker.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

StrayBit

  • Vectorian
  • ****
  • Posts: 529
Re: Web page maker
« Reply #26 on: September 14, 2015, 11:43:25 am »

Quote
Rather than doing things the hard way by installing each item individually, you may want to give this a shot instead.

https://www.apachefriends.org/index.html

It has all the necessary modules included that allows you to fire things up a lot quicker.
was a great idea.  Unfortunately, the Linux version is x64.  And the Windows version wouldn't start Apache,  (Now that I think about it, I was trying to start it wrong for Win7.
Logged
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

StrayBit

  • Vectorian
  • ****
  • Posts: 529
Re: Web page maker
« Reply #27 on: September 23, 2015, 10:45:37 am »

I tried downloading and compiling and got thoroughly confused.  (You can't confuse me!  I'm already confused!  ::) )  Files were placed differently than gslapt.
Removed the new files, installed httpd from gslapt (and reinstalled php and mysql).  Edited /etc/httpd/httpd.conf to load mod-php.conf.  Renamed the latter from mid_php.conf.development.  Found that /etc/rc.d/rc.mysqld needed to be set as executable (which would have solved the original problem!)
Apache works!  Now, 'http://127.0.0.1/wordpress/wp-admin/install.php' yields
Quote
WordPress
Error: PHP is not running

WordPress requires that your web server is running PHP.  Your server does not have PHP installed, or PHP is turned off.
Obviously, there is something that I have (not?) done.  But, I can't find it.  I have double checked httpd.conf and have tried with /etc/rc.d/rc.php-fpm executable or not.  Anyone have a suggestion?
Logged
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

StrayBit

  • Vectorian
  • ****
  • Posts: 529
Re: Web page maker
« Reply #28 on: September 24, 2015, 10:12:02 am »

Reinstalled httpd, mysql and php in gslapt.  edited httpd.conf
Quote
# Uncomment the following line to enable PHP:
#
Include /etc/httpd/mod_php.conf
# includes LoadModule php5_module lib/httpd/modules/libphp5.so

#Tell Apache to parse certain extensions as PHP.  Added per www.php.net
<FilesMatch \.php$>
    SetHandler application/x-httpd-php
</FilesMatch>
and still get
Quote
[b]WordPress
Error: PHP is not running[/b]

WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.
Will check WordPress site to see what they say.
Logged
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

wigums

  • Guest
Re: Web page maker
« Reply #29 on: September 24, 2015, 11:23:43 am »

what version of wordpress are you using? the new wordpress needs php5 > 5.5
im currently in the process of setting up wordpress on one of my boxes (not vl)
and there is a bit of a learning curve but its alot of fun and very well documented by wordpress themselvs

https://www.google.com/search?q=linux+instakll+wordpress

we're going pretty heavy into developing 7.2 so we are all rather busy but if you find something you need just ask us and we'll get it out there for you

edit:
sorry if thats been covered already. i did not read the entire thread
« Last Edit: September 24, 2015, 11:25:21 am by wigums »
Logged
Pages: 1 [2] 3