VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [ SOLVED ] Openshot quit working :(.  (Read 1208 times)

Locator

  • Vectorian
  • ****
  • Posts: 821
[ SOLVED ] Openshot quit working :(.
« on: December 19, 2015, 01:11:12 pm »

I tried to run Openshot from the main menu and nothing seemed to happen, ten I tried runnubg it fron the terminal and got the following output:

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------

** (process:18303): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:18303): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:18303): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
--------------------------------
   OpenShot (version 1.4.3)
--------------------------------
Process no longer exists: 18076.  Creating new pid lock file.
mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so
  (libavformat.so.53: cannot open shared object file: No such file or directory)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-menu-bar-popup-delay after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-label-select-on-focus after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-can-change-accels after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-menu-popup-delay after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-menu-popdown-delay after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-menu-images after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-button-images after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-entry-select-on-focus after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-entry-password-hint-timeout after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/SimpleGtkBuilderApp.py:32: Warning: Attempt to add property GtkSettings::gtk-scrolled-window-placement after class was initialised
  self.builder.add_from_file(path)
/usr/lib/python2.7/site-packages/openshot/windows/MainGTK.py:174: GtkWarning: Attempting to read the recently used resources file at `/home/doctor/.local/share/recently-used.xbel', but the parser failed: Error reading file '/home/doctor/.local/share/recently-used.xbel': Is a directory.
  manager = gtk.recent_manager_get_default()

Detecting formats, codecs, and filters...
Segmentation fault

 How do I resolve this issue?
« Last Edit: December 21, 2015, 09:55:45 am by Locator »
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3286
  • -- Just being myself --
Re: Openshot quit working :(.
« Reply #1 on: December 21, 2015, 06:25:18 am »

do you have mlt package installed?
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3479
Re: Openshot quit working :(.
« Reply #2 on: December 21, 2015, 06:41:58 am »

looks like he may have updated ffmpeg.

Which vector version is this on?

Locator

  • Vectorian
  • ****
  • Posts: 821
Re: Openshot quit working :(.
« Reply #3 on: December 21, 2015, 06:47:19 am »

Version7.0, and yes, I have mlt installed, and the ffmpeg version that I have installed is 0.11.5-i486.
Logged

Locator

  • Vectorian
  • ****
  • Posts: 821
Re: Openshot quit working :(.
« Reply #4 on: December 21, 2015, 09:55:10 am »

It turns out that the problem WAS with the upgraded version of ffmpeg after all, so I downgraded ffmpeg and openshot is working again :).
Logged