Author Topic: Language switching within an X session [RESOLVED]  (Read 2923 times)

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2921
    • The Linux Works
Language switching within an X session [RESOLVED]
« on: January 07, 2016, 07:44:26 pm »
Hi, everyone,

While my question is about Hebrew, I imagine the issue would be the same with any non-Latin character set so I'm hoping someone who is using two character sets (i.e.: Latin & Cyrillic) will know the answers.

I've finally put VL64 7.1 on my system with the Hebrew/English keyboard.  If I change the language when I login to Hebrew everything works fine in Hebrew and the keyboard can be switched back to English which also works.  However, if I login with a U.S. English locale, even if I change the keyboard setting to Israeli I can't seem to type in Hebrew at all.  This doesn't happen in other distros:  i.e.: language switching within an X session works fine in Debian or CentOS or whatever else I throw at this machine.   

I have added this to my .bashrc
setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,il

I also have tried setting keyboard switching in the XFCE keyboard settings app.

Has anyone got keyboard and character set switching working in XFCE without logging out?
« Last Edit: January 09, 2016, 03:12:13 pm by caitlyn »
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VL64 7.1

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: Language switching within an X session
« Reply #1 on: January 08, 2016, 05:03:47 pm »
https://wiki.archlinux.org/index.php/Keyboard_configuration_in_Xorg

This is a shot in the dark...I don't use xfce  :(
Play with it, try putting this in your .xinitrc:

Code: [Select]
setxkbmap -model pc104 -layout il,us -option grp:alt_shift_toggle

I don't know if your computer is pc104 or pc105.
See if alt-shift toggles the 2 languages, find out if you can toggle with the Caps Key :) (much faster)
Good luck!
« Last Edit: January 08, 2016, 05:16:55 pm by macondo »
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

roarde

  • Vectorian
  • ****
  • Posts: 781
  • it's enough
Re: Language switching within an X session
« Reply #2 on: January 08, 2016, 05:45:01 pm »
Part the first:
Open a run dialog.
env LANG=he_IL.UTF8 abiword

That may give you some progress, but I doubt it's the whole solution. Part the second would be to load a proper font, of which I am ignorant.

Spanish will work just by changing the keyboard because the characters needed are already in most left-to-right Latin UTF8 sets. But for Hebrew you need right-to-left and an entirely different set of characters, right?
Robert

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2921
    • The Linux Works
Re: Language switching within an X session
« Reply #3 on: January 09, 2016, 03:11:33 pm »
I clearly didn't explain the problem well.  If I login with a Hebrew/Israeli locale everything works.  Right to left is fine, the fonts are already in VL, keyboard switching works just fine.  If I login with a US English locale it just wouldn't allow me to enter anything in Hebrew.  I'd get nothing.

I did figure out the problem, BTW, and it's the fact that the default locale in VL 7.1 is en_US rather than en_US.UTF8.  If I change it to en_US.UTF8 everything works.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VL64 7.1

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: Language switching within an X session [RESOLVED]
« Reply #4 on: January 10, 2016, 08:37:28 am »
Glad to hear, congrats!
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8