VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: failed to start the X server[SOLVED]  (Read 1798 times)

Assaf-h

  • Member
  • *
  • Posts: 9
  • user
failed to start the X server[SOLVED]
« on: January 25, 2016, 11:48:43 am »

Hi

I am trying to run the Light version (7.1) on a Toshiba L30-134.

the installer finish and after restart I get a massage:
Failed to start the X server...
(see photo)

there is a lot of text in the report after this massage....
any idea how to pull this reports out from the Toshiba ? and share it?

thanks

Assaf

« Last Edit: January 28, 2016, 02:46:36 pm by Assaf-h »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4446
Re: failed to start the X server
« Reply #1 on: January 26, 2016, 04:45:03 pm »

Hi,

Boot to text mode from the boot selection screen and log in to command line. The file you are looking for is "/var/log/Xorg.0.log".

If you are not very familiar with the command line, enter command "mc" and use the arrow keys to navigate - right goes forward or into a directory, left goes back. Use down/up to highlight the file, then press F4 to view it. Look for lines with (EE), which indicate an error, and post them here.
Logged

Assaf-h

  • Member
  • *
  • Posts: 9
  • user
Re: failed to start the X server
« Reply #2 on: January 27, 2016, 01:06:32 pm »

Thanks nightflier

I used a live OS to get the file and the error lines are:


EE) systemd-logind: failed to get session: The name org.freedesktop.login1 was not provided by any .service files

(EE) Failed to load /usr/lib/xorg/modules/drivers/radeon_drv.so: libglamor.so.0: cannot open shared object file: No such file or directory

(EE) Failed to load module "radeon" (loader failed, 7)

(EE) Failed to load module "fbdev" (module does not exist, 0)

(EE) Screen 0 deleted because of no matching config section.

(EE) Device(s) detected, but none match those in the config file.

(EE)
Fatal server error:
[    45.168] (EE) no screens found(EE)
[    45.168] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org

any idea - how to fix it ?

Logged

roarde

  • Vectorian
  • ****
  • Posts: 767
  • it's enough
Re: failed to start the X server
« Reply #3 on: January 27, 2016, 09:04:59 pm »

Create the file /etc/X11/xorg.conf.d/56-radeon-EXA.conf:
Code: [Select]
Section "Device"
    Driver         "radeon"
    Identifier     "XPRESS200M"
    Option         "AccelMethod"    "EXA"
EndSection

Section  "Screen"
    Identifier     "Screen 0"
    Device         "XPRESS200M"
EndSection

What's happening is that the radeon driver is trying to load an acceleration driver that isn't appropriate for your card, and isn't present on the ISO. Hopefully the above works.

If it continues to look for "libglamor" after inserting the above file and rebooting, you'll need to remove the newly-created conf file and install the glamor-egl package.
http://vectorlinux.osuosl.org/veclinux-7.1/packages/x/glamor-egl-0.6.0-i586-1vl71.txz
Install with
installpkg glamor-egl-0.6.0-i586-1vl71.txz

It's a cleaner start if the conf file works and loading glamor at all is skipped. If you're forced to install the package anyway, it's probably better to make the fewest changes possible, thus skip the conf file. You might need to both have the glamor-egl package and the conf file.

Luck!
Logged
Robert

Assaf-h

  • Member
  • *
  • Posts: 9
  • user
Re: failed to start the X server
« Reply #4 on: January 28, 2016, 02:46:07 pm »

wow

THANK YOU  ;)

the file /etc/X11/xorg.conf.d/56-radeon-EXA.conf did not solved the problem

but installing the package glamor-egl solve it really grate,

the link: http://forum.vectorlinux.com/index.php?action=search2
was very helpful to get the job done.

Thanks alot

Assaf
Logged

roarde

  • Vectorian
  • ****
  • Posts: 767
  • it's enough
Re: failed to start the X server[SOLVED]
« Reply #5 on: January 28, 2016, 04:26:14 pm »

Glad to know it's working for you. Thank you very much for posting the issue, and especially for sharing your results  :)
Logged
Robert