Please support VectorLinux!

Author Topic: MPlayer, mplayer-plugin [SOLVED]  (Read 13299 times)

macondo

  • Vectorite
  • ***
  • Posts: 252
MPlayer, mplayer-plugin [SOLVED]
« on: March 01, 2016, 05:28:01 pm »
I can't watch a certain type of video in pbs.org/frontline. Checking the forums for different distros I found in one, the addition of mplayer and its plugin solved the problem in FF, Midori, and chromium.

Is there a way to get these so i can install them?

Thanks,
« Last Edit: March 03, 2016, 07:19:33 am by macondo »
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3286
  • -- Just being myself --
Re: MPlayer, mplayer-plugin
« Reply #1 on: March 01, 2016, 05:39:54 pm »
mind to give more info what mplayer plugin is missing?
I assume you are using VL 7.1 and I saw mplayer-1.1.1 is in the repo...did you install it?

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #2 on: March 01, 2016, 06:35:26 pm »
My bad! I search for 'mplayer' instead of MPlayer, it's already installed. the plugin is supposed to be 'mplayer-plugin'
unless i mispelled it. I also installed the w32codecs package just in case., I also looked for vlc...
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #3 on: March 01, 2016, 06:40:09 pm »
Or is it mplayerplug-in?
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #4 on: March 01, 2016, 07:01:33 pm »
The error I get is: 'Flash plugin failed to load', I thought i installed the latest one :(
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #5 on: March 01, 2016, 07:05:05 pm »
I also tried to install vlc.
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

roarde

  • Vectorian
  • ****
  • Posts: 779
  • it's enough
Re: MPlayer, mplayer-plugin
« Reply #6 on: March 01, 2016, 09:01:46 pm »
The error I get is: 'Flash plugin failed to load', I thought i installed the latest one :(

Enable the untested repo, and disable all others. Disabling the others is important in this case.
Code: [Select]
slapt-get -u
slapt-get -i flashplugin hal-flash
Then set repo selection back to normal (without untested) and slapt-get -u again.

The thing to note is whether it updates flashplugin.

If that sets you straight in mozilla-based browsers, remember not to allow flashplugin to be "upgraded" without insuring that it really is a later version.

No clue for chromium.
Robert

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #7 on: March 02, 2016, 05:54:44 am »
Chromium opens the link fine.
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #8 on: March 02, 2016, 06:10:01 am »
I followed your instructions to the letter, commented the repos except Testing, updated, when it came to install the packages, I got this error:
"No such package:flashplugin" . 

Code: [Select]
WORKINGDIR=/home/ftp/pub/veclinux/packages
EXCLUDE=kernel,kernel-ide,kernel-source,kernel-headers,kernel-modules
#DISABLED=file:///mnt/cdrom/packages/
#SOURCE=http://vectorlinux.osuosl.org/VL64-7.1/packages/
#SOURCE=http://vectorlinux.osuosl.org/VL64-7.1/extra/
#SOURCE=http://vectorlinux.osuosl.org/VL64-7.1/patches/:OFFICIAL
SOURCE=http://vectorlinux.osuosl.org/VL64-7.1/testing/
I updated...
« Last Edit: March 02, 2016, 06:12:36 am by macondo »
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #9 on: March 02, 2016, 06:41:55 am »
Errors:
"Retrieving package data [http://vectorlinux.osuosl.og/VL64-7.1/extra/]...Failed to download: Couldn't resolve host name"
"Sources failed to download, correct sources and rerun --update"
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2383
Re: MPlayer, mplayer-plugin
« Reply #10 on: March 02, 2016, 08:11:15 am »
Errors:
"Retrieving package data [http://vectorlinux.osuosl.og/VL64-7.1/extra/]...Failed to download: Couldn't resolve host name"
"Sources failed to download, correct sources and rerun --update"

Do you have a typo in your sources? (note 'og' instead 'org')
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #11 on: March 02, 2016, 08:23:44 am »
Do you have a typo in your sources? (note 'og' instead 'org')

Yes!
You hit the nail on the head. I corrected the typo and everything is hunky-dorry :D
Although, the original problem with flash persists.
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

roarde

  • Vectorian
  • ****
  • Posts: 779
  • it's enough
Re: MPlayer, mplayer-plugin
« Reply #12 on: March 02, 2016, 10:56:13 am »
"Untested". What I failed to pick up is that you've changed machines, haven't you? That would make "Enable the untested repo" an invaild instruction. It has to be written in for a fresh 7.1 install. Make this your only enabled SOURCE line, temporarily:
Code: [Select]
SOURCE=http://vlcore.vectorlinux.com/untested/veclinux-7.1/x86_64/( above edited since first post to show full line, not just URL)

And you need the security updates there too, so change the install procedure a bit:
Code: [Select]
slapt-get -u
slapt-get --upgrade
I'm gonna guess you looked in that repo already and didn't see flashplugin. It's been moved back in now, for a limited time.

Remember to re-enable the regular repos, disable untested, and do slapt-get -u again so your listings will be normal. For entertainment only, look at 'slapt-get -s -i flashplugin'. It will simulate "upgrade" of flashplugin to an older version.

Please comment on whether flashplugin works for your firefox, etc, here.
A word about how well you can connect to websites, etc, after the other updates this brought in would be nice, too, and that would go here: http://forum.vectorlinux.com/index.php?topic=18919.msg105061#msg105061
« Last Edit: March 02, 2016, 04:46:46 pm by roarde »
Robert

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #13 on: March 02, 2016, 02:11:09 pm »
"Untested". What I failed to pick up is that you've changed machines, haven't you?
I'm confused. I have not changed machines.

That would make "Enable the untested repo" an invaild instruction. It has to be written in for a fresh 7.1 install.
I don't have any "untested" repo, just "testing" as pasted at the beginning.

Make this your only enabled SOURCE line, temporarily:
Code: [Select]
http://vlcore.vectorlinux.com/untested/veclinux-7.1/x86_64/
And you need the security updates there too, so change the install procedure a bit:
Code: [Select]
slapt-get -u
slapt-get --upgrade
I'm gonna guess you looked in that repo already and didn't see flashplugin. It's been moved back in now, for a limited time.

Remember to re-enable the regular repos, disable untested, and do slapt-get -u again so your listings will be normal. For entertainment only, look at 'slapt-get -s -i flashplugin'. It will simulate "upgrade" of flashplugin to an older version.

@roarde:
I did the 'sudo slapt-get -u' and 'sudo slapt-get --upgrade' with no results whatsoever, (after commenting everything, except the 'untested' line I added as per your request.
Right now i commented the "untested" and uncommented the rest, back to normal. I did not install any flashplugin.
Problem continues,

Please comment on whether flashplugin works for your firefox, etc, here.
A word about how well you can connect to websites, etc, after the other updates this brought in would be nice, too, and that would go here: http://forum.vectorlinux.com/index.php?topic=18919.msg105061#msg105061
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8

macondo

  • Vectorite
  • ***
  • Posts: 252
Re: MPlayer, mplayer-plugin
« Reply #14 on: March 02, 2016, 02:13:51 pm »
VL 7.1 Light - icewm - jwm - ratpoison
“Just because you're paranoid doesn't mean they aren't after you.” ― Joseph Heller, Catch-22
Oscar Peterson - Bossa Nova - https://www.youtube.com/watch?v=cSX_7ejc5u8