Author Topic: imagemagick security update  (Read 2093 times)


roarde

  • Vectorian
  • ****
  • Posts: 779
  • it's enough
Re: imagemagick security update
« Reply #1 on: May 13, 2016, 05:24:28 pm »
The old package is called "imagemagick". The new package is called "ImageMagick". Slapt-get upgrade will not pick up the new package.
Robert

roarde

  • Vectorian
  • ****
  • Posts: 779
  • it's enough
Re: imagemagick security update
« Reply #2 on: May 13, 2016, 08:25:08 pm »
OK, this got hashed out. The package name for 7.1 remains "imagemagick", and it's now available.

The package name for 7.2 changes to "ImageMagick" to match the name supplied by the upstream source. For now, both "imagemagick" and "ImageMagick" are available -- other than the changes necessary to change the package's name, the packages are identical. What's expected is that 7.2 will not use the name "imagemagick" beyond this, but bear in mind it's still Alpha and subject to change.

7.1 supplied imagemagick on the install ISO. 7.2 doesn't need ImageMagick initially, so it's not on the ISO so far. That is, unless you have installed imagemagick on 7.2, "upgrade" won't and shouldn't pick this up, because there's nothing there to upgrade.
« Last Edit: May 13, 2016, 08:27:41 pm by roarde »
Robert