Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: canon printer pixma mg2950 wont' work  (Read 1113 times)


  • Member
  • *
  • Posts: 1
  • user
canon printer pixma mg2950 wont' work
« on: May 15, 2017, 10:14:07 am »

I am new to vector linux, but not new to linux (mint, ubuntu based..).
I just installed a vector linux (latest release I found, probably ver 7). I can't make it work the printer canon PIXMA MG2950.
I tried to configure CUPS, I tried with the drivers for similar models (the ones included already in vector).. I get no error, just the printer is not starting or printing anything. In the print queue I can see that the document or text was printed (job completed) but the printer just doesn't move.
Could you pls help me? I don't need advanced features, just basic printing.
Thanks a lot