Author Topic: php  (Read 5181 times)

StrayBit

  • Vectorian
  • ****
  • Posts: 543
    • Middleton Post 39
php
« on: June 12, 2017, 04:18:51 pm »
I'm still trying to get php to work with httpq (apache)
I've enabled all mod_*dbd and mod_*dbm trying to get php to work with httpd..  This is the only one I can't solve
Quote
root:# /etc/rc.d/rc.mysqld restart
vector://home/bruce
root:# 2017-06-10T20:56:50.170507Z mysqld_safe mysqld from pid file /var/run/mysql/mysql.pid ended
2017-06-10T20:56:51.572992Z mysqld_safe Logging to '/var/lib/mysql/vector.linux.vnet.err'.
2017-06-10T20:56:51.851646Z mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
root:# apachectl restart
httpd: Syntax error on line 143 of /etc/httpd/httpd.conf: Cannot load lib/httpd/modules/mod_session_dbd.so into server: /usr/lib/httpd/modules/mod_session_dbd.so: undefined symbol: ap_hook_session_save
/usr/lib/httpd/modules/mod_session_dbd.so is present.
What can I do?
I'm working with 7.2 STD B2 built on Feb-01-2017.
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3499
Re: php
« Reply #1 on: June 13, 2017, 05:52:53 am »
This looks like a problem in your configuration.  it does say Syntax error on line 143 of your /etc/httpd/httpd.conf.  Looks like the module you should be looking for is ap_hook_session_save.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2383
Re: php
« Reply #2 on: June 16, 2017, 05:49:22 am »
Its not a syntax error actually, this happens because the module you are trying to load has a dependency, it uses symbol defined in another module. Try adding this to your config:
Code: [Select]
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

StrayBit

  • Vectorian
  • ****
  • Posts: 543
    • Middleton Post 39
Re: php
« Reply #3 on: June 16, 2017, 11:23:19 am »
Sorry that it took so long to get back to this.
Thanks, rbistolfi.  I also needed to enable the mod_session*.so (3 of them).
Unfortunately, PHP says it can't connect to the database - perhaps because of user name or password.  Where can I find the correct one for the database?
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2383
Re: php
« Reply #4 on: June 16, 2017, 11:08:44 pm »
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

StrayBit

  • Vectorian
  • ****
  • Posts: 543
    • Middleton Post 39
Re: php
« Reply #5 on: June 25, 2017, 07:30:15 am »
Thanks for the link. rbistolfi.  Still no luck!
Re-installed mysql then removed all files in /run/mysql
Quote
vector://home/bruce
root:# mysqld --initialize
2017-06-24T16:07:54.526531Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2017-06-24T16:08:01.819878Z 0 [Warning] InnoDB: New log files created, LSN=45790
2017-06-24T16:08:03.194616Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.
2017-06-24T16:08:03.357419Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 4d34f5fb-58f7-11e7-817f-000c76a4c9d8.
2017-06-24T16:08:03.393535Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2017-06-24T16:08:12.609841Z 0 [Warning] CA certificate ca.pem is self signed.
2017-06-24T16:08:14.519138Z 1 [Note] A temporary password is generated for root@localhost: dh,,h<65:ZN?
vector://home/bruce
root:# /etc/rc.d/rc.mysqld start
vector://home/bruce
root:# 2017-06-24T16:19:07.003087Z mysqld_safe Logging to '/var/lib/mysql/vector.linux.vnet.err'.
2017-06-24T16:19:07.458769Z mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
then using the password above
Quote
root:# mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
vector://home/bruce
then, per your link
Quote
root:# /etc/rc.d/rc.mysqld stop
2017-06-24T16:21:18.717067Z mysqld_safe mysqld from pid file /var/run/mysql/mysql.pid ended
vector://home/bruce
root:# mysqld_safe --skip-grant-tables &
[3] 10711
vector://home/bruce
root:# Logging to '/home/mysql/vector.linux.vnet.err'.
2017-06-24T16:21:54.349587Z mysqld_safe Starting mysqld daemon with databases from /home/mysql
2017-06-24T16:21:55.804860Z mysqld_safe mysqld from pid file /home/mysql/vector.linux.vnet.pid ended
mysql -u root
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld.sock' (2)
[3]+  Done                    mysqld_safe --skip-grant-tables
/run/mysqld/ is owned by mysql and group mysql
Did I miss something?  probably!
7.2 STD B2 built on Feb-01-2017
HP 670 Win7 & VL7.0