VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: keyboard set up doesnt work  (Read 610 times)

black-clover

  • Member
  • *
  • Posts: 83
  • user
keyboard set up doesnt work
« on: July 01, 2017, 11:05:55 pm »

I had a problem setting up my laptop keyboard (spanish layout) on both VL 7.0 light and VL 7.2 std. In both case changing the layout with vasm didnt work. with VL 7.0 light I was able to fix the problem editing the layout line on the xorg. conf file and changing US for ES. but with VL 7.2 std I havent been able to find a solution. I changed the layout with vasm, the configuration manager and still it doesnt work. Also the layout is very weird, the letters that comes out are totally screwed up, with numbers in place of letters. Any suggestion?
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4426
Re: keyboard set up doesnt work
« Reply #1 on: July 02, 2017, 11:53:44 am »

As root, try running commands "vlocaleset", then "vkmapset". The keyboard test within the utility may not be valid, so just choose your layout, reboot the system and see how it does.
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #2 on: July 02, 2017, 01:37:27 pm »

now this is weird. First off, I tried the command you suggested and it didnt change anything. But what´s really strange is that when I type in the login window the keyboard works fine and it is just once I get into the desktop that the keyboard begins to acct wrongly. I tried to configure the keyboeard layout with the aplet that comes with the desktop, but it didnt work either. besides I can´t find the xorg.conf file in /etc/X11 to change the layout from there as I did in LV 7.1 light.
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #3 on: July 02, 2017, 02:11:33 pm »

this is getting odder and odder and also interesting. I switched from root to a user I set up during the install and got another desktop layout, much better and much similar to xlde and the keyboard now works better, it still doesnt recognizes the spanish characters but at least I dont get a 3 when I click a K.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4426
Re: keyboard set up doesnt work
« Reply #4 on: July 02, 2017, 03:22:36 pm »

Odd, indeed.  ???

It is obvious we have not had (m)any non-english testers of version 7.2. I'm gonna poke around some more, but hopefully someone with more knowledge than me will chime in with their opinions.

The xorg.conf file is no longer used by default, things are auto-detected and configured on start.
« Last Edit: July 02, 2017, 04:12:05 pm by nightflier »
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #5 on: July 02, 2017, 07:08:57 pm »

is there a way to override auto detection and set up a permanent X11 configuration? for what is worth, when the keyboard doesnt work in the root account it's only the right side of it which is screwed up, the left side works well, I don't know what kind of configuration causes this behavior. I still like the VL 7.1 light version better, at least as a main distro because on this old presario c500 just worked so well, found all the hardware easily and is very fast, yet I.m interested in testing the VL 7.2 std version to see how it works. I have a few other questions which I'm going to post separatedly.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4426
Re: keyboard set up doesnt work
« Reply #6 on: July 03, 2017, 04:18:56 am »

Yes, you may manually override auto-detection. The recommended way is to use individual files for each instance in the "xorg.conf.d" directory.

There are several guides available from web search, but it would look something like this:
Code: [Select]
/etc/X11/xorg.conf.d/00-keyboard.conf

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "kbd"
  Option "XkbModel" "pc105" # or pc104
  Option "XkbRules" "xorg"
  Option "XkbLayout" "es"
EndSection
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3479
Re: keyboard set up doesnt work
« Reply #7 on: July 03, 2017, 10:25:21 am »

You might give this a shot ... this is another way to do it.  But be advised... this will work for the GUI desktop... probably not for the text interface.

Code: [Select]
cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d/
nano -wc /etc/X11/xorg.conf.d/90-keyboard-layout.conf


Look for the option that says "Option "xkbLayout" " and change the value to a valid layout.  You can look up the possible values listed in /usr/share/X11/xkb/rules/base.lst.  In this case, Spanish is desired, so "es" would be the value to use.

Hope this helps.

_EDIT_
You may need to un-do anything else you've done before this.  Also, this *should* make it work accross the board all through-out X

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4426
Re: keyboard set up doesnt work
« Reply #8 on: July 03, 2017, 11:22:45 am »

Here is what I got after running commands "vlocaleset", then "vkmapset" and rebooting.. do you get a different result?
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #9 on: July 03, 2017, 02:21:20 pm »

as root I get:
qwerty456*asdfgh123-{}<zxcvbn0,.+
QWERTY2D2C*ASDFGH[]>ZXCVBN;2~

ain't that weird?

now I'm gonna try the command you suggested
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #10 on: July 03, 2017, 03:11:50 pm »

I tried this option

/etc/X11/xorg.conf.d/00-keyboard.conf

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "kbd"
  Option "XkbModel" "pc105" # or pc104
  Option "XkbRules" "xorg"
  Option "XkbLayout" "es"
EndSection


and when I reboot it says there's an error with Xorg configursation and goes to the text login
so I removed this file and rebooted and xorg worked again,
so I edited the file /etc/X11/xorg.conf.d/90-keyboard-layout.conf
and changed "us" for "es" and now in the normal user the keyboeard works perfectly with the spanish layout, but when I login as root it still acts weird.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4426
Re: keyboard set up doesnt work
« Reply #11 on: July 03, 2017, 06:22:50 pm »

normal user the keyboeard works perfectly with the spanish layout, but when I login as root it still acts weird.

I'd call that "close enough". You should not run X as root anyways. Nice work!   ;D
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #12 on: July 04, 2017, 07:17:08 am »

thanks for the help. as you say the important thing is that the computer is functional, yet I´m still curious as why there is a different behavior for the root account. It is a good thing that one can use the "su"command from another user account, otherwise I'be in trouble. Also, as a bug report,  the vasm application doesn´t seem to work as it doesn´t change the keyboard layout to spanish (I didn't try other languages)
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4426
Re: keyboard set up doesnt work
« Reply #13 on: July 04, 2017, 08:09:11 am »

Yeah, several things are involved in setting a user's environment, and they can conflict with each other. Advanced desktop environments like XFCE have their own keyboard selector, VL Light's IceWM does not. By default the root account is intended for limited use.

The issue is not unsolvable, with advanced tweaks you can make your root account whatever you like. At your own risk, of course.  ;)

Bug report received.
« Last Edit: July 04, 2017, 08:10:44 am by nightflier »
Logged

black-clover

  • Member
  • *
  • Posts: 83
  • user
Re: keyboard set up doesnt work
« Reply #14 on: July 04, 2017, 12:48:02 pm »

well, screwing up keyboard configuration for root might well be another effective way of  preventing users from messing up the distro. It certainly would have benn better for me that way a few times
Logged