VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Libre Office 5.3 Base problem  (Read 533 times)

black-clover

  • Member
  • *
  • Posts: 91
  • user
Libre Office 5.3 Base problem
« on: August 07, 2017, 03:40:49 pm »

Hi
I've tried to use the database program in Libre Office 5.3 on VL-7.2-STD-RC3  but when I click on the choice for setting up a new database or opening an existing one it just crashes. I tried installing the Java Runtime pkg because it seemed required but it still doesn't work. Anyone knows if is there some other package that needs to be installed in order to make it work?
Logged

overthere

  • Vectorian
  • ****
  • Posts: 1451
Re: Libre Office 5.3 Base problem
« Reply #1 on: August 08, 2017, 03:48:15 am »

Hi
Having the same issue with base here. found no solution...so far

Are you having any issue with the other five applications in the suite?

 I found no issue with the word, spread sheet and impress when creating and saving a file, not extensive tests but happy to have the apps

but just attempted to create a data base with the wizards defaults and it crashed. if confirmation helps for the moment
Logged
Everything Is Relative

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4446
Re: Libre Office 5.3 Base problem
« Reply #2 on: August 08, 2017, 06:33:05 am »

Definitely a bug, it is consistently reproducible.
Logged

overthere

  • Vectorian
  • ****
  • Posts: 1451
Re: Libre Office 5.3 Base problem
« Reply #3 on: August 08, 2017, 08:30:31 am »

I am using the 32 bit std version, is it the same on 64 bit? some google threads suggest it is a 32 bit issue with linux and could be a kernal patch that effects java but I am speculating at the moment

may be worth a look

https://ask.libreoffice.org/en/question/120447/libreoffice-base-32bit-crashes-on-linux-tried-multiple-configurations/?answer=120463#post-id-120463

https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg1437925.html
« Last Edit: August 08, 2017, 08:38:45 am by overthere »
Logged
Everything Is Relative

black-clover

  • Member
  • *
  • Posts: 91
  • user
Re: Libre Office 5.3 Base problem
« Reply #4 on: August 08, 2017, 10:42:44 am »

The other apps seems to work fine. I definitely think it is a Java Runtime issue cause I tried an installed version of Libre Office in another distro and also on Windows and I got similar problems with the Data app complaining it couldn't find Java.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4446
Re: Libre Office 5.3 Base problem
« Reply #5 on: August 08, 2017, 10:46:01 am »

Yep, tested on 64-bit. After installing LO and openjre I can create and edit databases.

Good find, overthere.  :)
Logged

overthere

  • Vectorian
  • ****
  • Posts: 1451
Re: Libre Office 5.3 Base problem
« Reply #6 on: August 08, 2017, 12:06:59 pm »

well that's good news for VLocity users thanks for confirmation. Is the kernel parameter workaround (stack_guard_gap=1) a possibility for 32 bit VL users? and how to pass it. it is suggested to be a security risk but may be effective for users who must have a working data base and willing to take the risk..
Logged
Everything Is Relative

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4446
Re: Libre Office 5.3 Base problem
« Reply #7 on: August 08, 2017, 12:46:52 pm »

32-bit: After adding "stack_guard_gap=1" to boot parameters, it works for me.

The easiest way to test is to manually do a one-time edit when the system starts. At the grub screen, press "e" to go to edit mode. Add "stack_guard_gap=1" after the "resume=/dev/xxx/", then press F10 to boot.

I don't know how that may affect security. This would be a work-around for individual users willing to dig into it. To add the boot parameter permanently, edit /etc/default/grub (as root), adding the string to the GRUB_CMDLINE_LINUX_DEFAULT line, right after the resume entry. After that, you need to run command "grub-mkconfig -o /boot/grub/grub.cfg".
Logged

overthere

  • Vectorian
  • ****
  • Posts: 1451
Re: Libre Office 5.3 Base problem
« Reply #8 on: August 08, 2017, 01:48:39 pm »

thanks very much for the how to pass, yes this appears to work, hope that helps the original poster
Logged
Everything Is Relative

black-clover

  • Member
  • *
  • Posts: 91
  • user
Re: Libre Office 5.3 Base problem
« Reply #9 on: August 08, 2017, 09:05:46 pm »

I hadn't have the chance to try the kernel fix yet.
For the moment I installed Calligra which seems a nice office suite, the database works just fine and doesn't need java.
Just for curiosity, I tried Libre Office Data on my sister's laptop which is 64 bits and it didn't work. I installed Java from the Oracle web page and still it doesn't work.
Logged

black-clover

  • Member
  • *
  • Posts: 91
  • user
Re: Libre Office 5.3 Base problem
« Reply #10 on: August 08, 2017, 09:12:33 pm »

Changed the boot parameter and now it works fine. Thanks.
Logged