VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: 7.2 lite slow to Bootup  (Read 853 times)

gaztoo

  • Member
  • *
  • Posts: 3
7.2 lite slow to Bootup
« on: August 04, 2018, 07:50:39 pm »

I have loaded VL 7.2 Lite onto a 15 year old HP Compaq presario laptop (with AMD Athlon CPU, 256MB ram).
It runs OK but the bootup speed is very slow. The load pauses for several minutes after the following line is displayed..
Triggering udev events: /sbin/udevadm trigger  --action=add
Following the pause there is one or more lines about processes being killed.
Then the load proceeds OK until it gets to the line....
Setting up apm
where it again pauses for several minutes before finally completing startup and displaying the User login box.
Being rather new in the Linux world, I am guessing that the pauses are due to unsupported devices and the lack of apm in the AMD cpu.
The laptop has NO wifi facilities, a dial up modem which is not used , and several card slots.
Network connection is via inbuilt Ethernet.
I have read the VL 7.1 installation guide where it mentions that several commands may be required
ie  linux pci=noacpi, linux acpi=off, linux apm=off
My question is - am I on the right track with this assumption, and if so, what and where do I find the file to add these commands to?
« Last Edit: August 05, 2018, 03:15:00 pm by gaztoo »
Logged

roarde

  • Vectorian
  • ****
  • Posts: 776
  • it's enough
Re: 7.2 lite slow to Bootup
« Reply #1 on: August 06, 2018, 07:44:21 am »

It's probably mainly lack of RAM leading to heavy swap. 7.2 Light was tested to a minimum of 256MB, but it did indeed perform there minimally, i.e. not well.

OTOH, it's possible the processor doesn't have a couple of capabilities that are necessary for the kernel, as compiled. Get a boot and post the results of the following. Regular user will do:
Code: [Select]
sed -ne '/^model name/p;/^flags/{p;q;}' /proc/cpuinfo
"Athlon" covers a bit of ground, so that helps narrow it down. Model name/number shows which processor is being dealt with. The main flags being looked for are "pae" and "nx". Won't run properly without them, but nx is hard to check for automatically, thus the manual listing.
Logged
Robert

gaztoo

  • Member
  • *
  • Posts: 3
Re: 7.2 lite slow to Bootup
« Reply #2 on: August 06, 2018, 09:17:28 pm »

G'Day roarde
Many thanks for the reply to my post.
I just might add that during the times when the boot sequence pauses, there is virtually no disk activity (perhaps a quick access in 30 secs or so), so I do not feel that it is paging during these pauses.
The following is the response to the command that you requested that I run.

robyn:$ sed -ne '/^model name/p;/^flags/{p;q;}' /proc/cpuinfo
model name   : mobile AMD Athlon(tm) XP2200+
flags      : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext

3dnow 3dnowprefetch vmmcall

I also ran lscpu which returned

Architecture:          i686
CPU op-mode(s):        32-bit
Byte Order:            Little Endian
CPU(s):                1
On-line CPU(s) list:   0
Thread(s) per core:    1
Core(s) per socket:    1
Socket(s):             1
Vendor ID:             AuthenticAMD
CPU family:            6
Model:                 8
Model name:            mobile AMD Athlon(tm) XP2200+
Stepping:              1
CPU MHz:               1789.080
BogoMIPS:              3578.16
L1d cache:             64K
L1i cache:             64K
L2 cache:              256K

and also   cat /proc/cpuinfo

processor   : 0
vendor_id   : AuthenticAMD
cpu family   : 6
model      : 8
model name   : mobile AMD Athlon(tm) XP2200+
stepping   : 1
cpu MHz      : 1789.080
cache size   : 256 KB
physical id   : 0
siblings   : 1
core id      : 0
cpu cores   : 1
apicid      : 0
initial apicid   : 0
fdiv_bug   : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 1
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext

3dnow 3dnowprefetch vmmcall
bugs      : fxsave_leak sysret_ss_attrs
bogomips   : 3578.16
clflush size   : 32
cache_alignment   : 32
address sizes   : 34 bits physical, 32 bits virtual
power management: ts fid vid

I have also attached a file containing /var/log/ files for messages, debug and syslog if they are of any help.

You might notice an error shown at the end of the syslog that indicates that the laptop was not shut down correctly.
This arises due to the fact that when Shutdown is selected, an orderly close down takes place and the last entry on screen reads
[1396.19006] reboot: Power down
The laptop does not power off, and needs the Power button to be pressed for several seconds to close.
« Last Edit: August 06, 2018, 09:21:00 pm by gaztoo »
Logged

bigpaws

  • Administrator
  • Vectorian
  • *****
  • Posts: 1896
Re: 7.2 lite slow to Bootup
« Reply #3 on: August 07, 2018, 07:51:06 am »

There are several areas that can create this problem.

1. RAM is minimal may be fixed using a bigger swap file
    if the drive is large enough. At least 2G for swap file.

2. The hard drive shows using udma100 that is a real bottleneck.

3. I see the problem you list about your hard drive. You can try fsck
    to test the hard drive. It may also be the amount of errors on the
    hard drive.

VL 7.2 has a lot of services to aid in configuration of hardware. This
comes at a price of using more resources.

I hope this gets you started.

Bigpaws
Logged

quake1

  • Member
  • *
  • Posts: 4
  • user
Re: 7.2 lite slow to Bootup
« Reply #4 on: August 08, 2018, 02:30:22 am »

Maybe due to the lack of RAM leading to heavy swap
Logged

gaztoo

  • Member
  • *
  • Posts: 3
Re: 7.2 lite slow to Bootup
« Reply #5 on: August 14, 2018, 10:56:36 pm »

Thanks again for the replies to my post. Apologies for the delay in coming back but I have been a bit time poor recently.
@quake1 -  As I mentioned above, I do not think that the long pauses in the bootup routine are caused by paging. There just isn't enough disk activity in these periods to support this premise. I do agree that the 256MB ram is marginal at best and it does page when the system is up and I go to open a program. However, the owner of the laptop is happy to accept this situation as they do not want to spend money on more ram (or a SSD) unfortunately.

I may have unintentionally stumbled on a reason for the long pauses in the boot up sequence when I started the laptop up with no Ethernet connected. (remember, the laptop does not have inbuilt wifi).
With no Ethernet the laptop booted up with NO pauses at all!
From memory, I then plugged in the Ethernet and conected to the Network OK. I then did a restart only to find that the pauses in the boot routine had returned. Next I did another restart with no Ethernet connected and found that the pauses were again evident. Then, after logging in and plugging in the Ethernet I found that I could not connect to the network as the wicd daemon had closed down. Since then I have done a number of restarts and have not been able to connect to the network. After logging in there is a message along the lines " wicd needs to access the network cards" - enter password - I enter the Admin password - get another error message - "could not connect to the wicd D-Bus interface - check wicd  log" - "wicd daemon has closed down and will not function until a restart". After many restarts, I get the same result. I also cannot read the contents of the wicd log as access is denied (as su ). I am at the point where I am going to reload the software from the CD, but first I would ike to set (or verify) the existing state of the swap partition.

@bigpaws -  Regarding making a larger Swap partition - I feel that the current Swap is around 330MB.
I had previously loaded VL7.2 before my initial post several times.
On the second last occasion I had used GParted (from a live CD) to partition the HDD (20GB) for a 5GB swap and 15GB ext4 partition. I then did an "Advanced" install but when I encountered the issues listed above, I then re-installed it using the Automatic option. I feel that when this procedure made a swap partition, it decided on the 330MB size. Since getting your post I have tried to run GParted to verify the existing partitions, but GParted will now not run. I have dowloaded the GParted program into VL and tried to run it - again, without success. It also will not run when I try to boot from my GParted live CD. I am at a loss as to why. I just get a series of error messages.

I think that I have spent enough time on this old dog. Time to send it to the knackery........
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4457
Re: 7.2 lite slow to Bootup
« Reply #6 on: August 15, 2018, 05:26:46 am »

@gaztoo, if you want to experiment any further: Since you don't use wifi, I would suggest removing wicd and configure your ethernet manually. You can do this from a root terminal with command "removepkg wicd". After a reboot, issue commands: "ifconfig eth0 up" and "dhcpcd eth0" (assuming your ethernet card is eth0.. it could be different). If this works, you can just add those to your rc.local file.
Logged