VectorLinux
July 29, 2014, 04:44:59 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How-to: Have Vector Linux 5.8 resolve NetBIOS addresses  (Read 2545 times)
ThunderEagle
Member
*
Posts: 9


« on: March 17, 2007, 11:13:58 am »

A little back ground.  I already have a home windows network and I'm putting VL5.8 on an old machine, of course I would like it to play nice with my existing windows network.  Here are the steps I had to take on VL 5.8 to have the Linux box resolve the NetBIOS names on my network.

I'm running a LinkSys router with DHCP enabled, and at least for now, I want to keep it that way.  I have two Win XP pro machines and and an older Win ME laptop.

I'm going to assume you have Samba installed.

Symptoms:
After basic configuration, I could ping the Linux box from the win boxes by NetBIOS name, I could ping the win boxes from the Linux box by IP, but no resolution would happen by name.

Solution
1. Enable SAMBA (VASM->SUPER->SERVICE->SVRSET->4  Select samba)
2. Edit the smb.conf
    Set the GROUPNAME  in /etc/samba/smb.conf
      ex:  GROUPNAME = teagle
    Replace 'teagle' with your workgroup name.
3. add 'wins' to the hosts line in /etc/nsswitch.conf
                 hosts:       files dns wins
4. disable firewall by opening a terminal window, su to root:
chmod a-x /etc/rc.d/rc.firewall
chmod a-x /etc/rc.d/init.d/firewall

The firewall must be disabled in this way.  If you disable it in VASM either under SVRSET or the NETWORK/FIREWALL options, you will not even be able to ping the Linux box from the win boxes.  Opening the NetBIOS ports in the firewall also do not work.

Risks
You are disabling the firewall, if your box is not behind a router, this isn't always a very good idea.  While a router is not foolproof, any basic SOHO router providing NAT generally does a good job at keeping most scanning type things out of your network.  I would hope anyone needing this information already has at least a basic understanding of what this implies.

More information:
I found the following site: http://samba.netfirms.com/ to be very informative in terms of easy to understand Samba configuration.
Logged
stoichyu
Packager
Vectorite
****
Posts: 369



« Reply #1 on: March 29, 2007, 02:32:42 am »

There is a solution to all that without disabling the firewall script (you still have to do steps 1-3 though). It involves modifying the firewall script. There are two ways to editing your firewall script. One is directly editing /etc/rc.d/init.d/firewall for everything, while the second is to change  line 93 of /etc/rc.d/init.d/firewall, REQUIRE_EXTERNAL_CONFIG to yes, then editing your /etc/firewall.conf for any subsequent changes.

Let's get to the real part shall we. One thing you must first know is the subnet of your network. Something like 192.168.1.0/24. An easy way to find this out is getting your ip address and changing the last number to 0 and then append /24. For example, your ip address is 10.0.2.232, your subnet mask would be 10.0.2.0/24. Now we edit the /etc/rc.d/init.d/firewall or /etc/firewall.conf based on what you chose earlier.

Assuming your subnet is 10.0.2.0/24, we edit the line that says:
Quote
PERMIT="192.168.0.0/24 445/tcp 137-139/tcp 445/udp 137-139/udp"
to
Quote
PERMIT="10.0.2.0/24 445/tcp 137-139/tcp 445/udp 137-139/udp"

then do a "service firewall restart" and you can get netbios name resolution and still have a firewall.
Logged

There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!