VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VPN client  (Read 5771 times)

elifarley

  • Member
  • *
  • Posts: 10
    • org.ecc - Java Blog
VPN client
« on: March 18, 2007, 06:35:49 pm »

I need a VPN client.
Does anyone know where I can get a suitable package ?

Thanks!
Logged
Vector Linux 5.8 SOHO Final   May-15-2007

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: VPN client
« Reply #1 on: March 18, 2007, 06:55:53 pm »

http://vectorlinux.osuosl.org/veclinux-5.8/extra/net/openvpn-2.0.9-i586-1vl58.tlz

Download above, open a terminal, navigate to the directory where you downloaded it, login as root (su), type ¨installpkg nameofpackage¨.

« Last Edit: March 18, 2007, 07:06:40 pm by lagagnon »
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

carsten

  • Vectorite
  • ***
  • Posts: 137
  • I know why birds sing ...
Re: VPN client
« Reply #2 on: May 29, 2007, 06:32:47 am »

Hy,

I tried the same, but when executing it I get following message :

openvpn: error while loading shared libraries: liblzo2.so.2: cannot open shared object file: No such file or directory

This liblzo is not in the repository. What next?
I am running VL 5.8 on my box,

Carsten
Logged
Tam exacte ut oportet, non ut licet!

forbajato

  • Packager
  • Member
  • ****
  • Posts: 46
Re: VPN client
« Reply #3 on: May 29, 2007, 06:45:29 am »

Try searching the repos for lzo.  My openvpn uses this fine (though I actually ended up compiling mine from source).  When I do a search for lzo I get the following:

Code: [Select]
lzo-2.02-i586-1vl58 [inst=no]: LZO (a real-time data compression library)
lzo-2.02-i486-2ahl [inst=yes]: lzo 2.02 (Data compression library)
gnutls-1.2.9-i486-4cf [inst=no]: gnutls

My version of openvpn (2.0.5) runs fine against this lzo compression library.

HTH, not sure whether the newer 2.0.9 openvpn work on this library or not.

forbajato
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: VPN client
« Reply #4 on: May 29, 2007, 12:22:44 pm »

The problem is that the openvpn package was moved to the extra repo, while it's dependency, lzo is still in the testing repo.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

TommyChaos

  • Member
  • *
  • Posts: 1
Re: VPN client
« Reply #5 on: June 01, 2014, 09:15:17 pm »

You choose what SunVPN plans to avail at http://www.sunvpn.com/. SunVPN.com offers plans worth $ 9.99 for mobiles and $14.99 for SSL or both SSL and mobile.
Logged