VectorLinux
December 20, 2014, 06:16:29 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: i follow the wifi howto (by easuter) with the same ID key but it failed :SOLVED  (Read 9883 times)
tagazoup
Member
*
Posts: 15


« on: April 06, 2007, 11:16:18 am »

hello{sorry for my english}
first, thanks easuter for this howto which is very detailed !


I try to use an USB key  "SMCWUSB-G" which have the same ID number =083a:4505 than in the Wifi Network Howto ...
so it might be good ...but it failed !

I try Linux since a short time and i am really a new one ,a "newbie",
so please let be clear in your explanation!
I have installed Vector linux (5.18 normal ,i believe)
on an old notebook Toshiba satellite Pro 490.

Before to try the ZD1211 driver ,i have tried ndiswrapper very quickly
and have seen that it worked but only only without security key.
I saw my "Box" which emitted wifi and its essid.
First i try wpa with ndiswrapper = it hadn't work but i didn't knew ,at this stage ,to configure wpa_supplicant.
i did it again with the zd1211b driver than i install with makefile modifies with # set to 1 for zd1211b
ZD1211REV_B=1 .(saw at the Zyda site)
When i launch modprobe zd1211b it says nothing but vasm don't see any network card.
My key don't blink;it did it with ndiswrapper.
when i do :
wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
i have a lot of errors.
do i need to remove ndiswrapper ?
could you help me ?


thanks.
« Last Edit: May 15, 2007, 02:35:07 pm by tagazoup » Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #1 on: April 06, 2007, 05:13:49 pm »

Hi there!

So you are using the zd1211b after all?
if yes then that is fine, you don't have to remove ndiswrapper.

Please post the contents of /etc/modprobe.conf here.
Also, what type of encrypted connection do you need, WEP or WPA?
Logged

tagazoup
Member
*
Posts: 15


« Reply #2 on: April 07, 2007, 03:56:18 am »

hello and thanks about your quick answer !

my modprobe.conf is following :
# /etc/modprobe.conf (old location for Linux 2.6+ config)
#
# The use of this config file is deprecated if you are using a
# 2.6.x or newer kernel.  Instead, create files in the
# /etc/modprobe.d/ directory containing modprobe options.
#
# For more information, see "man modprobe.conf".

alias wlan0 zd1211b
#alias wlan0 ndiswrapper
#alias wlan1 zd1211rw

{in fact, in "/etc/modprobe.d/" there's only a link to /etc ...is it normal ?}

I have uninstall ndiswrapper to be sure.
I have verified that zd1211b was in the kernel config (2.6.18.5) and it is there:
>device driver/network device support/wireless LAN/Zydas ZD1211/ZD1211B USB-wireless support
Last night i did my "first one" compilation to be sure that zd1211b would be used at the boot.I don't know if it was usefull but i did it !
Do we have to compil again when it's only module which are new marked in the kernel menu ?
The result it the same than before:i do modprobe zd1211b,there is no error but thats all !

I have parallel questions :
1/Why do i have to do :
INTERFACE="eth0 wlan0"
i don't understand the reason?

2/How can i have the Vector version ?

Thanks to help me !
Logged
tagazoup
Member
*
Posts: 15


« Reply #3 on: April 07, 2007, 06:46:14 am »

sorry,
I forgot to say that it's WPA-PSK than i want to use !

bye

tagazoup
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #4 on: April 09, 2007, 03:59:09 pm »

You can see which version of VL you are using by entering this command:

Code:
cat /etc/vector-version

Ok then, the first thing to do is to blacklist the zd1211rw module, since it is still experimental and it interferes with zd1211b.

Open /etc/modprobe.d/blacklist as root and add this line to the end of the file:

Code:
blacklist zd1211rw

Now make sure that zd1211rw is not running anymore be removing the module:

Code:
rmmod zd1211rw

And now insert zd1211b:

Code:
modprobe zd1211b

Bring up the network interface:

Code:
ifconfig wlan0 up

After you have done all that, please post what you get when you run this command:

Code:
iwlist wlan0 scan

Sorry for taking so long to answer  Embarrassed
Logged

tagazoup
Member
*
Posts: 15


« Reply #5 on: April 10, 2007, 01:06:22 am »

hello,

I have done what you said but it don't answer what i thought.

I have blacklisted zd1211rw
but when i write rmmod zd1211rw it says that zd1211rw does not exist in /proc/modules,so it's not the problem.

As i was waiting ,i have installed ndiswrapper again because you said it was ok to have the two drivers :i reply to your post with wifi but not encrypted.
I have tried several times with wpa but it doesn't works.
The files in /etc/wireless:MyEssid.essid.conf and MyEssid.wpa.conf are ok (i think).
Why there is another interface.conf in /etc/wireless ?I modify this one too !

For zd1211b i wonder if it loaded at boot:How can i see it ?
When i do modprobe zd1211b it says nothing.

Is Ndiswrapper is known to work with WPA-PSK  ?

Thanks for your reply

Bye
Logged
tagazoup
Member
*
Posts: 15


« Reply #6 on: April 10, 2007, 11:19:55 pm »

hello,

I'm sorry because i forgot to send the result of
iwlist wlan0 scan
Here it comes:
wlan0     Scan completed :
          Cell 01 - Address: 00:17:33:21:13:A5
                    ESSID:"G_fifi"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.412 GHz (Channel 1)
                    Quality:67/100  Signal level:-53 dBm  Noise level:-96 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0

I don't think it interests you because it works with ndiswrapper above.
In fact ,if it's too hard with zd1211b we can try have WPA with Ndiswrapper first...

Bye
tagazoup
Logged
tagazoup
Member
*
Posts: 15


« Reply #7 on: April 16, 2007, 05:22:45 am »

is there someone to help me ?

i use my ndiswrapper driver for my wifi dongle but without security key now.
I want absolutely to use it with WPA ,
either with zd1211b (native linux)driver (but it seems it doesn't work) or  with windows driver.

thanks
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #8 on: April 17, 2007, 11:07:53 am »

Sorry for taking so long to answer  Undecided

Can you tell me what encryption protocol for WPA your router is using?
If I'm not mistaken there are a couple of different ones.
Logged

tagazoup
Member
*
Posts: 15


« Reply #9 on: April 17, 2007, 01:00:27 pm »

hello,
i'm not sure to be able to answer to your question.
The only thing i know is :it's WPA-PSK.
Is this specification that you want ?
bye
Logged
tagazoup
Member
*
Posts: 15


« Reply #10 on: May 07, 2007, 02:37:39 am »

hello,

is there someone to help me ?
my problem is always the same !

thanks
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #11 on: May 07, 2007, 03:39:48 am »

Damn! Sorry about this  Embarrassed

First of all for the WPA configuration, post the contents of /etc/wpa_supplicant.conf so we can see what configuration settings you are currently using for WPA
Logged

tagazoup
Member
*
Posts: 15


« Reply #12 on: May 10, 2007, 11:51:09 am »

hello,

I  was waiting  for  the  vector site  because it was offline  since  2 days !



here are my configuration files about wifi=



>My wpa_supplicant.conf=



ctrl_interface=/var/run/wpa_supplicant



network={

   ssid="MYSSID"

#   scan_ssid=1

   proto=WPA

   pairwise=TKIP CCMP

   group=TKIP

   key_mgmt=WPA-PSK

   psk="MYKEY"

}



>My modprobe.conf=



#alias wlan0 zd1211b

alias wlan0 ndiswrapper



>My ifplugd.conf=



INTERFACES="eth0 wlan0"



# Additional parameters for ifplugd.

#ARGS="-fwI -u0 -d5 -pql"

#ARGS="-fwI -t2 -u0 -d10"





>>I have tried severals things but it's my last state.



i send this message with wifi key but without security key again.


What do i have to do before the "WPA" step than you described Huh??



>Do i have to do only "wpa_supplicant -B -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf"



OR (more logical)



>do i have to type (as in "wifi with no security key" explanation):



iwconfig wlan0 essid "xxxx xxxx xxx"

iwconfig wlan0 mode Managed

iwconfig wlan0 channel Auto

iwconfig wlan0 ap any

wpa_supplicant -B -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf

dhcpcd -t 25 -d wlan0



I have tried the line above without success.



How could i know if wpa_supplicant succeeds or not (it says nothing !) ?



thanks to help me.
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #13 on: May 11, 2007, 01:44:07 pm »

When using wpa_supplicant, you won't need to use iwconfig at all.

Anyway, I was doing some research and it seems that with more recent ndiswrapper versions ( like the one on VL 5.8 ) should use -Dwext instead of -Dndiswrapper:

Code:
wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

Try using the command as indicated now, and see it it solves your problem.
Please post back with your results (if you are getting errors or messages in your terminal, post them here)
« Last Edit: May 11, 2007, 02:55:06 pm by easuter » Logged

tagazoup
Member
*
Posts: 15


« Reply #14 on: May 14, 2007, 02:04:26 am »

hello easuter,

(do you speak french?)

I have tried what you suggested but it doesn't works.

I 've made a little script, not to have to type the same command every time=

#!/bin/sh
#script tagazoup WPA wifi

echo "driver ndiswrapper"
#remove if already here
modprobe -r ndiswrapper
modprobe ndiswrapper
echo "scan  connexion wifi"
iwlist wlan0 scan

echo "Kill all services using  wpa"
killall wpa_supplicant
echo "un-validation dhcp"
rm /etc/dhcpc/dhcpcd-wlan0.pid
#
wpa_supplicant -B Dwext -iwlan0 -c/etc/wpa_supplicant.conf
#wpa_supplicant -B Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf
#
echo "ask for dhcp"
dhcpcd -t 25 -d wlan0
echo "At the END,if IP Address it's OK !"

and i obtain what is below=

driver ndiswrapper
scan  connexion wifi
wlan0     Scan completed :
          Cell 01 - Address: 00:17:33:21:13:A5
                    ESSID:"G_fifi"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.412 GHz (Channel 1)
                    Quality:62/100  Signal level:-56 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK 

Kill all services using  wpa
wpa_supplicant: no process killed
devalidation dhcp
rm: ne peut enlever `/etc/dhcpc/dhcpcd-wlan0.pid': no file or directory to remove
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
ask for dhcp
dhcpcd: MAC address = 00:13:f7:63:6a:5d
At the END,if IP Address it's OK !

do you have an idea ?

tagazoup
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!