VectorLinux
April 23, 2014, 10:22:44 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: CPU overheating on laptop  (Read 4366 times)
frankbonatelli
Member
*
Posts: 19


Grampa time 1.237 (bun in the oven) Now thats life


« on: April 07, 2007, 09:02:59 am »

Hey all in VL land
First post for help and I hope all is ok (location and subject et all)
Sincerely love this distro. It is so grass roots It has become my new home!!
Thanks for all your hard work and efforts.

A question to be posed for them in the know!
How can I go about setting my laptop fans to accellarate when the work load increases (i believe this is known as throttling)? Twice now the system has Simplly shut down Shocked and would not start till it cooled down. Yes they Work (they are brand new two month back) and as for work load I was trying to Down load a good copy of a VL ISO while doing some graphics manipulations with Inkscapeand listening to tunes with XMMS. Nothing out of the ordinary
On any other distro that I have used (many many different ones till I found my home. VL all the way)
this was always an automatic thing which I never had to dig into.
My VL is the 5.8 SOHO deluxe gold (sort of, and I say this because I have been trying now for three weeks to get a good ISO burned to disc and never seem to be able to. I get XFCE on but can not get KDE or any of the disc two extras.
The laptop is a Toshiba satellite P30 p4 2gig ram 150 gig hard drive.

Thanks for any lite you may shed on this dark subject.
--------------------------------------------------------------
Linux is about patience and persistence
Logged
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #1 on: April 07, 2007, 11:50:25 am »

See if this post on vcpu-freq helps you:

http://www.vectorlinux.com/forum2/index.php?topic=1995.msg11510#msg11510

Keep us posted Smiley

LLL
Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
frankbonatelli
Member
*
Posts: 19


Grampa time 1.237 (bun in the oven) Now thats life


« Reply #2 on: April 07, 2007, 01:07:54 pm »

Hey Thanks for the bread crumbs but........................................................

I have been down the path before and to be honest the vcupfreq dose  not seem to change any thing. I apply all the settings and set for throttled or "ondemand" load at start load on boot save on exit. Tryed together and on there on each separately. No love.
I have scoured the forum in depth and have come up empty even google hasn't been giving up the treasured bit of knowledge. The search continues.
Logged
frankbonatelli
Member
*
Posts: 19


Grampa time 1.237 (bun in the oven) Now thats life


« Reply #3 on: April 07, 2007, 01:16:44 pm »

Further to the above Heating issue.

I just tryed launching from Comand line and this error was spit at me. Any further thoughts?

root:# vcpufreq
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
sh: /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed: Permission denied


Also noticed it says I have two CPU on dec. This is not so. I have one p4 running @ 3.04 Huh Strange.
Logged
bigpaws
Vectorian
****
Posts: 1834


« Reply #4 on: April 07, 2007, 06:57:48 pm »

Quote
Also noticed it says I have two CPU on dec

I belive from what I have googled on that laptop that it may have
HT which will show as 2 CPUs.

My laptop had overheating problems from the fan not running much.

After a kernel recompile to match my hardware everything ran better.
There are options that are available after the kernel is setup to control
your fan.

HTH

Bigpaws
Logged
frankbonatelli
Member
*
Posts: 19


Grampa time 1.237 (bun in the oven) Now thats life


« Reply #5 on: April 08, 2007, 11:02:36 am »

Even tho I have been in the Linux loop for years I still cringe at the thought of the kernel!

I had thought of this, maybe it is not compiled for a Toshiba with ACPI enabled, but do to a deep fear of the kernel and all it intails, i tend to look for any GUI tools to help avoid it entierly.
But we must look so look i did. 7 hours of compile test fail and compile again Shocked . So for the seventh seems to be the charm. Will wait and see as I have just now got back to a GUI and all seems to be in order. Fan still seems to be spinning to much doing nuthing and to little doing everything. Used the standard kernel that comes with the VL 5.8 standard as my SOHO gold disc (as mentioned earlier) seem to be corrupt or bad burn. standard spins on to the platter smoothly so will stick with this.

So i set all i could to point to Toshiba and acpi on now we wait to see the out come.
Thanks for all the input.
Ill keep every one posted on thing as they develop.
Logged
frankbonatelli
Member
*
Posts: 19


Grampa time 1.237 (bun in the oven) Now thats life


« Reply #6 on: April 21, 2007, 04:39:40 pm »

Well the fan dose now throttle under hard labour but it still dose not get fast enough to cool the system down (with other distros it would spin so fast i could hardly stand it but it always stayed cool) under any hard proses. Thought I had it worked out but last night I was trying to get evolution mail running using source code and when Making file she over heated and shut down. Its stable under normal load but would still like to solve this.

If some one has further knowledge the wish to share it would be greatly appreciated.
Logged
fvj
Member
*
Posts: 10


« Reply #7 on: June 01, 2007, 07:27:20 am »

First of all, bonjour from France to everybody sharing their knowledge here. VL is great (still running a 5.1 on a Compaq 166 mHz 80 EDO RAM laptop and 5.8 Gold on a IBM 533 mHz 512 SDRAM!!!) even if sometimes it is like tuning a rally car, to get the full speed of driving (OK, not with those 2 boxes...). I almost found every answer here, so I will try to give back what I've found on that subject (please don't forget I'm a french native speaker  =;+)

First perhaps this can help you http://www.vectorlinux.com/forum2/index.php?topic=1401.0 (it's about P4 - P3 and AMD).

Then a description of the problems I've got and how I've solved them. It's for my main box (VL 5.8 Gold) with an AMD Athlon 64 3700+(= 2,4 gHz), but perhaps some of the tips and commands could be helpful in this case, I don't know, I will just explain it...

First I wanted to use vcpufreq and I got that "cpufreq driver UNAVALAIBLE", even if it was after a fresh install! I've made a search on the forum and found this http://www.vectorlinux.com/forum2/index.php?topic=3047.0 . Like it is said I made a
Code:
modprobe -l | grep powernow
and get the output saying the modules are there.
Code:
lsmod
didn't shown nothing like this
Code:
modprobe powernow-k8
worked without error
Code:
lsmod
  showed the module and then I wrote "/sbin/modprobe powernow-k8" (without quotes) in /etc/rc.d/rc.modules, because like in the topic 3047.0, I don't have a line about this inside (why, I don't know).
I get back to vcpufreq, it was working and I put "ondemand", to get the full power just when needed, saved and choose every options for loading on boot time.
After a reboot, I wanted to have a look back to it and i got a message telling me "unable to set desired scaling governor" and that I have to "modprobe cpufreq_ondemand". I made it, no errors and then wrote also "/sbin/modprobe cpufreq_ondemand" in rc.modules and rebooted the box.
Code:
lsmod
showed now "cpufreq_ondemand" used by "1" (without name), "powernow_k8" used by "0" and "freq_table" used by "1" (powernow_k8). I get back to vcpufreq, the same stupid message and I could set everything again to "ondemand". After a few reboot, it looked like it was impossible to save my setting, even if they were working in vcpufreq, because the freq was 1 gHz and no more 2,4 anymore, and this message added to the fact to have to set it back each time made me nuts!!! So I've searched furthermore and found in the Gentoo Wiki (another source of great knowledge, even if the configuration files have other names) this http://gentoo-wiki.com/HOWTO_PowerNow!
So I did
Code:
dmesg | grep powernow
to see if my CPU is well recognized and it was (perhaps there is something like this for Intel?).
Then
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
showed me my lovely "ondemand" (that was supposed to be there, nevertheless...).
I confirmed that my CPU was set (temporary @*!) to 1 gHz with
Code:
# cat /proc/cpuinfo
or
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
, then pushed it to the limits in an other console with
Code:
cat /dev/urandom > /dev/null
, which made the beast very busy (cancel with Ctrl+c), and looked back at the freq being now 2,4 gHz.
At last, I put
Code:
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
in /etc/rc.d/rc.local after the very last line and used the tip in topic 1995 "I also set up my XFCE to include the CPU Frequency Monitor in my panel (it's a plugin; right-click panel and choose 'Add New Item') so I can see what it's up to" (thanx the author).
So now, I'm writing this (and hearing the great band Frontline Assembly from Vancouver, Canada) with 1 gHz, what is really enough for it and my CPU goes wild just when it's needed, showed by the XFCE plugin (you can see it changing in "live", life is sooo beautiful  Wink...).
vcpufreq still give me the @*!<< message, and also "sh: /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed: permission denied" (the file doesn't even exist!) if I start it from the Console, but after show the right freq, so I don't care (but if somebody know why, I take it, just by curiosity...)!
So I hope that was some kind of help and not too long...
« Last Edit: June 01, 2007, 09:03:51 am by fvj » Logged
fvj
Member
*
Posts: 10


« Reply #8 on: June 07, 2007, 04:15:48 am »

Just an edit of the last post:

- by setting the CPU_FREQ_GOVERNORS with
Code:
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
in etc/rc.d/rc.local script,  with no activity, I have the slowest speed possible of my CPU (1 GHz instead of 2,4 GHZ). But if I want to change this minimum to the next step (1,8 GHZ), the settings in vcpufreq are not saved.
Writing
Code:
echo 1800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
in etc/rc.d/rc.local script does the trick!

- The file sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed appears just when the governor is set to "userspace" (it looks like it's in it that the settings manually changed are stored) and is gone with the "ondemand" mode, so my opinion is now not to care anymore about the "... : permission denied" error message.

- 1 GHZ + Xorg 7.2 + Beryl + multimedia files playing brought to some pops, glitches and troubles, so this is why I fixed the minimum to 1,8 GHZ (a bit less power saving for more fun Roll Eyes
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!