VectorLinux
September 23, 2014, 02:07:26 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2] 3 4 5
  Print  
Author Topic: 070410 - GNOME 2.18.0  (Read 29731 times)
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #15 on: April 13, 2007, 01:55:10 am »

I'm sorry guys, but I really need to say this: GNOME rocks! Thanks Easuter! You're the man!!!

The simplicity is awesome.. Graphical design is nice... Maybe this could become my new preferred DE. I'll keep testing it.  Cool

Some minor things I encountered: VASM is 2 times in the System menu, and when logged in as root the 'root terminal' doesn't start (perhaps this is normal to be like this), Sounds play nice however when going to System > Preferences > Sound and trying to test this I get: "audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: no element "gconfaudiosink" " otherwise: superb work dude!
« Last Edit: April 13, 2007, 03:04:19 am by Freeman » Logged

It's better to die 10 times, than never to have loved at all.
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #16 on: April 13, 2007, 03:46:07 am »

I just tried to change the default theme, but Gnome gave up on me and locked the screen. Nothing could be done except a cold reboot. And no, it was no kernel panic this time Smiley So now I'm searching on a way to clear/clean my last used settings, when I was logged into Gnome. Cause I can't login to it anymore.. It hangs on the Gnome splash screen. I'll report back if I succeeded to get it running again, cause I really liked what I saw. Damn, I'm glad I'm in vacation now :p

I guy with the same problem I have: http://www.physicsforums.com/showthread.php?t=158267
« Last Edit: April 13, 2007, 03:53:12 am by Freeman » Logged

It's better to die 10 times, than never to have loved at all.
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #17 on: April 13, 2007, 04:35:33 am »

Removing the dir /root/.gconf did the trick! We're back up and running Gnome...  Smiley

But now I can't logout using the little door in Gnome Sad Will search for a fix. The screens stays on: 60 seconds... Strange..

Same problem described here: http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/2004-July/006269.html
« Last Edit: April 13, 2007, 04:55:20 am by Freeman » Logged

It's better to die 10 times, than never to have loved at all.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #18 on: April 13, 2007, 06:13:48 am »

Thaqnks for the feedback Freeman.

When you tried to install new themes, did you install them using GNOME's theme manager, or by installing them directly into /usr/share/themes?
Normally what I do it download the theme from gnome-look.org, open the theme manager (System -> Preferences -> Theme) and then click on the "Install Theme" button. A dialog apears and I select the tarball I just downloaded. The theme manager then extracts the tarball and installs the theme on its own.

I've heard about problems if GDM is not installed, but haven't experienced any myself. I'll build a GDM package and if it fixes the problem I'll add it to the gnomemeta package.
Logged

Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #19 on: April 13, 2007, 06:59:06 am »

Thx for the response Easuter, but when playing around with the pre-installed themes, it always hangs when choosing Crux. I can't get around that problem.. Very weird. And it happened already for 3 times that I needed to remove the .gconf dir to get back in after playing with the theme manager.
« Last Edit: April 13, 2007, 07:03:08 am by Freeman » Logged

It's better to die 10 times, than never to have loved at all.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #20 on: April 13, 2007, 07:08:12 am »

I can't seem to duplicate your problem. After clicking on the Crux theme, it takes a few seconds to change all the themes, but after that everything is back to normal with the new look.

Can anyone else test the Crux theme and see if it gives problems?
Logged

Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #21 on: April 13, 2007, 09:45:30 am »

I am on SOHO 5.8 RC2, maybe someone else could check this as you suggested. Would be strange if I am the only on who has that problem right? We'll wait for others to test. Thx again for the fine effort Easuter. Don't want to be always negative, cause I like your package Smiley
Logged

It's better to die 10 times, than never to have loved at all.
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #22 on: April 14, 2007, 03:35:57 am »

My Limewire won't start either, think it has something to do with Java.. no error output in the terminal though. Just hanging on the splash screen.
Logged

It's better to die 10 times, than never to have loved at all.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #23 on: April 14, 2007, 04:25:54 am »

Well, it is most likely java related and nothing to do with gnome because it works fine on my gnome desktop:

http://clientes.netvisao.pt/alynnsut/limewire_gnome.png
Logged

Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #24 on: April 14, 2007, 08:50:17 am »

Indeed, are you running SOHO RC2 ?
Logged

It's better to die 10 times, than never to have loved at all.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #25 on: April 14, 2007, 12:31:31 pm »

Nope I was running 5.8 Standard.
I installed RC2 on a separate partition and then installed gnome and got the same problem as you when selecting a different theme. On Standard the themes all have previews, but on SOHO the themes appear with question marks on them and when trying to select one it freezes.....pretty weird behaviour  Huh

However, I can't seem to find what differences between SOHO and Standard would cause this since the theme package is exactly the same and has no relationship whatsoever with KDE.

I'll post back when I have new on this issue
Logged

easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #26 on: April 14, 2007, 01:36:48 pm »

Well the problem might appear if compositing is enabled:

http://gnomesupport.org/forums/viewtopic.php?t=9851&view=next&sid=bddc5a2ac9540552db242d77d0bf59eb

and

http://forums.fedoraforum.org/showthread.php?t=76997

Not sure whats different in SOHO's xorg though....

EDIT: this bug seems to have been fixed already about  a year ago, so it shouldn't apply.

I was however able to retrieve this useful bit of information from running gnome-theme-manager in a terminal in SOHO RC2:

Code:
a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.


IIRC KDE has its own GTK theme manager! That would explain why this problem doesn't appear in 5.8 Standard and why the font settings in GNOME on SOHO are the same as the ones set in the KDE GTK theme manager....

Just have to figure out how to "kill" the kde GTK theme manager....
« Last Edit: April 14, 2007, 02:00:55 pm by easuter » Logged

easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #27 on: April 14, 2007, 02:17:35 pm »

Yes! Wooohoo!  Grin

The sollution is to simply remove /root/.gtkrc-2.0 and ~/.gtkrc-2.0

The KDE GTK theme manager generates a gtkrc, but that doesn't seem to play nicely with GNOME, so simply remove it and restart X with ctrl+alt+backspace and log into gnome again.

After removing the above mentioned files, run the GNOME theme manager and the Crux theme should now have a preview and you should be able to select it just fine. It may take several seconds to apply so just be patient Smiley

This fixed it for me, but it it doesn't work for you then post back with extra details.
« Last Edit: April 15, 2007, 04:17:20 am by easuter » Logged

Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #28 on: April 15, 2007, 03:55:53 am »

Thanks for the quick answer, indeed, after removing /root..gtkrc-2.0 I can finally choose another Theme. But I have to say: yours was the best already Wink Maybe I'll hunt down later on for another theme if I feel like doing so.
I was wondering if KDE needed that file, so I logged (after removing it) back into KDE RC2 and all my settings where lost. The shortcuts I made in the menu, the desktop backgrounds, .... So maybe for users who wish to use both, the'd better think twice. For me, as a new Gnome user, it doesn't bother me that much. But thanks again, for the effort!

Oh, have you seen the log out problem now, with RC2 and Gnome?
Logged

It's better to die 10 times, than never to have loved at all.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #29 on: April 15, 2007, 09:23:41 am »

Nope, I don't get the logout problem.

Try doing this:

-logon into a failsafe terminal session as a user.
-remove any previous gnome and gconf settings:

Code:
rm -r ~/.gconf* ~/.gnome* ~/.gtk*

-then su to root and repeat those commands.

Post back with the results.
Logged

Pages: 1 [2] 3 4 5
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!