VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: After reboot it forgets permission from chmod  (Read 6522 times)

acous

  • Member
  • *
  • Posts: 78
After reboot it forgets permission from chmod
« on: May 16, 2007, 12:53:22 pm »

I give permission with this command

"chmod 666 /dev/video0"

and it works, but efter reboot it is "permission denied" again

how solve this?
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: After reboot it forgets permission from chmod
« Reply #1 on: May 16, 2007, 12:58:31 pm »

Are you using chmod as root.

You may also be able to add yourself to the video group.

Bigpaws
Logged

acous

  • Member
  • *
  • Posts: 78
Re: After reboot it forgets permission from chmod
« Reply #2 on: May 16, 2007, 01:06:34 pm »

yes I wrote su

How do I add myself to the video group?
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: After reboot it forgets permission from chmod
« Reply #3 on: May 16, 2007, 01:11:04 pm »

easiest way to fix it is add  "chmod 666 /dev/video0" to the bottom of /etc/rc.d/rc.local
You can also make a udev rule to fix it when the device is created.
you can add yourself to the video group by editing /etc/group and add your username on the line that starts with video

HTH,
Uelsk8s
Logged

acous

  • Member
  • *
  • Posts: 78
Re: After reboot it forgets permission from chmod
« Reply #4 on: May 16, 2007, 01:51:21 pm »

thanks, edited rc.local and it works

doesnt work if I plug in webcam after reboot, but that is no problem.
Logged

saulgoode

  • Vectorite
  • ***
  • Posts: 340
Re: After reboot it forgets permission from chmod
« Reply #5 on: May 16, 2007, 04:36:55 pm »

The 'video0' device is created when the camera driver module gets installed. This means that if you unplug and then reconnect your camera, the /dev/video0 link will be destroyed and then recreated.

I believe you have to manually change the ownership and/or permissions afterwards. I should be interested if there is an alternate method of which I am unaware.
Logged
A complex system that works is invariably found to have evolved from a simple system that works.

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: After reboot it forgets permission from chmod
« Reply #6 on: May 16, 2007, 10:37:33 pm »

http://reactivated.net/writing_udev_rules.html

This might help. Sad to say that I have little experience with udev myself.
Logged
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

acous

  • Member
  • *
  • Posts: 78
Re: After reboot it forgets permission from chmod
« Reply #7 on: May 17, 2007, 01:42:40 am »

Thanks for answers, this forum is very nice! but it is not my computer so not that important to be able to plug in webcam after boot. Just tell them to have it plugged in.

 :)
Logged