VectorLinux
September 19, 2014, 09:39:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: Is an rt2570 driver in 5.8 SOHO?  (Read 6942 times)
JimC
Member
*
Posts: 18


« Reply #15 on: May 23, 2007, 01:56:23 pm »

JimC:

I am curious exactly the rt-chipped usb wifi which is up (manufacturer, revision, etc.) at least on the level to allow some traffic.  Grin
Do You configure the rausb0 via a config file at bootime or load manually the driver, and manually iwconfig-ifconfig it?

See my May 18, 2007, 05:29:50 PM  post in this thread (I copied and pasted what I did into that post). 

But, I was unable to get it working again after a reboot with Vector 5.8 SOHO (see my later posts about issues, including something causing the ESSID to be truncated).

My adapter shows up this way using lsusb in most distros (it's a Belkin USB Wireless G Adapter).

Bus 005 Device 003: ID 050d:7050 Belkin Components F5D7050 ver 1000 WiFi

Note that the rt2570 driver from serialmonkey does seem to be working OK in PCLinuxOS 2007 Test 4 with all updates (I haven't bothered to try the final yet).   But, it does seem to be "flaky" with Vector 5.8 SOHO (at least using iwconfig to configure it after a reboot) for some reason. 

With a number of distros, it works without needing to "jump through hoops" (driver already in the distros to support rt2570). 

For example, it worked in Vector 5.1.2 SOHO Live, PCLinuxOS 0.92, SimplyMEPIS 6.0, 6.5, some of the Kanotix releases, and others.  Ubuntu seems to like it OK, too (multiple releases work OK with it).  Ditto for the later Fedora 7 test releases (and I've never tried their earlier releases to see if it works with them or not).   Heck, even Puppy works with it from a Live CD (at least 2.12 and later) just by typing modprobe rt2570 and using iwconfig to set it up).  I can even use it from some of the rescue CD type distros around.  It seems to be a well supported chipset with most distros.  It typically shows up as rausb0 when it is supported by a distro.




« Last Edit: May 23, 2007, 02:01:32 pm by JimC » Logged
JimC
Member
*
Posts: 18


« Reply #16 on: May 23, 2007, 02:07:53 pm »

Please let me know if it works on VL, and I might also need a copy of that driver!  Wink

Send me a PM with a good e-mail addy and I'll send you a copy of the driver files (rt2500usb.inf, rt2500usb.sys, etc.).   I no longer have Vector installed (I was just giving it a quick test run and it doesn't seem to have exactly what I'm searching for).   So, I don't know if it works with Vector or not (I didn't try it with Vector).

It seemed to work just fine with an older version of SimplyMEPIS though (3.4.3) that I tried it with after making the post.  So, if it works with an older version of ndiswrapper, it probably works with a newer version of ndiswrapper, too.  The drivers I used with ndiswrapper were on the CD that came with my adapter (mine is a Belkin).
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!