VectorLinux
August 30, 2014, 12:07:40 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: root filesystem check hangs  (Read 4047 times)
m-eick
Member
*
Posts: 3


« on: May 22, 2007, 12:18:31 am »

Hi everyone,

I have a problem with my fresh VL 5.8 SOHO system. My computer is an Acer Aspire 1652 wlmi laptop with 1,7 Ghz Centrino cpu, Ati Radeon X300 gpu and 512 mb ram. There seems to be no problem with the installation itself, but after I removed the install-cd and reboot for the first time, the boot-process stops with the message "checking root filesystem:". Nothing happens after that: no message, no progress-bar, the LED that indicates harddisk-activity remains dark, the keyboard is dead (thus I can't access a console to see a proper boot-message) and even a shutdown or reboot via the power-button is impossible (I have to remove the battery).

I installed VL as the only system on the disk, with hda1 as swap (~700 MB) an hda2 as / (the rest of 80 GB). I tried grub and lilo, ext3 and xfs - no difference (I am not sure if xfs is really used, as there is no observable disk-formatting during installation).

Any ideas what I could do? Boot-parameters? How can I get rid of the splashscreen to see a bootmessage?

Greeting, Michael
Logged
bigpaws
Vectorian
****
Posts: 1847


« Reply #1 on: May 22, 2007, 01:05:35 am »

From your post it appears that you know your
way around Linux.

Did you do a MD5 sum after the download?

Did you try a boot option acpi=noacpi for
example. As for the bootsplash use option bootsplash=silent.
iirc that the tab key will give you a graphical text boot.

I only found one post on Ubuntu listing that acpi
needed to be off for the installation.

HTH

Bigpaws
Logged
m-eick
Member
*
Posts: 3


« Reply #2 on: May 22, 2007, 03:01:42 am »

Ok, thanks Bigpaws.

acpi=off did the job. However, running a laptop without powermanagement and battery-monitor isn't very funny  Sad

I think the problem is the broken DSDT-table of my laptop. I will try to append my fixed DSDT to the initrd as soon as I find the time (or as soon as I've figured out how that is done under VL).

OpenSuse 10.2 and Ubuntu 6.10 worked without fixing the DSDT. I had hoped, the improvements in the kernels acpi-system had made this a thing of the past.
Logged
bigpaws
Vectorian
****
Posts: 1847


« Reply #3 on: May 22, 2007, 03:10:35 am »

OpenSuse and Ubuntu use patched kernels.

I was not able to find a reference to a broken DSDT table,
so I did not find a fix.  A kernel patch and recompile maybe
in order.

Usually if a system will not boot the acpi=noacpi will work.

Bigpaws
Logged
m-eick
Member
*
Posts: 3


« Reply #4 on: May 22, 2007, 03:41:13 am »

No, acpi=noacpi didn't work, but acpi=off  (btw.: bootsplash=silent didn't work as well)

And yes: you need a patched kernel to add a fixed DSDT to the initrd without recompiling (http://gaugusch.at/kernel.shtml) - I don't think that I want to do this
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #5 on: May 22, 2007, 04:00:06 am »

Actually bootsplash=silent means graphic lilo, you need bootsplash=verbose.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!