VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Problems still with DHCPD in 5.8SOHO final  (Read 3458 times)

ekp

  • Member
  • *
  • Posts: 55
Problems still with DHCPD in 5.8SOHO final
« on: May 22, 2007, 08:24:02 am »

I can not get my network up when booting.  Have had problems in the past but been able to work around it.  Can not start at all now when booting.

I have two ethernets one is on board SIS chip (disabled) the other is a Lynksys.  Lynksys card is seen as eth0 and other eth1 in KControl but vasm will only start network with inet 2 and eth1.  There seems to be some conflict.  VASM should see card as eth0 but does not.

For clarity I can only start network manually from VASM by inet 2 with a device which is seen as eth1 when it should be seen as eth0.  When setting up network init1 is set to boot automatically with DHCP which does not work.
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Problems still with DHCPD in 5.8SOHO final
« Reply #1 on: May 22, 2007, 09:47:27 am »

Reboot your machine and without manually starting your network please post the output of the following commands for us:

ifconfig
route
cat /etc/resolv.conf
lsmod | grep eth

Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Problems still with DHCPD in 5.8SOHO final
« Reply #2 on: May 22, 2007, 12:41:34 pm »

Could this have anything to do with your interfaces problem?:
http://www.vectorlinux.com/forum2/index.php?topic=979.0
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

ekp

  • Member
  • *
  • Posts: 55
Re: Problems still with DHCPD in 5.8SOHO final
« Reply #3 on: May 22, 2007, 07:56:59 pm »

Reboot your machine and without manually starting your network please post the output of the following commands for us:

ifconfig
route
cat /etc/resolv.conf
lsmod | grep eth


[/quot
Code: [Select]
root:# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0A:E6:91:C9:18
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0xd400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vector://home/ed
root:# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
loopback        *               255.0.0.0       U     0      0        0 lo
vector://home/ed
root:# cat /etc/resolv.conf
# Generated by dhcpcd for interface eth1
search nycap.rr.com
nameserver 24.92.226.9
nameserver 24.92.226.102
vector://home/ed
root:# lsmod | grep eth


Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Problems still with DHCPD in 5.8SOHO final
« Reply #4 on: May 22, 2007, 09:08:20 pm »

Since you state you can get an ipaddress with a
change in VASM the driver is ok.

Did you read the information from Joe1962?

How about "mcedit /etc/dhcpc/dhcpcd-eth0.info" add the MAC
address of the NIC you want to use.

HTH

Bigpaws
Logged