April 20, 2015, 10:08:17 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: [SOLVED] Problems with 1280x1024 screen in VL5.8-SOHO-final  (Read 3194 times)
Posts: 58

« on: May 24, 2007, 07:22:11 am »

Hi all VL users

I am an enthusiastic user of VL 5.8 SOHO. I have been using successively RC1, 2, and 3,
and was eager to install VL 5.8 SOHO final. I could do it this afternoon, and I immediately
faced the following new problem:

At first boot (in graphic mode), the complete screen picture is shifted 3 cm left, with a
black vertical bar at the right side; the K menu icon, pushed outside of the screen, is not
accessible, as well as the left-side column of icons of the desktop, etc...    Embarrassed

I found a PROVISIONAL cure by opening a console (as an ordinary user) and typing
the command "kcontrol": the KDE control center opens a window. Then, clicking on
peripherals > display   I discovered that the screen size was (wrongly) 1400x1050,
in place of the 1280x1024 that I choose during the installation (hence: this is a new bug
to correct in the installation program, since the previous versions of VL5.8 did not
suffer this symptom). Selecting 1280x1024 gives back a normal screen aspect.   Smiley

The problem is that this has to be done again at each reboot !   Angry
(Even though I marked the square "apply settings on KDE startup")

Does someone know what to do to make this correction permanent ?

Technical data: screen Hyunday B71A (1280x1024)
Graphic card: ATI
Driver selected during installation: ATI (I tried FGLRX and radeon: error messages and
could only boot in console)

VL5.8-SOHO-RC3, old P3@700MHz
« Last Edit: May 27, 2007, 12:01:26 pm by JohnB316 » Logged
Posts: 1346

Registered Linux User #386728

« Reply #1 on: May 24, 2007, 08:31:47 am »

You'll need to edit your /etc/X11/xorg.conf file as the root user. Find the section of the file that gets into monitor depths and add "1280x1024" with the quotes to the beginning of the resolution lists for each of the bit depths listed in the file.


VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.
Posts: 58

« Reply #2 on: May 25, 2007, 04:04:15 am »

Hi JohnB316, and thank you for your answer.

Actually I found no xorg.conf file in /etc/X11, but xorg.conf.ati and xorg.conf-vesa.   Huh

I could modify xorg.conf-vesa according to your messages, but, when rebooting,
the symptom was still there.  Embarrassed

Then I created a copy of this modified xorg.conf-vesa under the simpler name
xorg.conf: then at boot, my screen went black, except a message from its hardware
"frequency too high".   Angry

I deduce that, to be taken into account, the correct name of the file must be xorg.conf
(which was obvious in your message) but that the file content is still inadequate.
I tried to modify it (specify vertical and horizontal frequencies) without success.   Sad

Finally I solved the problem by using a copy the xorg.conf of my RC3 version of VL5.8
from my main hard disk (I am testing VL5.8-SOHO-final on an auxiliary hard disk).   Roll Eyes
This is abominably brutal, but everything works now perfectly ! (so far)     Smiley     

It would be interesting to localize which exact detail needs to be modified, but
I prefer going on exploring the new VL5.8 !

Thanks again for your help. Soon news to come from the tests !

VL5.8-SOHO-RC3, old P3@700MHz
Triarius Fidelis
Posts: 2399

Domine, exaudi vocem meam

« Reply #3 on: May 25, 2007, 01:56:17 pm »

If it isn't working, try running vxconf first.

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
Posts: 58

« Reply #4 on: May 27, 2007, 06:41:54 am »

Hi Hanumizzle, and thanks for your suggestion.

In-between, I found out what was wrong: I inadvertedly skipped some stage
during the install, when selecting the ati driver, etc...   Embarrassed

To check this, I did a new install carefully, and no problem at all now with
the display !   Smiley    So there is no bug to correct, as I wrote wrongly before,  Roll Eyes
just the installer which is perhaps not very clear at that stage.

Everything seems to work smooth now. Congratulations, and thanks again to
all the VL team: this is a great achievement indeed !

VL5.8-SOHO-final, old P3@700 MHz
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!