VectorLinux
April 24, 2014, 12:05:05 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: screen problem  (Read 2017 times)
soulbadguy
Member
*
Posts: 1


« on: May 24, 2007, 10:17:26 pm »

hi just install vector 5.8 and the KDE desktop deosnt fit all the screen.They are large black space on the right and the left.I tried to use Ksnpshot to take a pic,but on the snapshot all seem fine as if the black area isnt in the desktop.Of course i tried setting on my screen,changing resolution etc... but nothing.I think  the probleme is due more to X that to KDE.I have a very similar problem on slackware 10.2 after installing the nvidia graphic driver so i believe the probleme must be relatted to this driver.Have someone the same probleme and possibly a solution ?How can i uninstall the nvidia driver ?

thanks
.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #1 on: May 25, 2007, 05:02:53 am »

I have that problem sometimes when I switch nvidia driver versions, but I have a autoadjust button on my lcd that takes care of it for me.
you can run "nvidia-installer --uninstall" to remove the nvidia driver
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #2 on: May 25, 2007, 05:15:55 am »

The black areas don't show up in a screen shot because they are not part of the screen. Problem is that your monitor is not displaying it correctly.

As uelsk8s mentions, LCD's often have an autocorrect function to fix this. CRT's usually require you to use the geometry buttons to tweak it. This tweaking has to be done for every resolution/refresh rate/color depth combination you use. I run my displays at the same settings with all os's, that way I only have to adjust the monitor once.

You can also try a different driver without uninstalling nvidia.
As root, open the file /etc/X11/xorg.conf in a text editor like mcedit or kedit. Find the line:
  Driver    "nvidia"
and change nvidia to nv or vesa. Restart X or your computer to see the results.
Logged
tomh38
Vectorian
****
Posts: 912



« Reply #3 on: May 25, 2007, 09:50:23 am »

Whether you have a CRT or an LCD, you might have to use the geometry buttons to adjust display width and height to fill the whole screen (on one older LCD I have to do this).  If you don't have an auto-adjust button, you may need to look in the manual to figure out just how to do this - I've always had trouble with navigating these kinds of menus.  If you don't have the manual handy, you should be able to find one on the manufacturer's website.

Then again, as nightflier and uelsk8s said, it could be a driver problem.  I don't know much about that.

Hope this helps.

Tom
Logged

"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991
jklslvch
Member
*
Posts: 33


« Reply #4 on: May 26, 2007, 03:47:39 pm »

try doing what worked for me logging into VL as root in a plain terminal and using the command "vxconf" and try to let it auto configure your screen settings. in the slackware based distro SLAX and BackTrack the command that would work somewhat the same was "xconf" i dont know if it works in slackware though...
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!