Please support VectorLinux!

Author Topic: ACER S2W 3300u scanner  (Read 10408 times)


  • Vectorite
  • ***
  • Posts: 302
ACER S2W 3300u scanner
« on: August 19, 2007, 02:04:05 pm »
I have an ACER S2W 3300u scanner which I have used without incident before but have some how disconnected and can not remember how to install. As I recall all I did before was to hit the Xsane option under Graphics and follow the prompts. Now when I do that I get the following error message:
Failed to open device 'snapscan:libusb:1:2':
Invalid argument
Everything is plugged in correctly.
What simple thing have I forgotten?


  • Vectorite
  • ***
  • Posts: 302
Re: ACER S2W 3300u scanner (solved)
« Reply #1 on: August 19, 2007, 06:28:41 pm »
Solved but I thought I would post my trials and solution because it did not turn out to be so simple to solve. At least for me!

After a number of dead ends and some Googleing I did this.

Code: [Select]
cat /proc/bus/usb/devices

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs=  1
P:  Vendor=04a5 ProdID=20de Rev= 1.00
S:  Manufacturer=Color
S:  Product= FlatbedScanner 13
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=   8 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=16ms
line S shows the scanner is present
But line I shows Driver=(none)
therefore the vendor and product ID have to be supplied during module loading.
modprobe  scanner vendor=04a5 product=20de
but this shows there is no scanner module present!

It appears that in the 2.6 kernel the scanner module was dropped!

sane now requires libusb
which is included in Vec 5.8 standard.

So then I proceeded as follows:

in terminal ran
Code: [Select]
scanimage -L
device `snapscan:libusb:1:2' is a Acer FlatbedScanner13 flatbed scanner

So scanner is recognized.

then ran
Code: [Select]
[snapscan] Cannot open firmware file /usr/share/sane/snapscan/your-firmwarefile.bin.
[snapscan] Edit the firmware file entry in snapscan.conf.
scanimage: open of device snapscan:libusb:1:2 failed: Invalid argument

checked /etc/sane.d/snapscan.conf
and sure enough it points to

but there is no .bin file in /usr/share/sane/snapscan/

Almighty Google revealed that the windows driver that comes on the CD for the scanner is the .bin
file in question. Copy the .bin file (there are many) specified in this table

and edit
so that the firmware file reads
firmware /usr/share/sane/snapscan/u222v067.bin
(u22v067.bin was the firmwarefile I used)

test by running
Code: [Select]
If you get a pause followed by ,,,scanner warming up wait 20 sec... you have succeded.
Don't wait for an image you will just get gibberish. Close the terminal and run
Xsane from the Graphics option.

for more information try this

NOTE 1: If any one else has problems with their scanner on the newer 2.6 kernel and this helps say so. It may be a usability issue that needs to be addressed.

NOTE 2: If any one has an all in one scanner printer and this works I would like to know. I could use more desk space.

NOTE 3: If anyone who has worked on hotpluging reads this please check out this in particular beneath the table under USB scanners - Libusb it indicates an issue with hotplug managers. I don't think it's relavent due to there no longer being a scanner module in the kernel. But I wouldn't know.