VectorLinux
August 28, 2014, 03:03:34 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Recomendations for NTFS mounting with normal user access  (Read 21730 times)
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« on: May 26, 2007, 06:36:53 pm »

- For persistent mounts add one of these lines to /etc/fstab:

For read-only access:
Code:
/dev/hda1 /mnt/win ntfs uid=root,gid=users,fmask=0111,dmask=0000,users,nls=utf8,ro,noexec 0 0

As of the VL 5.8 series, NTFS-3G over FUSE is included for read/write access to NTFS formatted partitions:

For read/write mount:
Code:
/dev/hda1 /mnt/win ntfs-3g defaults,allow_other,umask=0,users,nls=utf8,noexec 0 0



- For temporary mounts execute one of these commands in a terminal (as root):

For read-only access:
Code:
mount -t ntfs /dev/hda1 /mnt/win -o uid=root,gid=users,fmask=0111,dmask=0000,users,nls=utf8,ro,noexec

As of the VL 5.8 series, NTFS-3G over FUSE is included for read/write access to NTFS formatted partitions:

For read/write mount:
Code:
mount -t ntfs-3g /dev/hda1 /mnt/win -o defaults,allow_other,umask=0,users,nls=utf8,noexec
« Last Edit: August 07, 2007, 05:09:59 pm by Joe1962 » Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
alan
Member
*
Posts: 1


WWW
« Reply #1 on: May 31, 2007, 11:54:42 pm »

Great tips, Thanks joe.
Logged

M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #2 on: August 02, 2007, 06:07:43 am »

mmmm
I had never tried to write to the old Wind OS partition on my laptop from VL, but I just tried this today, and I get an ugly error

Code:
root:# mount /dev/hda2
Bootsector checksum failed.
Failed to startup volume: Invalid argument
Failed to mount '/dev/hda2': Invalid argument
The device '/dev/hda2' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?
I'm using the second suggestion here... I want to allow users to write the ntfs, not just root

here is my fstab
Code:
# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system>   <mount point>   <type>   <options>   <dump>   <pass>
#
# dump(8) uses the <dump> field to determine which file systems need
# to be dumped. fsck(8) uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# The Linux partitions
/dev/hda6 / xfs  defaults  0  1
/dev/hda7 /home xfs defaults  0 2

# Shared Windows/Linux partition
#/dev/hda1   /mnt/dos  msdos  umask=0   0  0
#/dev/hda1   /mnt/win  vfat   fmask=111,dmask=0,quiet,shortname=mixed,user  0  0
#mount the win partition allowing users to wrte to it
/dev/hda2 /mnt/win ntfs-3g defaults,allow_other,umask=0,users,nls=utf8,noexec 0 0
# Floppy disks
# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/fd0   /mnt/floppy  auto    defaults,noauto,user    0 0
#/dev/fd1  /mnt/floppy  auto    defaults,noauto,user    0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd       /mnt/ls120      auto    defaults,noauto,user    0 0

# CDROM, CDWRITER, DVD
/dev/cdrom      /mnt/cdrom      iso9660         users,noauto,ro
/dev/cdwriter   /mnt/cdwriter   iso9660         users,noauto,ro
/dev/dvd        /mnt/dvd        iso9660         users,noauto,ro

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de  /mnt/nfs  nfs  defaults  0 0

# proc file system:
proc    /proc   proc    defaults        0 0

# Unix98 devpts filesystem:
none  /dev/pts  devpts  gid=5,mode=666  0 0

# Shared memory filesystem:
tmpfs   /dev/shm    tmpfs defaults 0  0

# Basic USB filesystem
sysfs  /sys  sysfs  defaults  0 0

# example of a VFAT USB pendrive
#/dev/sda1  /mnt/pendrive vfat   fmask=111,dmask=0,noauto,user,quiet,shortname=mixed 0 0


# Swap partitions
# The 'sw' option means auto activating with 'swapon -a'.
/dev/hda5   none   swap   sw   0  0


Please suggest a solution Wink
Logged

M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #3 on: August 02, 2007, 06:40:31 am »

Never mind... turns out it's not ntfs after all... Sad

I assumed it was ntfs... I dont see how they would ship out an XP install on a FAT32 filesystem if ntfs is considered the "safest" filesystem according to M$.
Logged

Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #4 on: August 02, 2007, 07:49:21 am »

 Cheesy Cheesy Cheesy
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1545


I like the bass to go BOOM!


WWW
« Reply #5 on: August 02, 2007, 04:13:03 pm »

My laptop shipped with FAT32 as well... I'm not sure why. There was this "ntfs convertor" icon on the desktop, but I never dared to click it Roll Eyes.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
chrisdragon
Member
*
Posts: 11



« Reply #6 on: August 07, 2007, 04:38:51 pm »

Where exactly would this be typed, in the terminal? What if I were mounting it through VSAM, what options would I be putting in?
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #7 on: August 07, 2007, 05:01:53 pm »

That is the syntax for permanently adding mounts to /etc/fstab. Thanks for pointing it out, I will add a note to the original FAQ.


EDIT: vasm is currently not NTFS-3G ready.
« Last Edit: August 07, 2007, 05:11:01 pm by Joe1962 » Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!