Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Insane keyboard rreeeeppppeeeeeaaat rate won't change....  (Read 2075 times)


  • Member
  • *
  • Posts: 1
Insane keyboard rreeeeppppeeeeeaaat rate won't change....
« on: May 28, 2007, 06:25:41 pm »

Hi all:

New to Vector here; think it's pretty slick....

But haven't got past square 1 because of the following problem:

The keyboard repeat rate.

I just fresh-loaded Vector 5.8 on an oldish K6-II 500MHz box with 128MB RAM.  I immediately noticed that the keyboard repeat function was WAY too sensitive.  As in, you can barely type your username without repeating all the letters 47 times--never mind passwords. 

"No problem," said I, "I'll just mosey over to this Keyboard Settings dialog and change things the way I want them."  Accordingly, I cranked the Delay all the way up and the repeat rate all the way down.

No effect.  This is bad :(

I have tried several different keyboards, rebooted repeatedly, and looked at the BIOS for some way to change this in the firmware, which there isn't.  I have tried manually adjusting the Typematic rate with
Code: [Select]
xset r rate 195 35/[code]  Also, I have booted this same box into a Puppy live CD with no such keyboard-repeat difficulties.  The only solution I have found is to turn off repeat entirely, which is not acceptable for day-to-day use.

Problem doesn't show up in a console login, only in X.

Any ideas would be appreciated.  I really like Vector.

Thanks in advance,



  • Member
  • *
  • Posts: 9
Re: Insane keyboard rreeeeppppeeeeeaaat rate won't change....
« Reply #1 on: February 27, 2008, 07:10:54 pm »

Hi how did you fix that ? I have the same problem. cannot type anything, it just repeats all the characters and this is driving me nuts.  I have installed 5.9. 

anyone has any idea how to fix that ?