VectorLinux
July 23, 2014, 03:39:29 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Garbled Man Pages  (Read 1358 times)
Pita
Vectorian
****
Posts: 1308


« on: March 28, 2008, 07:02:09 pm »

When trying to open man pages I get garbled output both on the console and in terminals such as:

cat manxterm-errors
<standard input>:4: warning: can't find character with input code 3
<standard input>:4: warning: can't find character with input code 127
<standard input>:4: warning: can't find character with input code 2
<standard input>:5: warning: can't find character with input code 12
<standard input>:5: warning [p 1, 0.0i]: cannot adjust line
<standard input>:5: warning [p 1, 0.2i]: can't break line
<standard input>:5: warning: can't find character with input code 6
<standard input>:5: warning: can't find character with input code 7
<standard input>:5: warning: can't find character with input code 5
<standard input>:5: warning: can't find character with input code 4
<standard input>:5: warning [p 1, 0.3i]: cannot adjust line
<standard input>:5: warning [p 1, 0.5i]: can't break line
<standard input>:5: warning [p 1, 0.7i]: cannot adjust line
---snip---
<standard input>:19: warning [p 1, 6.7i]: can't break line
<standard input>:19: warning [p 1, 6.8i]: can't break line
<standard input>:19: warning [p 1, 7.0i]: can't break line
<standard input>:20: warning: numeric expression expected (got `Ô')
<standard input>:20: warning [p 1, 7.2i]: cannot adjust line
---snip---
<standard input>:41: warning [p 1, 16.2i]: can't break line
<standard input>:41: warning [p 1, 16.3i]: can't break line
<standard input>:41: warning [p 1, 16.5i]: cannot adjust line
<standard input>:41: warning [p 1, 16.7i]: cannot adjust line
<standard input>:41: warning [p 1, 16.8i]: can't break line
<standard input>:42: warning [p 1, 17.0i]: can't break line
<standard input>:43: translation to \troff: Failed assertion at line 122, file `errarg.cpp'.
groff: troff: Signal 6
grotty:<standard input> (<standard input>):892: missing argument
grotty:<standard input> (<standard input>):893: X command without `tty:' tag ignored
grotty:<standard input> (<standard input>):3264: missing argument
grotty:<standard input> (<standard input>):3265: X command without `tty:' tag ignored
^H^HÒExterm.1.gÒExterm.1ì[Ûr9}îú
¢#,Iú:½nï%Ñ6g$QAÒ·O¬Á"HÖ¨XÅ)%±c

Opening man pages in "mc" with F3 they display perfectly.

Any ideas?
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #1 on: March 28, 2008, 07:35:56 pm »

Those look like incorrect code page errors, though I'm not sure that such things really exist in Linux.

What language do you use in Vector? And how is it set in /etc/profile.d/lang.sh?

While it may not be related, I had some problems with man under Vector as well. I ended up installing most as a replacement for less, then setting up an alias in ~/.bashrc that goes like this:

Code:
man="man -P most"

Since using that, I've not seen the problem repeated.

I don't know if there is a Vector build of most, but the Zenwalk version works fine under Vector. It can be found here if you want to try it:

http://www.users.waitrose.com/~paulm/files/most/most-5.0.0a-i486-50.1.tgz

There is also a Slackware build - that was what Zenwalk was using before I built version 5.0.0a.

paul.
Logged
Pita
Vectorian
****
Posts: 1308


« Reply #2 on: March 29, 2008, 05:59:47 pm »

Thanks!

I have not yet tried most, however, I found when I give the command: "less manpage.gz" I get a perfect display of the manpage in question.

It seems somehow man is not passing things correctly. It does react, however:

$ man cul
No manual entry for cul

$ man
What manual page do you want?

I put alias man="man -P less" into .bashrc it does not change anything.

Regards
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!