Please support VectorLinux!

Author Topic: abiword needs x11 7. repos tell i have latest x11  (Read 6373 times)

Diabolic Preacher

  • Vectorite
  • ***
  • Posts: 100
  • Freedomaniac
    • DP's Journal
abiword needs x11 7. repos tell i have latest x11
« on: May 31, 2007, 02:03:43 pm »
i used slapt-get to download and install abiword but it fails as it needs X11 > 7.0 (or 7.1) but when i try upgrading X11, slapt-get refuses to upgrade to new version and says that your version is up to date.
Diabolic Preacher
As Is
http://pintooo15.livejournal.com

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #1 on: May 31, 2007, 02:33:22 pm »
I think that's a bad package. ( I may have built that on a dirty box.)

I also thought that was re-built by someone else. I can no longer maintain it because I do not have a clean install anymore.

Diabolic Preacher

  • Vectorite
  • ***
  • Posts: 100
  • Freedomaniac
    • DP's Journal
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #2 on: May 31, 2007, 10:40:57 pm »
oh!

...so umm my basic question is where else do i get a .tlz package of abiword or .tgz or only .tar.bz2 ?
Diabolic Preacher
As Is
http://pintooo15.livejournal.com

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #3 on: June 01, 2007, 05:51:53 am »
you can use slapt-get --install abiword --no-dep

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #4 on: June 24, 2007, 06:32:05 pm »
This issue is still unresolved.  I got the same results trying to install abiword into VL 5.8 SOHO. Yes, the version out there works with stock X.org. It's merely a matter of changing the slack-required file.  I could probably do that and resubmit the package if the original package maintained cannot.

-Cait
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #5 on: June 25, 2007, 07:53:32 am »
I will re-build the package in a clean install to get rid of this issue... Please hold ..... <background music>


EDIT:

< Stop background music >

The package has been fixed

slapt-get --update and slapt-get --install abiword should do it now
« Last Edit: June 26, 2007, 06:52:26 am by M0E-lnx »

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #6 on: July 05, 2007, 04:48:43 pm »
It's fixed for SOHO but now broken for Standard due to a freetype 2.2.1 dependency.  Either freetype in Standard needs to be upgraded or the slack-required file needs another change :(

Sorry to be the bearer of bad news.
-Cait
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #7 on: July 06, 2007, 02:40:25 am »
I think this is a problem that has happened with a number of packages, I think we may need to separate the repositories for 5.8 standard and 5.8 soho.....

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #8 on: July 06, 2007, 03:42:27 pm »
Thanks for the info caitlyn.

By the way, does everything work correctly if you use the --no-dep option of slapt-get?
At least for the X11 and Freetype dependencies? If yes, then it will just be a matter of fixing abiword's slack-required.

I'm very sorry for not taking care of this sooner, but time is rather limited for me right now.
Tomorrow is Saturday, so I can spare some time to getting this fixed.  :)

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #9 on: July 06, 2007, 05:24:33 pm »
Yes, it works just fine with --no-dep.  As you say, probably correcting the slack-required file would do it.  I'm just wondering if bringing the version of freetype up to the same level as SOHO may be a better approach to avoid problems with other packages.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: abiword needs x11 7. repos tell i have latest x11
« Reply #10 on: July 07, 2007, 10:00:40 am »
I've fixed the slack-desc files for both abiword and goffice, and they both install in SOHO and run correctly too.

Thanks for the feedback everyone!