VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Fluxbox does not start.  (Read 6362 times)

Binky

  • Member
  • *
  • Posts: 17
Fluxbox does not start.
« on: February 22, 2007, 06:08:18 am »

I installed fluxbox.  the process seemed to go fine.  there is a option for it in the logon screen and such.  however when I try to logon I get a pretty black screen and then I am dumped back to the logon screen.

I edited the startup script in the ~/.fluxbox folder to create a log.  the log file is loaded with things like the following....

Failed to read: session.tabs
Setting default value
Failed to read: session.ignoreBorder
Setting default value
Failed to read: session.forcePseudoTransparency
Setting default value
Failed to read: session.numLayers
Setting default value

there is alot more of this, just didn't want a two page post.  Could somebody point me in the right direction on where to look for a solution.

Thanks
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3277
Re: Fluxbox does not start.
« Reply #1 on: February 22, 2007, 06:35:46 am »

How did you install it? from source, from slack package, vector package?

and can you please post the startup script in ~/.fluxbox ..

Binky

  • Member
  • *
  • Posts: 17
Re: Fluxbox does not start.
« Reply #2 on: February 22, 2007, 06:47:30 am »

being new to Linux I had forgotten about GSLAPT probably being if not easier but probably better.  I installed from source.  I grabbed the fluxbox-1.0rc2.tar.bz2 file from fluxbox's website.

Here is the start script.

# fluxbox startup-script:
#
# Lines starting with a '#' are ignored.

# You can set your favourite wallpaper here if you don't want
# to do it from your style.
#
# fbsetbg -f /home/heffer/pictures/wallpaper.png
#
# This sets a black background

/usr/local/bin/fbsetroot -solid black

# This shows the fluxbox-splash-screen
# fbsetbg -C /usr/local/share/fluxbox/splash.jpg

# Other examples. Check man xset for details.
#
# Turn off beeps:
# xset -b
#
# Increase the keyboard repeat-rate:
# xset r rate 195 35
#
# Your own fonts-dir:
# xset +fp "/home/heffer/.fonts"
#
# Your favourite mouse cursor:
# xsetroot -cursor_name right_ptr
#
# Change your keymap:
# xmodmap "/home/heffer/.Xmodmap"



# Applications you want to run with fluxbox.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
#
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.

# exec /usr/local/bin/fluxbox
# or if you want to keep a log:
exec /usr/local/bin/fluxbox -log "/home/heffer/.fluxbox/log"
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3277
Re: Fluxbox does not start.
« Reply #3 on: February 22, 2007, 11:39:32 am »

Yeah.. if I we you, I'd install from Gslapt... not only easier, but better... Makes sure you get all dependancies covered...

you can also use slapt-get from a terminal (if NO GUI is usable ATM).
run slapt-get --update first, then slapt-get --search fluxbox
You'll see the packages there

Binky

  • Member
  • *
  • Posts: 17
Re: Fluxbox does not start.
« Reply #4 on: February 23, 2007, 06:54:29 pm »

XFce works fine, just fluxbox does not want to go.  Having XFce working I used Gslapt to re-install fluxbox.  That process seemed to work fine.  Being new to all of this I am still unsure on where to find all of the different log files to search out clues.  I did however find this in the .Xsession-errors file.  perhaps it means more to somebody out there, or it could mean nothing at all, like I said, still learning.

/usr/bin/startxfce4: X server already running on display :0
Agent pid 2611
** Message: Querying Xkb extension
** Message: Xkb extension found
** Message: This build doesn't include support for XF86Misc extension
** Message: Querying Xkb extension
** Message: Xkb extension found

** (xfwm4:2625): WARNING **: The display does not support the XComposite extension.

** (xfwm4:2625): WARNING **: Compositing manager disabled.
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3277
Re: Fluxbox does not start.
« Reply #5 on: February 26, 2007, 05:59:35 am »

How about looking in your /home/heffer/.fluxbox/log see what kind of stuff is in there... That would probabbly get some logs more specific to fluxbox.

Also, look at your /var/log/Xorg.0.log

Colonel Panic

  • Vectorian
  • ****
  • Posts: 526
Re: Fluxbox does not start.
« Reply #6 on: March 08, 2007, 05:29:01 am »

Have you got a .fluxbox sub-directory under your $HOME directory (probably root)? That makes the difference for my system as to whether or not fluxbox works.
« Last Edit: March 08, 2007, 05:31:41 am by Colonel Panic »
Logged

InTheWoods

  • Vectorite
  • ***
  • Posts: 302
Re: Fluxbox does not start.
« Reply #7 on: May 20, 2007, 07:29:00 pm »


Quote
# exec /usr/local/bin/fluxbox
# or if you want to keep a log:
exec /usr/local/bin/fluxbox -log "/home/heffer/.fluxbox/log"

In /home/me/.fluxbox/start I had to go with
Code: [Select]
exec /usr/X11R6/bin/fluxboxTrying to log in in text mode revealed there is no /usr/local/bin/fluxbox

I have some menu problems but it does start.

Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Fluxbox does not start.
« Reply #8 on: June 15, 2007, 04:02:08 pm »

I  can confirm there seems to be a problem with the fluxbox package that is currently in the repository for VL 58. Under VL 5.8 SOHO it gives me quite a number of errors - seems as though it is looking for certain files in the wrong places.

Anyone else to confirm this behaviour? - because I do not exactly have a clean SOHO 5.8 install here to verify!
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll