VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Notebook troubles  (Read 4823 times)

LinuxNewbie

  • Member
  • *
  • Posts: 5
Notebook troubles
« on: June 06, 2007, 06:01:30 pm »

Hey everyone I am new to linux and am having trouble installing Vector on my laptop. Well i recently bought a used vaio one with out a floppy or cd-rom and the hard drive was blank. I do however have a brand new laptop that does have a cd-rom. So my question is how can i get vector onto the vaio without a cdrom or floppy? Could i put the hard drive in my new laptop and use its cdrom to install it or is there a chance that might mess something up. Thanks and sorry about the length.
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Notebook troubles
« Reply #1 on: June 06, 2007, 06:48:45 pm »

... Could i put the hard drive in my new laptop and use its cdrom to install it ...
Yes, I think that is your only viable option. When you re-install the drive to the old box you then boot into linux-tui (text interface) and run VASM, HWSET to redetect all the hardware.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Notebook troubles
« Reply #2 on: June 06, 2007, 07:00:44 pm »

You should do a forum search, I seem to remember several vaio-related threads.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

LinuxNewbie

  • Member
  • *
  • Posts: 5
Re: Notebook troubles
« Reply #3 on: June 06, 2007, 08:36:30 pm »

... Could i put the hard drive in my new laptop and use its cdrom to install it ...
Yes, I think that is your only viable option. When you re-install the drive to the old box you then boot into linux-tui (text interface) and run VASM, HWSET to redetect all the hardware.
Thanks for the info, I just wanted to make sure that it would be ok.
Logged

LinuxNewbie

  • Member
  • *
  • Posts: 5
Re: Notebook troubles
« Reply #4 on: June 06, 2007, 11:18:28 pm »

I just finished installing vector on the good computer with the vaios hard drive an put it back in an booted it, but it wouldnt go beyond the sony logo. What happened it installed fine?
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4141
Re: Notebook troubles
« Reply #5 on: June 07, 2007, 05:04:39 am »

If it's sitting at the Sony logo then it has probably not even reached the stage where it begins to boot from the hard drive. Enter BIOS to see if the hard drive is detected.
Logged

LinuxNewbie

  • Member
  • *
  • Posts: 5
Re: Notebook troubles
« Reply #6 on: June 07, 2007, 08:43:24 am »

It isnt detected. What do you think is wrong?
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Notebook troubles
« Reply #7 on: June 07, 2007, 08:50:52 am »

You need to read the BIOS (setup) manual for the computer. Usually you press Del or F2 to enter the BIOS setup. You then need to redetect the hard drive in the BIOS setup - or set it to AUTO. Also, are you sure you inserted the hard drive properly into its slot?
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2323
Re: Notebook troubles
« Reply #8 on: June 07, 2007, 08:52:23 am »

I think you have not a loader. Do you installed LILO at the mbr of that hd?
If you dont, the only solution I can see is go back to the new laptop, boot the VL cd and go to Fix Lilo or something like that. Then install LILO on the mbr of the old hd.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Notebook troubles
« Reply #9 on: June 07, 2007, 09:39:02 am »

It's not a loader problem (yet), since the BIOS doesn't even see the HDD.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2323
Re: Notebook troubles
« Reply #10 on: June 07, 2007, 10:19:36 am »

It isnt detected. What do you think is wrong?

Oops! I missed that one.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4141
Re: Notebook troubles
« Reply #11 on: June 07, 2007, 11:22:56 am »

Also re-check the physical installation, make sure it is fully seated against the contacts.
Logged

LinuxNewbie

  • Member
  • *
  • Posts: 5
Re: Notebook troubles
« Reply #12 on: June 07, 2007, 11:30:17 am »

Well I tried it again in my good laptop and it froze at the loading screen too just like the vaio. Im guessing it must have gotten knocked lose while booting and corrupted it?
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4141
Re: Notebook troubles
« Reply #13 on: June 07, 2007, 12:25:09 pm »

Try booting from the VL cd and re-install. If the hard drive is not okay, the process will halt when it can not find it. If it works, do a whole new installation, make sure it will boot up from hard drive before moving it back to original machine.
Logged