VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [Solved] turning off machine from KDE  (Read 4089 times)

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
[Solved] turning off machine from KDE
« on: June 09, 2007, 08:15:50 am »

hello,

I have VL 5.8 SOHO final and when I want to turn it off from KDE it switch to runlevel 0 and hangs forever.

reboot works well.

The same behavior is from console.

please advise.

veki
« Last Edit: June 11, 2007, 08:28:21 am by lagagnon »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: turning off machine from KDE
« Reply #1 on: June 09, 2007, 08:45:22 am »

Try to boot to "linux-tui" and issue command "poweroff". Does it end up with a message like "system halted" or "power down", or does it seem to hang at a certain process?
Logged

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
Re: turning off machine from KDE
« Reply #2 on: June 09, 2007, 09:26:12 am »

Hello,

I use Grub so I could not linux-tui.  But, anyway, I noticed that any entrace in terminal except the one that is within X causes hanging.
For example, when I from login prompt want to  enter Conosle X hangs causing whole computer to hang.  Even it is not possible to enter virtual terminals with Alt+1.....
When I enter virtual terminal from X with let say Alt+2 my keyboard stopped to work so I could not login.

I suppose that actually failure starts before script could start to shutdown machine.
The same is the case after I allowed everyone to shutdown machine.

maybe this helps.

veki
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: turning off machine from KDE
« Reply #3 on: June 09, 2007, 09:48:22 am »

Looks like your trouble may be in the X window system or above. It would help troubleshooting if you could boot to command line without X. Try to run vasm > super > xwindow > bootset > check "Text user interface desktop". When you reboot it should come up to plain text. After getting everything working, you can set it back to "Graphical user interface desktop".
Logged

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
Re: turning off machine from KDE
« Reply #4 on: June 09, 2007, 02:22:39 pm »

hello,
Sorry, I Installed today more than 35 machines with VL and after all those monitors I do not see anything and I do not remember anything so I could do setuop to logiun in textual mode on my own. sorry. :p

When I come to root in text mode poweroff works nicely.
But as soon as I come to GUI it does not work.  I suppose that it is some problem with X.
I tried to setup X with vasm from root console.
It is interesting it broke and restarted machinbe when it came to hardware identification.  On that machine I have hercules 3D/GL old video adapter.
I returned top old xorg.conf when it recognized as Texas Instruments, manufacturer with glint driver.

Is  there any textual way of fixing this?

thanx,

veki
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: turning off machine from KDE
« Reply #5 on: June 09, 2007, 04:55:08 pm »

Hard to tell where the problem may be. I would definitely try to use the vesa driver for X and go from there.
In /etc/X11/xorg.conf, device section, look for a line:
driver         "whatever"
and change "whatever" to "vesa"
Logged

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
Re: turning off machine from KDE
« Reply #6 on: June 10, 2007, 02:30:06 pm »

Hello,

OK, I will try , but it is interesting that VL 5.8 Standard Gold recogtnized 7 machines with identical hardware as this one including this one and I did not have such a problem on any of them.

Best wishes,

veki
Logged

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
Re: turning off machine from KDE
« Reply #7 on: June 11, 2007, 02:25:19 am »

Hello,

It is interesting that my card is Hercules Dynamite DL , but only glint driver works.  tseng drivers that are assumed for Hercules cards do not work.  The symptom with tseng drivers is the same when trying to shut down machine from KDE.
Thus, it seems to me that actually hardware recognition is not done well and/or there was modification of drivers and actually when trying to shutdown machine from KDE the X server becomes broken and I have problem before actuall start up of shutdown procedure.
Since everything works with VL 5.8 Standard and VL 5.1.2 SOHO, maybe it is needed to trace problem in VL 5.8 SOHO specific differences.
When I do Run command and type: poweroff, choose that command is done by root user  and after pressing OK I get teh following:
INIT:Switching to runlevel:0
INIT:Sending processes teh TERM Signal
and machine hangs forever.

thanx,

veki
« Last Edit: June 11, 2007, 02:44:23 am by vvucic »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: turning off machine from KDE
« Reply #8 on: June 11, 2007, 05:02:52 am »

You could try to run hardware detection again:
vasm > super > autosetup.
Try to do this from command line interface, not from within X-windows.
Logged

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
Re: turning off machine from KDE
« Reply #9 on: June 11, 2007, 05:14:37 am »

Hello,

I tried that and it breaks when detecting video hardware :/


Thanks,

veki
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: turning off machine from KDE
« Reply #10 on: June 11, 2007, 07:36:51 am »

,,,,
INIT:Switching to runlevel:0
INIT:Sending processes teh TERM Signal
and machine hangs forever.

I don't think such a problem has anything to do with video. It is more likely an ACPI/APM issue. Please carefully read the ACPI mesages in "dmesg" or /var/log/messages and post them here (you can do that with "dmesg | grep ACPI". You should also first of all go into your BIOS setup and make sure you have ACPI enabled.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

vvucic

  • Packager
  • Vectorite
  • ****
  • Posts: 113
    • GNU Linux Center
Re: turning off machine from KDE
« Reply #11 on: June 11, 2007, 08:09:01 am »

Hello,

BIOS of that computer does not have ACPI.  It does have APM as power management.
When I disabled APM everything works great.
SHould I put that this is [SOLVED]?

Congratulations :)
thanks,

vedran
Logged