Please support VectorLinux!

Author Topic: tunapie --need help to run it  (Read 4425 times)

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
tunapie --need help to run it
« on: June 10, 2007, 08:58:03 am »
another great app,that is written in python... I can package it but not before i get it to work
http://sourceforge.net/project/screenshots.php?group_id=132284

i get this error:
Code: [Select]
shadow:$ tunapie
Traceback (most recent call last):
  File "/usr/local/share/tunapie/Tunapie.py", line 5, in ?
    import wxversion
ImportError: No module named wxversion
[/quote]

i installed version 2
http://sourceforge.net/project/downloading.php?group_id=132284&use_mirror=belnet&filename=tunapie-2.0rc7.tar.gz&98594930

=======
i have
wxpython-2.6.3.3
python-2.4.3

EDIT: I'm sorry,move it to Software forum.
« Last Edit: June 10, 2007, 10:25:47 am by blurymind »
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: tunapie --need help to run it
« Reply #1 on: June 10, 2007, 01:37:25 pm »
another vectorite with a problem.
http://sourceforge.net/forum/forum.php?thread_id=1681660&forum_id=448938

Quote
Mismatched versions of wxpython and wxwidgets.

hmm...i dont even get to there. His error is different i guess.

i posted at
http://sourceforge.net/forum/forum.php?thread_id=1630259&forum_id=448938
« Last Edit: June 10, 2007, 01:50:51 pm by blurymind »
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: tunapie --need help to run it
« Reply #2 on: June 13, 2007, 04:02:38 pm »
Run locate wxversion. What comes up?

Also, please tell me the output of

Code: [Select]
python -c 'import sys; print sys.path'
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: tunapie --need help to run it
« Reply #3 on: June 14, 2007, 04:26:00 am »
Run locate wxversion. What comes up?

this:
Code: [Select]
shadow:$ locate wxversion
locate: warning: database /var/lib/slocate/slocate.db' is more than 8 days old
locate: fatal error: set_path_head: path_head len <= 0: 0

Quote
Also, please tell me the output of

Code: [Select]
python -c 'import sys; print sys.path'

i get
Code: [Select]
shadow:$ python -c 'import sys; print sys.path'
['', '/usr/lib/python24.zip', '/usr/lib/python2.4', '/usr/lib/python2.4/plat-linux2', '/usr/lib/python2.4/lib-tk', '/usr/lib/python2.4/lib-dynload', '/usr/lib/python2.4/site-packages', '/usr/lib/python2.4/site-packages/gtk-2.0']
thx for the interest to help
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: tunapie --need help to run it
« Reply #4 on: June 14, 2007, 10:32:34 pm »
Run updatedb as root, then try locate wxversion again.
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: tunapie --need help to run it
« Reply #5 on: June 15, 2007, 09:44:18 am »
i ran the command,then i got the same error when tried to run tunapie.
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: tunapie --need help to run it
« Reply #6 on: June 15, 2007, 07:51:56 pm »
i ran the command,then i got the same error when tried to run tunapie.

Yes, but what does locate say? I'm trying to use it for diagnosis.
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: tunapie --need help to run it
« Reply #7 on: June 16, 2007, 02:06:38 am »
i ran the command,then i got the same error when tried to run tunapie.

Yes, but what does locate say? I'm trying to use it for diagnosis.

locate wxversion   doesnt say anything.

Code: [Select]
vector:/~
shadow:$ locate wxversion
vector:/~
shadow:$ su
Password:
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, vi
Multimedia     : alsamixer, play
vector://home/shadow
root:# locate wxversion
vector://home/shadow
root:#
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: tunapie --need help to run it
« Reply #8 on: June 16, 2007, 02:21:50 am »
Your wxpython installation appears to be faulty...  :-\
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: tunapie --need help to run it
« Reply #9 on: June 16, 2007, 02:24:32 am »
Your wxpython installation appears to be faulty...  :-\
the package is
/home/ftp/pub/veclinux/packages/libs/wxPython-2.6.3.3-i586-4vl58.tlz

should i reinstall it? There is no other version it seems at the repo.
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/