VectorLinux
April 16, 2014, 11:31:39 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Broken package in Extra repository: torrent-swapper  (Read 3248 times)
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« on: June 13, 2007, 09:30:38 am »

We have a broken package (missing dependency) in the Extra repository.  Here is what I get when trying to install torrent-swapper:

Quote
root:# slapt-get --install torrent-swapper
Reading Package Lists... Done
Excluding torrent-swapper, use --ignore-dep to override
The following packages have unmet dependencies:
  torrent-swapper: Depends: wxPython >= 2.6.3.3
The following packages have been EXCLUDED:
  torrent-swapper
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

The required version of wxPython is in testing:
ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/testing/libs/wxPython-2.6.3.3-i586-4vl58.tlz

I'd suggest that either wxPython, if sufficiently tested, be moved into Extra or else torrent-swapper needs to be rolled back to testing.

Thanks,
Cait
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #1 on: June 13, 2007, 10:47:20 am »

Thanks for the report. I'll test both packages and move either one accordingly.
Logged

easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #2 on: June 14, 2007, 04:29:13 am »

Caitlyn, just as well you found this package  Smiley: after testing torrent-swapper there is another problem as well, but relating directly to the torrent-swapper dependency list.

It was most likely built against the revised wxGTK package (6vl58), however since checkinstall probably did the dependency checking, there was no revision info appended to the slack-required file.

I'll fix the package, and move wxPython into the extra/ repo as well.
Logged

easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #3 on: June 14, 2007, 08:25:11 am »

I've made the changes, everything should work smoothly.

Logged

caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #4 on: June 14, 2007, 12:05:50 pm »

Great!  I was just curious about torrent-swapper so it wasn't urgent for me but I know you like to keep the repositories working well.

Thanks,
Cait
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!