VectorLinux
October 31, 2014, 11:35:02 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 1st attempt at package for repository (aborted)  (Read 5070 times)
InTheWoods
Vectorite
***
Posts: 302


« on: June 15, 2007, 09:01:04 am »

As I recently had to reinstall Vec 5.8 and require wine. And as wine 0.9.39 is out but 0.9.29 is the most recent available on the repository; I thought I would try to make a repository grade package. I have successfully built this before but I have compile errors.

Code:
configure: WARNING: Wine will be build without OpenGL or Direct3D support
configure: WARNING: because something is wrong with the OpenGL setup:
configure: WARNING: /usr/X11R6/lib/libGL.a is present on your system.
This probably prevents linking to OpenGL. Try deleting the file and restarting configure.

Is deleting /usr/X11R6/lib/libGL.a a wise course of action?

<edit>
I renamed /usr/X11R6/lib/libGL.a to /usr/X11R6/lib/Backup_libGL.a
but now get
Quote
configure: WARNING: Wine will be build without OpenGL or Direct3D support
configure: WARNING: because something is wrong with the OpenGL setup:
configure: WARNING: No OpenGL library found on this system.

I've been having problems with an ATI card
http://www.vectorlinux.com/forum2/index.php?topic=3304.0
and I'm thinking maybe I should'nt try to build this for the repository!

« Last Edit: June 15, 2007, 09:58:44 am by InTheWoods » Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #1 on: June 15, 2007, 09:13:34 am »

there is a 0.9.37 package at the repo.Not sure if has open GL enabled.
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
InTheWoods
Vectorite
***
Posts: 302


« Reply #2 on: June 15, 2007, 09:27:23 am »


Quote
there is a 0.9.37 package at the repo.Not sure if has open GL enabled.

So creating a package for wine isn't as urgent as I thought.
but while were on the subject I updated my /etc/slapt-get/slapt-getrc file to the one posted here
http://www.vectorlinux.com/forum2/index.php?topic=1219.0
updated gslapt and still only see wine 0.9.29.

Where are you getting this from?
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #3 on: June 15, 2007, 09:31:59 am »

Wine 0.9.37 is in the testing repo. Add this to your slapt-getrc:

SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/testing/
Logged

InTheWoods
Vectorite
***
Posts: 302


« Reply #4 on: June 15, 2007, 09:58:18 am »


Thanks!

Got it.

I will try my hand at something else later.

Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #5 on: June 15, 2007, 01:08:13 pm »


Thanks!

Got it.

I will try my hand at something else later.



Sure thing.
By the way, let us know if that package works correctly, so it can be moved to the extra/ repo.  Smiley
Logged

InTheWoods
Vectorite
***
Posts: 302


« Reply #6 on: June 15, 2007, 01:09:59 pm »

I tried the test package in the repository and wanted to respond in a post requesting test results.
I can't find that post ( it was here earlier today so it did not dissappear in the clean up) so I will relate my experiences here.
Code:
Installing IE 6
  Initializing
  Creating Wine Prefix
Wine has detected that you probably have a buggy version
of libXrender.so .  Because of this client side font rendering
will be disabled.  Please upgrade this library.
Wine has detected that you probably have a buggy version
of libXrender.so .  Because of this client side font rendering
will be disabled.  Please upgrade this library.
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  1 (X_CreateWindow)
  Serial number of failed request:  13
  Current serial number in output stream:  15
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  1 (X_CreateWindow)
  Serial number of failed request:  13
  Current serial number in output stream:  15
Your wine does not have wineprefixcreate installed. Maybe you are running an old Wine version. Try to update it to the latest version.

I got this error trying to install IEs4Linux. The bit about libXrender.so also appeared during the wine install.
This may be unique to my system because the other wine packages yielded the same errors while the wine 0.9.39 package I compiled myself did not.
Logged
JohnB316
Administrator
Vectorian
*****
Posts: 1346


Registered Linux User #386728


« Reply #7 on: June 15, 2007, 07:22:25 pm »

Was the package of wine that's in testing built on a box with proprietary ATI or Nvidia video drivers? Those kinds of errors can creep up when stuff is built on a box using proprietary video drivers.

FWIW,
John
Logged

VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #8 on: June 16, 2007, 12:42:55 am »

Was the package of wine that's in testing built on a box with proprietary ATI or Nvidia video drivers? Those kinds of errors can creep up when stuff is built on a box using proprietary video drivers.

FWIW,
John

Nope, it was built on a "clean" VL installation, no proprietary drivers installed.
I may as well build a new package with the latest release since this one isn't working properly...
Logged

easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #9 on: June 16, 2007, 04:03:36 pm »

InTheWoods, there is a new Wine build in the testing repos (0.9.39):

http://www.vectorlinux.com/forum2/index.php?topic=3375.0

I built it explicitly enabling OpenGL support, on a clean installation of VL.
Please let us know if it works for you.  Smiley
Logged

InTheWoods
Vectorite
***
Posts: 302


« Reply #10 on: June 17, 2007, 12:56:19 pm »


Your new package works fine Eauster. No installation errors when installing IEs4linux.

Quote
Was the package of wine that's in testing built on a box with proprietary ATI or Nvidia video drivers? Those kinds of errors can creep up when stuff is built on a box using proprietary video drivers.

My box does have proprietary ATI video drivers on it. From your comment I take it that I shouldn't try to build anything other than personal packages on it with my present set up?

Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #11 on: June 17, 2007, 02:29:16 pm »

Quote from: InTheWoods
From your comment I take it that I shouldn't try to build anything other than personal packages on it with my present set up?

Yeah, if its for the repo, then you should use a "vanilla" VL setup, no extras.
ATI and Nvidia use modified OpenGL libraries and headers, and the can interfere when building apps that expect to find the original ones, not modified ones.

BTW, do you get any library related errors like what nightflier was experiencing:

http://www.vectorlinux.com/forum2/index.php?topic=3375.msg21199#msg21199
Logged

InTheWoods
Vectorite
***
Posts: 302


« Reply #12 on: June 17, 2007, 03:19:23 pm »

Ive replied in the thread you posted above.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!