VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [Solved] VLC no sound, Xine plays ok  (Read 2464 times)

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
[Solved] VLC no sound, Xine plays ok
« on: June 18, 2007, 08:57:46 pm »

VL 5.8 SOHO
ASUS P4SE
Pentium 4  1.8GHz
SiS 645 chipset
nVidia Corporation NV17 [GeForce4 MX 440]
40GB WD hdd
256MB DDR
Samsung DVD/CDRW
SiS AC'97 onboard sound
ADMtek NC100 Network Everywhere Fast Ethernet

I finally got VLC to play a DVD by entering Device name as "/dev/dvd" but there is no sound. This is a little puzzling because Xine plays the same DVD fine, with good sound.

EDIT: I needed to adjust the setting for PCM with KMix; PCM was set at zero. Now at 90% or so, I have sound with VLC.
« Last Edit: June 21, 2007, 08:50:29 am by nubcnubdo »
Logged

nubcnubdo

  • Vectorian
  • ****
  • Posts: 675
Play a CD with VLC
« Reply #1 on: June 18, 2007, 09:50:19 pm »

To play an Audio CD with VLC on VL 5.8 SOHO, you accept the default Device name as "/dev/cdrom". The tricky part is that the default value for Track is "0", and you must increment that value to the total number of tracks on the CD. Then click OK to close the dialog. When configured in this manner, VLC starts up playing the last track, so to play Track 1 first, you must move the slider to the far left.

If you know a better way to play a CD with VLC, please describe it in this thread.

EDIT: Another way to handle the Track value is to set it to a number greater than the actual number of tracks, for which VLC starts playing at Track 1, thence to Track 2 and so on. ("30" usually works)
« Last Edit: June 18, 2007, 10:09:06 pm by nubcnubdo »
Logged