VectorLinux
July 29, 2014, 06:22:32 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 070617 - Wine 0.9.39  (Read 4732 times)
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« on: June 16, 2007, 04:01:18 pm »

The latest (and greatest!) Wine release can be downloaded from the testing repository. This release features enhanced OpenGL/Mesa support and lots of bug-fixes, as usual:

Source: http://vectorlinux.osuosl.org/veclinux-5.8/source/testing/emulators/wine/
Package: http://vectorlinux.osuosl.org/veclinux-5.8/testing/emulators/wine-0.9.39-i586-1vl58.tlz

Code:
wine: Wine (WINdows Emulator)
wine:
wine: Wine is an Open Source implementation of the Windows API
wine: on top of X, OpenGL, and Unix.
wine:
wine: Website: http://www.wineq.org/
wine: License: GNU Lesser General Public License, version 2.1

Post feedback for this package here.
Logged

nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #1 on: June 17, 2007, 06:35:23 am »

When trying to launch:
Code:
wine: error while loading shared libraries: libwine.so.1: cannot open shared object file: No such file or directory

I made a symlink:
ln -s /usr/lib/libwine.so.1.0 /usr/lib/libwine.so.1

That made it work.
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #2 on: June 17, 2007, 11:20:56 am »

Hmm.. thats odd, the installation script has that symlink in it, so it should be made when the package installs  Huh:

Code:
( cd usr/bin ; rm -rf wineg++ )
( cd usr/bin ; ln -sf winegcc wineg++ )
( cd usr/bin ; rm -rf winecpp )
( cd usr/bin ; ln -sf winegcc winecpp )
( cd usr/lib ; rm -rf libwine.so.1 )
( cd usr/lib ; ln -sf libwine.so.1.0 libwine.so.1 )
( cd usr/lib ; rm -rf libwine.so )
( cd usr/lib ; ln -sf libwine.so.1.0 libwine.so )
( cd usr/share/man/man1 ; rm -rf wineg++.1 )
( cd usr/share/man/man1 ; ln -sf winegcc.1 wineg++.1 )

Can anyone else please confirm this problem as well?
Logged

InTheWoods
Vectorite
***
Posts: 302


« Reply #3 on: June 17, 2007, 03:15:37 pm »


My initial install and use of IEs4 Linux went well, but then I encountered this.
Code:
winecfg
Wine has detected that you probably have a buggy version
of libXrender.so .  Because of this client side font rendering
will be disabled.  Please upgrade this library.
Wine has detected that you probably have a buggy version
of libXrender.so .  Because of this client side font rendering
will be disabled.  Please upgrade this library.
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  1 (X_CreateWindow)
  Serial number of failed request:  13
  Current serial number in output stream:  15
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  1 (X_CreateWindow)
  Serial number of failed request:  13
  Current serial number in output stream:  15

Logged
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #4 on: June 17, 2007, 03:21:50 pm »

I upgraded from 0.9.37 using gslapt, would that have made any difference?
Logged
InTheWoods
Vectorite
***
Posts: 302


« Reply #5 on: June 17, 2007, 03:32:21 pm »

I swapped out your package for mine and winecfg runs but still with an error
Code:
winecfg
wine: creating configuration directory '/root/.wine'...
err:module:import_dll Library wined3d.dll (which is needed by L"c:\\windows\\system32\\d3d8.dll") not found
err:module:import_dll Library wined3d.dll (which is needed by L"c:\\windows\\system32\\d3d9.dll") not found
wine: '/root/.wine' created successfully.
Quote
I upgraded from 0.9.37 using gslapt, would that have made any difference?

When I started using wine a few months ago someone stated that they had better luck with packages they compiled themselves. That got me started and thereafter I just installed from GSLAPT. without problems. I wondered too if reinstalling was somehow different then a fresh install.
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #6 on: June 17, 2007, 03:34:44 pm »

I upgraded from 0.9.37 using gslapt, would that have made any difference?

No, it shouldn't make a difference  Huh
nightflier, do you also get those libxrender errors when running winecfg?
« Last Edit: June 18, 2007, 04:33:52 am by easuter » Logged

nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #7 on: June 18, 2007, 04:20:43 am »

No errors when running winecfg here.

5.8 SOHO RC1
Logged
rhauff
Vectorite
***
Posts: 105


« Reply #8 on: June 18, 2007, 05:07:37 am »

I got the same error as nightflier after upgrading 0.9.37 to 0.9.39:

wine: error while loading shared libraries: libwine.so.1: cannot open shared object file: No such file or directory

Creating the symlink as he suggested:

ln -s /usr/lib/libwine.so.1.0 /usr/lib/libwine.so.1

worked for me also.
Logged
rhauff
Vectorite
***
Posts: 105


« Reply #9 on: June 18, 2007, 05:10:06 am »

Woohoo!  The fonts in the Windows app look nice after upgrade!

Thanks, easuter for packaging this!

Roland

Update.... My application (DataQ Windaq acquisition program) screen dies due to apparently recurrent bug giving:
 X Error of failed request:  BadPixmap (invalid Pixmap parameter)

I need to revert to 0.9.37 for now.
« Last Edit: June 18, 2007, 08:34:04 am by rhauff » Logged
Freeman
Tester
Vectorite
****
Posts: 323


Choice to the user!


« Reply #10 on: June 19, 2007, 09:59:24 am »

Hi Easuter

After upgrading with Gslapt, same problem here:
Code:
root:# winecfg
/usr/bin/wine: error while loading shared libraries: libwine.so.1: cannot open shared object file: No such file or directory
Logged

It's better to die 10 times, than never to have loved at all.
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #11 on: June 19, 2007, 12:55:34 pm »

I've moved the package to the unstable/ repository until I can fix this permanently (haven't been able to replicate the problem here...).
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!