VectorLinux
November 26, 2014, 07:57:15 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How to share Files in Samba?  (Read 2338 times)
sa3atsky
Member
*
Posts: 13


« on: June 17, 2007, 10:25:44 pm »

Hi, I know this is a stupid question.. I love Vector Linux, but documentation, wikis and FAQs are all fragmented and a mess. The search function is not working in the forum either.. So I had to ask, how do you share a file on linux to your local samba share?
Logged
hata_ph
Packager
Vectorian
****
Posts: 3259


-- Just being myself --


« Reply #1 on: June 18, 2007, 12:03:59 am »

hi sa3atsky,

use VASM to configure the SAMBA
try below link......
http://vectorlinux.osuosl.org/docs/vl58/manuals/vl5_admin_vasm_en.html#sambaweb

btw, what version of VL you are using?
Logged
bigpaws
Vectorian
****
Posts: 1857


« Reply #2 on: June 18, 2007, 01:16:36 am »

Samba documentation is one of the best documented out there.

IBM has written good howtos.

Google samba, a good one samba by example.

I agree that documentation can be a mess. When that happens using
google to find where these packages came from. In that case usually
the docs are in good shape.

Bigpaws
Logged
sa3atsky
Member
*
Posts: 13


« Reply #3 on: June 18, 2007, 10:38:22 am »

Did everything right, when I access the pc from windows it tells me "There are currently no logon servers available to service the logon request"
whats wrong? is it with the permissions and authentication that i have to edit?

Fiddled around with it some more and fixed that problem, had to set it on share.... now after i mounted the folders i wanted to share no matter what i do it tells me "network path not found"..
« Last Edit: June 18, 2007, 10:42:19 am by sa3atsky » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #4 on: June 18, 2007, 11:21:27 am »

A few conditions need to be satisfied before you can access your files on the samba server. Here is an example to get you started.

As root, open /etc/samba/smb.conf in a text editor.
- find the line for "workgroup = WORKGROUP" and change WORKGROUP to whatever you use in Windows
- find "security = user" and change it to "security = share"
- add a section like this:
[public]
   comment = Public Stuff
   path = /public
   public = yes
   writable = yes

Save file and exit.

Make the directory and make it read-write for all:
mkdir /public
chmod 777 /public


Start the samba server:
/etc/rc.d/init.d/samba start

Assuming all went well and there is no firewall blocking access, you should now be able to access your Linux box from windows.

If you want this to be permanent, enable samba from vasm.
This is taking a lot of shortcuts and disregarding safeguards. Additional study is recommended.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!