Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VL installation / kernel version - module dependency  (Read 3597 times)


  • Member
  • *
  • Posts: 5
VL installation / kernel version - module dependency
« on: June 18, 2007, 01:06:12 pm »

Although this may be obvious to more experienced users, it took me a few hours to figure out what the problem was with my Linux (Vector Linux) configuration....

1. I've installed VL 4.0 following the instructions here:

2. This went onto /dev/hdb1 (slave drive on IDE 1); Windows 95 exists on drive C: (master on IDE 1).

3. Lilo would not work because everytime I tried to configure lilo and to write it to the MBR it would not allow to boot either Windows95 or VL....... there was a seek error and lilo only output: "L 40 40 40 40 40 " (look here for details:

4. So, I ended up putting back the Windows95 boot routine to the MBR (which was there originally, before I added VL)

5. I used the floppy disk which I created using the procedure described in the VL4.0 setup page (link is above). This allowed me to book Win95 without floppy; or to boot to VL using floppy.

6. Everything was find until I needed to use internet (this morning).
a. upon looking closer I determined that "ifconfig" command (run as "root") would only provide information on "lo", but there was no "eth0" (which is why I could not connect to internet through my LinkSys router and DSL cable modem). Next question was - why it not it there.

b. next step was determining that the proceduer described above (#5), during booting there were multiple errors of this kind "modprobe: can't open dependencies file".

c. by using "uname -a" command I determined that the version of kernel running was 2.4.21 which is why "modprobe" and "insmod" would (both, during root routine and when accessed in window environment) were complaining that they could not find the dependency file "lib/modules/4.2.21/modules.dep". In reality, the path to "modules.dep" in my setup is "lib/modules/4.2.22/modules.dep". Manually changing the folder name 4.2.22 > 4.2.21 did no good since modprobe would complain that the modules did not match the kernel version.

d. it was at this point that I was able to determine that kernel version running conflicted with the actuall installation. Google didn't help much with this as the only posts on the this subject seemed to suggest that "installation was incorrect" or that "compilation errors" took place in case of making a custom kernel. My installation was not custom at all.

e. finally - what worked - a new formatted (fdformat /dev/fd0) and unmounted (umount /dev/fd0) floppy was used to create a new bootup disk (sbin/makebootdisk). The one I chose to make was the LILO version and pointed it to /boot/vmlinuz ( Also note that different verions of Linux use differ in "makebootdisk" vs "mkbootdisk"

f. rebooting the system and using this new floppy boot disk INSTEAD of the boot disk created during installation process (using the procedure and package linked to above) resolved all the incompatibility problems between the kernel version and the modules which it was looking for during at boot time.

Conclusion: do not try to use the floppy book disk created during installation of VL 4.0 (and perhaps other versions of Linux / VL) to boot the system. Rather, make a new floppy boot disk after the system is working on its own. Perhaps something along these lines (mismatched kernel versions) should find its way into the VL4.0 installation page.

Hope this helps someone....