April 21, 2015, 10:37:02 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: Terrible wireless trouble  (Read 1990 times)
Posts: 2

« on: June 18, 2007, 12:59:43 pm »


I'm pretty new to linux and I'm having a terrible time getting vector to recognize my dwl-g650 pcmcia wireless card on an IBM 600x. I've followed all the wireless information I've been able to find in the forms. Is there any other place I can look for help on getting things up and running.

I have no other network card in the system. When I install Vector it doesn't detect the card at all. If I run hardware setup from VASM as root in a terminal once Vector is installed, the card is identified correctly and assigned to 'eth0'. That's the only card listed in any of the .conf files. The wireless indicator seems to think it's 'ath0', however. If I setup the system to recognize either 'eth0' or ath0' neither card is recognized. If I scan for an essid, the lights begin to flash on the card but no signal is detected.

I've been hunting th enet and reading everything I've found related to Vector and wireless setup, but nothing has worked for may. Any suggestions or help would really be appreciated. Thanks.
Posts: 1868

« Reply #1 on: June 18, 2007, 01:30:47 pm »

Google slackware dgl-g650:


Posts: 2

« Reply #2 on: June 18, 2007, 08:59:38 pm »

That's great! Thanks for the reply. I'll read through everything there and replay back as to how things go.
Posts: 302

« Reply #3 on: June 19, 2007, 08:38:57 am »

Is there any other place I can look for help on getting things up and running.
If you haven't already, read Eauster's HOW TO on the topic

Follow it step by step and when it doesn't work (you won't get it right off ) do it again! it took me several attempts to get wireless going and I think most people have difficulty the first time through.

If I run hardware setup from VASM.......
Don't bother for some reason VASM does not seem to be very good at setting up wireless in my experience. Stick to the command line tools in Eauster's HOW TO.

If I setup the system to recognize either 'eth0' or ath0' neither card is recognized
'eth0' is ethernet 0. I'm not sure what ,'ath0' is but you need to connect to a Wireless Local Area Network or 'wlan0'. Eauster's HOW TO will explain what files need to be altered to get this to appear.

If you can't get the card to be properly recognized you may need to use 'ndiswrapper'. Basically this allows you to use a card which has no native Linux driver. You do this by inserting the proper Windows driver (from the CD that came with your card) in a wrapper that allows the driver to function in Linux. Again this is in the HOW TO. You may not require this.

The only thing not in the how to is how to set up your system to start your wireless on startup. But you may or may not want to do that.

Ask questions when you need to and some one will answer in a way that hits home.
Keep at it and you will eventually get it.

<edit> 'ath0' is sometimes required by cards with an athereos chip. Mine has this chip but 'wlan0' works fine.
« Last Edit: June 19, 2007, 01:52:55 pm by InTheWoods » Logged
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!